Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


View this topic in a long page with up to 500 replies per page Create new topic
1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10


740 posts

Ultimate Geek


  # 1051262 22-May-2014 18:32
Send private message

Goodoo Farcus, thanks for the suggestions. Will investigate - if it works for you it'll have to work here eventually.
Presume it is OK.  The red light comes on and it once did something on the pi.

Will check Input Device settings and have a smartphone too, so will try that as well.

Haven't updated anything. Unless it does it automatically. It's always connected.

1014 posts

Uber Geek


  # 1051451 22-May-2014 23:22
Send private message


Haven't updated anything. Unless it does it automatically. It's always connected.


You were going to disable the automatic updates, remember.
To update to gotham turn automatic updates on again and then reboot (but I'd recommend holding out until the next raspbmc update - which is imminent - to get a few of the gotham bug fixes specific to raspbmc)

 
 
 
 




740 posts

Ultimate Geek


  # 1068592 18-Jun-2014 15:48
Send private message

Hi Facus, you mentioned a few messages back

One more tip - if you are in the habit of shutting down your pi it could be an idea to turn off automatic updates from raspbmc because the updates occur when you boot and you get no warning - so youu could be sitting down to watch some telly and an update begins that will lock you out of the pi for 20 mins or so.

Had something like this happen the other night , we're in the middle of watching something and it just started updating. Spent hours looking for the setting (which I thought I'd set previously) but can't find it now. Can you tell me please ?

Did get the xbmx remote working on the mobile.  It's good..  but is there a description anywhere of what the various mobile screen icons do ?



1014 posts

Uber Geek


  # 1068655 18-Jun-2014 16:47
Send private message

ADKM:

Had something like this happen the other night , we're in the middle of watching something and it just started updating. Spent hours looking for the setting (which I thought I'd set previously) but can't find it now. Can you tell me please ?


are you using Raspbmc or Openelec?
It shouldn't be possible for Raspbmc to update in the middle of watching a movie because it only checks for updates on boot.
However, I think openelec might do what you describe.

If Raspbmc - to disable go into (if default Confluence skin) . . .
Programs > Addons > Raspbmc Settins > System Configuration

and uncheck "Keep Raspbmc Updated"

In Openelec the procedure is almost identical.

Did get the xbmx remote working on the mobile.  It's good..  but is there a description anywhere of what the various mobile screen icons do ?


which specific icons do you mean?
If you have the official xbmc android remote it should be pretty evident what each section of the remote does.
Is this the remote you have?
https://www.youtube.com/watch?feature=player_detailpage&v=nqt05xahzZI#t=433



740 posts

Ultimate Geek


  # 1068860 18-Jun-2014 20:51
Send private message

Hi farcus.

farcus:are you using Raspbmc or Openelec?


Well, I guess I should know but haven't a clue !

farcus: If Raspbmc - to disable go into (if default Confluence skin) . . .
Programs > Addons > Raspbmc Settins > System Configuration

and uncheck "Keep Raspbmc Updated"

In Openelec the procedure is almost identical.


I'll certainly try that but it's being right used.

which specific icons do you mean?


The black & white screen with white blobs. LOL now I'm looking with a magnifying glass I can see some have descriptions

If you have the official xbmc android remote it should be pretty evident what each section of the remote does.
Is this the remote you have?
https://www.youtube.com/watch?feature=player_detailpage&v=nqt05xahzZI#t=433


Yes, that's it.  Wish I'd seen that first. It took me about a week to get and install the app.  (Never done it before). I can see now there's a lot I did not do. My version is 13.1 stable but "Git" is unknown.  Of the page of red buttons with white icons, only Remote control seemed to work.  Most tell me "NullPointer Exception" and the only option is Close.
Perhaps that will change after applying the setup described in your link.  What was interesting is the navigation from the phone did not bring up the OSD. I sense a remote would do the same if I knew how.  Had hoped to work though the keymapping precedures but had to give up.  The xbmx and rasp forums were no help.  Couldn't get the remote from TradeMe  to do anything  and its in the drawer for now, but the Panasonic one is working great.
That link also shows more tutorials and will have a look at each.  I've a lot to learn !

1014 posts

Uber Geek


  # 1068964 19-Jun-2014 03:43
Send private message

ADKM: Hi farcus.

farcus:are you using Raspbmc or Openelec?


Well, I guess I should know but haven't a clue !


when booting - Raspbmc will display a red R while openelec will display a kind of unfolding blue box with "openelec" displayed.

which specific icons do you mean?


The black & white screen with white blobs. LOL now I'm looking with a magnifying glass I can see some have descriptions


Yes, that is the navigation part of the remote
here's a larger image of the remote - that may be of some help
http://tinyurl.com/oeoovys


. . . My version is 13.1 stable but "Git" is unknown.  Of the page of red buttons with white icons, only Remote control seemed to work.  Most tell me "NullPointer Exception" and the only option is Close.
Perhaps that will change after applying the setup described in your link.  What was interesting is the navigation from the phone did not bring up the OSD. I sense a remote would do the same if I knew how.  Had hoped to work though the keymapping precedures but had to give up.  The xbmx and rasp forums were no help.  Couldn't get the remote from TradeMe  to do anything  and its in the drawer for now, but the Panasonic one is working great.
That link also shows more tutorials and will have a look at each.  I've a lot to learn !


don't worry about the "Git is unknown" part. It's not important and mine displays the same as yours.

The reason you get "NullPointer" is that you haven't set up a samba, nfs or some other kind of network share on your computer for watching TV, Movies or listening to music. If I remember correctly, you are using DLNA (UPnP) for streaming content - so these buttons will not work.

If you want to get these buttons working - and have xbmc scrape all the beautiful online fanart for each show/movie have a look at this tutorial
http://tinyurl.com/pl5v8tr

 

despite what the tutorial says - nfs shares are the best way to go but a lot of setups do not support this.
Personally, I use smb shares - because my nas drive doesn't support nfs.



740 posts

Ultimate Geek


  # 1069311 19-Jun-2014 16:09
Send private message

Hi Farcus,

It is the Raspbmc version.    We have a number of files which appear under VIDEOS-Files in the xbmc main horizontal menu.  They exist in folders on my PC.  I presume this is nfs?  I recall setting them up but not sure how this ties in with DLNA.  They are the same folders we can access via the TVs Vierra Tools Media-server.  That first shows Twonky then explores to the folders and files but that hasn't been used this since having xbmc.

I spent some time setting up everything on the mobile as per that link. I'm positive everything is correct but "NullPointer" is still showing and nothing works, except the remote control.  It's frustrating as I don't really know what to expect or what should do what.  In some ways I'm tempted to leave it alone and just use what does work.

While entering the password there was no way to exit the text entry box with the Panasonic remote. I had to power off to get out. But then tried again and found the other remote (that I said didn't work) would let me move a cursor and hit Enter.  It won't do other stuff though, like stop, play etc.


 
 
 
 


1014 posts

Uber Geek


  # 1069324 19-Jun-2014 16:22
Send private message

ADKM: Hi Farcus,

It is the Raspbmc version.    We have a number of files which appear under VIDEOS-Files in the xbmc main horizontal menu.  They exist in folders on my PC.  I presume this is nfs?  I recall setting them up but not sure how this ties in with DLNA.  They are the same folders we can access via the TVs Vierra Tools Media-server.  That first shows Twonky then explores to the folders and files but that hasn't been used this since having xbmc.


if it is on a windows pc then it is most likely either dlna or smb - depending on how you first navigated there to set it up.

I spent some time setting up everything on the mobile as per that link. I'm positive everything is correct but "NullPointer" is still showing and nothing works, except the remote control.  It's frustrating as I don't really know what to expect or what should do what.  In some ways I'm tempted to leave it alone and just use what does work.


this makes me think you most likely set up the share using DLNA
When you look at the home screen what do you see (entry options)

if you see

Weather | Pictures | Videos | Music | Programs | Systems

then you have probably set up using DLNA (or possibly smb but failed to designate as either movie or TV and have the scraper do its work)

if you see

Weather | Pictures | Videos | Movies | TV Shows | Music | Programs | System

then those buttons on the remote should work for you. If yur system is set up like this but they still don't work then it means that xbmc can't currently access those shares (perhaps because your computer is turned off).

If you can't see Movies | TV Shows try following the guide in the previous youtube link to add smb shares and have the tvdb scraper and moviedb scraper do their magic.

Before setting this up make sure you follow naming conventions for movies and TV shows correctly for it to work.

http://wiki.xbmc.org/index.php?title=Naming_video_files/Movies



740 posts

Ultimate Geek


  # 1069459 19-Jun-2014 18:08
Send private message

My home screen shows | Pictures | Videos | Music | Programs | Systems.

There's no weather, Movies or TV shows.  Which I see as options on the mobile.

All my files are under Videos\Files\MyStuff\TV\Movies .  (MyStuff\TV\Movies are in Win XP)

After viewing the link I see the files are added in a way I may not have done. And there's a whole protocol to filenames, structure, artwork etc. It makes sense until this is setup those other options on the mobile won't work.

LOL Now I don't know if I should try to change things, or keep it like it is (and we've got used to).  The existing file structure is used by other things, not just the pi.

But thanks for all the help and advice.   Those links are so informative.  The other skin he demoed with Artwork was pretty impressive, but I'm happy with just the list of names.

I'm keen  learn more on the remote.  Was it you who said you could jump ahead /back by entering mins/secs numbers on the remote ?
That, and navigating without OSD showing is would make my day  Then we wouldn't have to use the mobile for navigating and do everything from the one remote.   Hopefully one of the keys on the TV one can be  "Enter".

1014 posts

Uber Geek


  # 1069628 19-Jun-2014 23:39
Send private message

leave your current links in place
then go to

Video > file > add videos > browse > windows network (smb) > network name . . . . until you are at the folder with the videos
select OK
name the folder and select OK again
a window will pop up stating this directory contains
the choices are None, Movies, TV Shows, Music Videos
select the most applicable choice and OK
It will then ask if you want to scrape for content now . . . select Yes

You'll then get a new entry on your Home screen for either TV Shows or Movies
When you enter those all your TV shows or Movies will be displayed with appropriate artwork.
Remote shortcuts will also then work and also show the correct movie/TV artwork.



740 posts

Ultimate Geek


  # 1071228 20-Jun-2014 18:39
Send private message

Hi Farcus, Success!  We have artwork showing now and my wifes super pleased as it's a good reminder for what the program is/about.

No trouble following instructions, it all seems to come together very well.  I did end up with a Television and  Televison (2) but both seem to have the same contents.   And I see where some assumptions were made e.g. a folder called 'Documentary' it called 'KBS Documentary).  I presume I can edit these somehow?

Are additions/deletions made on the PC echoed into xmbc, or do you need to 'Scrape Again' ?  The whole lot or can you limit to a single file ?

Not sure what 'remote shortcut' you refered to ? Is that something to do with the remote control ?

Certainly adds a nice new dimension !  Thanks for the tip !  cool

1014 posts

Uber Geek


  # 1071247 20-Jun-2014 18:56
Send private message

ADKM: Hi Farcus, Success!  We have artwork showing now and my wifes super pleased as it's a good reminder for what the program is/about.

No trouble following instructions, it all seems to come together very well.  I did end up with a Television and  Televison (2) but both seem to have the same contents.   And I see where some assumptions were made e.g. a folder called 'Documentary' it called 'KBS Documentary).  I presume I can edit these somehow?

Are additions/deletions made on the PC echoed into xmbc, or do you need to 'Scrape Again' ?  The whole lot or can you limit to a single file ?


Certainly adds a nice new dimension !  Thanks for the tip !  cool


I think you have double content showing because you have the same share twice. Just delete one of them - probably the older one.

As for the Docu folder - I think there is some info about naming conventions in one of the video links that will tell you how to over come this.

What you delete on your computer isn't deleted automatically from your library.
From time to time just go into Settings > Video > Clean Library to fix this up.
I have mine set to update library on boot - but this only adds new content - it doesn't remove old/deleted content.

Not sure what 'remote shortcut' you refered to ? Is that something to do with the remote control ?


yes, the TV Show shortcut on the remote should take you to a screen on your phone that shows all the TV shows in your library.



740 posts

Ultimate Geek


  # 1071875 21-Jun-2014 21:00
Send private message

Still more questions Farcus, hope you don;t mind.

> yes, the TV Show shortcut on the remote should take you to a screen on your phone that shows all the TV shows in your library.

They do !  Impressive.  But if I try to play them on the phone you get a frozen picture. Continuing on, brings up Null Pointer again.

I'm OK on the naming conventions and will apply Settings > Video > Clean Library after more tidy ups. I haven't tried the scraper with Movies yet as I suspect I'll get a Movies (2) . After many hours trying I still could not delete Television (2).

The Arora browser suddenly installed itself today and  I had to power down to get out of it.  No remotes would do anything. Getting input devices working is the pis biggest downfall.  They don't market something that works reliably, do they ?  Even if a few £s...  be worth it.



740 posts

Ultimate Geek


  # 1071942 22-Jun-2014 03:13
Send private message

Hi Farcus

I've changed some filenames and have tried to "scrape" the revised list.  Sadly (hours later) I have Television(2) to Television(6) !!
But no new artwork can be seen.  I'm following your instructions

Video > file > add videos > browse > windows network (smb) > network name . . . . until you are at the folder with the videos
select OK
name the folder and select OK again
a window will pop up stating this directory contains
the choices are None, Movies, TV Shows, Music Videos
select the most applicable choice and OK
It will then ask if you want to scrape for content now . . . select Yes


I'm not getting those same results or the popup, or asked to scrape for content.  Following logically through as best I can
I click OK after selecting the TVDB and just get back to the List of Televison(x) with x growing with each new Add instance.

> From time to time just go into Settings > Video > Clean Library to fix this up.

I don''t seem to have this option available ??

Thanks for any help, ADKM

1014 posts

Uber Geek


  # 1071944 22-Jun-2014 07:07
Send private message

it's probably an idea to start again with your sources.

Go into Video > files

right click on each source and select remove source
It will probably then ask if you want to remove from /clean up the library - just choose yes.

then

go into system > video

I think in Gotham to see the option to clean library you have to change to advanced view. You should see on the left near the bottom it will say something like standard view (or something similar)
Just click on that to get advanced view

Re-add your video sources and scrape again.

I'd recommend staying away from the Arora browser. It can cause problems.



1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10
View this topic in a long page with up to 500 replies per page Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Disney+ streaming service confirmed launch in New Zealand
Posted 20-Aug-2019 09:29


Industry plan could create a billion dollar interactive games sector
Posted 19-Aug-2019 20:41


Personal cyber insurance a New Zealand first
Posted 19-Aug-2019 20:26


University of Waikato launches space for esports
Posted 19-Aug-2019 20:20


D-Link ANZ expands mydlink ecosystem with new mydlink Mini Wi-Fi Smart Plug
Posted 19-Aug-2019 20:14


Kiwi workers still falling victim to old cyber tricks
Posted 12-Aug-2019 20:47


Lightning Lab GovTech launches 2019 programme
Posted 12-Aug-2019 20:41


Epson launches portable laser projector
Posted 12-Aug-2019 20:27


Huawei launches new distributed HarmonyOS
Posted 12-Aug-2019 20:20


Lenovo introduces single-socket servers for edge and data-intensive workloads
Posted 9-Aug-2019 21:26


The Document Foundation announces LibreOffice 6.3
Posted 9-Aug-2019 16:57


Symantec sell enterprise security assets for US$ 10.7 billion to Broadcom
Posted 9-Aug-2019 16:43


Artificial tongue can distinguish whisky and identify counterfeits
Posted 8-Aug-2019 20:20


Toyota and Preferred Networks to develop service robots
Posted 8-Aug-2019 20:11


Vodafone introduces new Vodafone TV device
Posted 7-Aug-2019 17:16



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.