Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.
View this topic in a long page with up to 500 replies per page Create new topic
1 | 2 | 3 
1420 posts

Uber Geek
+1 received by user: 148


  Reply # 1035339 2-May-2014 11:09
Send private message

leo0787sx: Glad you got it sorted :)

Perhaps we can share setup and see if we can get the best out of the system :)

Sure!

I probably won't be able to put it together until Saturday afternoon.

I've got an Sony KDL-40CX520 TV, MagicTV 3600 PVR box, Wii, and Raspberyy Pi running RaspBMC for my movie collection.

1420 posts

Uber Geek
+1 received by user: 148


  Reply # 1036361 4-May-2014 11:21
Send private message

After plugging it all in I've found a problem: if the Raspberry Pi is plugged in when I'm watching TV then the TV reports a problem with the external audio (i.e. the home theatre) and switches to using the TV's built-in speakers.  Unplugging the Raspberry Pi's HDMI cable (either from the TV or the Pi itself) and the TV will output sound to the home theatre.  Somehow the Raspberry Pi is causing a problem for the TV, even if the Pi itself is turned off.

I've found someone talking about HDMI EDID Override but I don't know anything about this or even if it's possible to set up for the Pi.

Does anyone have any ideas?

What's weird is that yesterday I had it all working fine, with the Pi powered up and the audio was coming out the home theatre.

This is all set up with the home theatre plugged into the TV's HDMI ARC port.  I've also tried disabling the ARC and using a toslink cable but I couldn't get any sound out of that at all.



407 posts

Ultimate Geek
+1 received by user: 25


  Reply # 1036363 4-May-2014 11:26
Send private message

leo0787sx: For testing I am using the 5.1 test on the Hunger Games. My settings currently are:



TV:

Speakers: Audio system

Audio out: variable (also tried fixed)

HDMI audio source: HDMI audio

Digital audio out: Auto



Home Theater:

Bd audio mix: on

Audio drc: on

Attenuate audio: on

Audio output: speaker + hdmi

Sound effect: sound mode on

Control for hdmi: on

audio return channel: auto



PS3:

HDMi

Automatic

Multi output off

BD DVD output format HDMI: Bitstream



PS4:

Primary output: hdmi out

Audio format: linear PCM (also tried bitstream Dolby and bitstream dts)





Sky:

Audio output: stereo

Hdmi digital output: Dolby

Specific digital output: Dolby


These are my settings, not sure if it helps. I have everything HDMI into my TV then the Home Theater into the ARC HDMI, you need to make sure the HDMI cable from Home Theater to TV via ARC is audio return capable :)



407 posts

Ultimate Geek
+1 received by user: 25


  Reply # 1036366 4-May-2014 11:30
Send private message

Also both my TV and Home Theater have done two updates each, one each were today so make sure WiFi is setup and try an update :)

1420 posts

Uber Geek
+1 received by user: 148


  Reply # 1036368 4-May-2014 11:34
Send private message

leo0787sx: Also both my TV and Home Theater have done two updates each, one each were today so make sure WiFi is setup and try an update :)

Thanks.

My settings pretty much match yours (although I have no Playstations).  The home theatre updated its firmware yesterday and I've just tried the TV but it's on the latest.

What I find strange is that just having the Raspberry Pi's HDMI cable plugged in, but with the Pi off, the TV can still detect it and not like it.

More investigating is needed so I know how it all works I think!

1420 posts

Uber Geek
+1 received by user: 148


  Reply # 1036392 4-May-2014 12:32
Send private message

After some more experimenting I've found that with the Raspberry Pi turned on then the home theatre works fine on all inputs (TV, MagicTV box, Raspberry Pi) and I get sound out the home theatre's speakers.

Having the Raspberry Pi turned off but the HDMI cable between it and the TV plugged in at both ends then the TV complains about a fault in the external audio and reverts to using the TV's built-in speakers.

Unplugging the Raspberry Pi's HDMI cable (either from the TV or the Pi) allows everything to work.

So I guess the solution is to either have the Raspberry Pi running all the time, or only plug it in when I actually want to use it.

I don't understand HDMI well enough to know what's going on here.  Does anyone have an idea?

21124 posts

Uber Geek
+1 received by user: 4210

Trusted
Subscriber

  Reply # 1036403 4-May-2014 13:15
Send private message

I have seen issues with a powered down pi plugged into my TV, it kills most of the HDMI CEC control.




Richard rich.ms

1420 posts

Uber Geek
+1 received by user: 148


  Reply # 1036405 4-May-2014 13:17
Send private message

richms: I have seen issues with a powered down pi plugged into my TV, it kills most of the HDMI CEC control.

Thanks for the confirmation, looks like it might be something to do with the Raspberry Pi's HDMI port then.   It's as if the TV is seeing that the Raspberry Pi's HDMI cable is plugged in but because it doesn't get a reply from the Pi it's failing the audio.



407 posts

Ultimate Geek
+1 received by user: 25


  Reply # 1036413 4-May-2014 13:33
Send private message

Random but just tried some different region DVDs and it seems the blu ray system with the home Theater is DVD multi region :) I tried region 1, 2 and 4 :)

1420 posts

Uber Geek
+1 received by user: 148


  Reply # 1036414 4-May-2014 13:35
Send private message

leo0787sx: Random but just tried some different region DVDs and it seems the blu ray system with the home Theater is DVD multi region :) I tried region 1, 2 and 4 :)

I've found the same thing and thought it was strange that Sony should do this, but at least it saves trying to make it multi-region!

921 posts

Ultimate Geek
+1 received by user: 39


  Reply # 1036655 4-May-2014 22:28
Send private message

Sony has been shipping BD players multi-region for DVDs. Panasonics are shipped region locked but I've heard their service centres should unlock for free if you take it in and show your receipt within 1 year of purchase.

1420 posts

Uber Geek
+1 received by user: 148


  Reply # 1036901 5-May-2014 11:59
Send private message

After some research I've found out that the Raspberry Pi's do indeed have a known problem with interfering with HDMI CEC when powered off.  See http://www.raspberrypi.org/forums/viewtopic.php?f=35&t=14273 for lots of details.

The solution seems to be to remove D14 (a diode)from the Raspberry Pi.  In later hardware versions of the Pi this has apparently been removed.  I thought that I had the latest version when I bought it last year, but I'll have to check when I get home to see if it's there or not.

An alternative is to buy a CEC-less HDMI cable, or even a little dongle that fits onto the end of any HDMI cable and disables CEC.  I can't find these for sale anywhere in NZ, but you can get them from: http://www.pulse-eight.com/store/products/110-cec-less-hdmi-cable.aspx or http://www.lindy.co.uk/cables-adapters-c1/audio-video-c107/hdmi-c109/hdmi-cec-less-adapter-female-to-male-p7299  Bit pricey though.

2627 posts

Uber Geek
+1 received by user: 503


  Reply # 1036966 5-May-2014 12:52
Send private message

If you are brave and are prepared to DIY, then this might be of interest to you:
http://www.acryan.com/forums/viewtopic.php?t=5234

If you have some other HDMI cables you could try swapping them around - some people report that problem doesnt happen with some cables. Seems there are various revisions of HDMI - although it looks like version 1.0 had CEC support but some cables seem to have it disabled anyway - maybe they havent followed the standard properly.





Nothing is impossible for the man who doesn't have to do it himself - A. H. Weiler

1420 posts

Uber Geek
+1 received by user: 148


  Reply # 1036990 5-May-2014 13:35
Send private message

robjg63: If you are brave and are prepared to DIY, then this might be of interest to you:
http://www.acryan.com/forums/viewtopic.php?t=5234

If you have some other HDMI cables you could try swapping them around - some people report that problem doesnt happen with some cables. Seems there are various revisions of HDMI - although it looks like version 1.0 had CEC support but some cables seem to have it disabled anyway - maybe they havent followed the standard properly.


Thanks for your suggestions.

I'm not that keen on hacking up an HDMI cable, it seems pretty fiddly and I'm sure to make a hash of it.

I've got three cables and I've tried swapping them all without any luck, looks like they're all too new.

I'll check out the Pi when I get home and see if it has D14 on it or not.  If it does then removing it should be an easy job.



1420 posts

Uber Geek
+1 received by user: 148


  Reply # 1039279 8-May-2014 17:11
Send private message

An update:

Leaving the Raspberry Pi unplugged seems to allow everything to work ok (I've got a CEC-Less cable on order) but now I've found another problem.

While fast-forwarding through ads when watching a recording on my Magic TV PVR, when I've got through the ads and started the program playing at normal speed, all sound has been lost.  No sound from the Magic TV (either from a recording or live TV) or from the TV if I switch back to that.  Turning the home theatre off and on fixes the problem, but it takes 3 or 4 minutes for the home theatre to go from "STBY" on the screen until it actually turns off (normally this only takes a few seconds).

This has happened to me four times over the last two nights.  It doesn't happen every time I fast forward, maybe once in every four or five times.

Does anyone have any ideas?

1 | 2 | 3 
View this topic in a long page with up to 500 replies per page Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

N4L helping TAKA Trust bridge the digital divide for Lower Hutt students
Posted 18-Jun-2018 13:08


Winners Announced for 2018 CIO Awards
Posted 18-Jun-2018 13:03


Logitech Rally sets new standard for USB-connected video conference cameras
Posted 18-Jun-2018 09:27


Russell Stanners steps down as Vodafone NZ CEO
Posted 12-Jun-2018 09:13


Intergen recognised as 2018 Microsoft Country Partner of the Year for New Zealand
Posted 12-Jun-2018 08:00


Finalists Announced For Microsoft NZ Partner Awards
Posted 6-Jun-2018 15:12


Vocus Group and Vodafone announce joint venture to accelerate fibre innovation
Posted 5-Jun-2018 10:52


Kogan.com to launch Kogan Mobile in New Zealand
Posted 4-Jun-2018 14:34


Enable doubles fibre broadband speeds for its most popular wholesale service in Christchurch
Posted 2-Jun-2018 20:07


All or Nothing: New Zealand All Blacks arrives on Amazon Prime Video
Posted 2-Jun-2018 16:21


Innovation Grant, High Tech Awards and new USA office for Kiwi tech company SwipedOn
Posted 1-Jun-2018 20:54


Commerce Commission warns Apple for misleading consumers about their rights
Posted 30-May-2018 13:15


IBM leads Call for Code to use cloud, data, AI, blockchain for natural disaster relief
Posted 25-May-2018 14:12


New FUJIFILM X-T100 aims to do better job than smartphones
Posted 24-May-2018 20:17


Stuff takes 100% ownership of Stuff Fibre
Posted 24-May-2018 19:41



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.