Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




391 posts

Ultimate Geek


# 215370 24-Jun-2017 16:08
Send private message

Hi all,

 

I am not sure what happened or how - could have been an update or some other thing? - but all of the sudden I lost the capability to DELETE recorded tv. I can record just fine, everything works OK but when I try to delete a recorded tv show from MP interface, it is "thinking" for 3-4 seconds and then tells me that "could not delete this file". I have checked the folder properties and none of the files are marked "read only".

 

The problem is the HDD is filling up. I can use explorer and delete recorded shows but after that (as expected) they are still shown in the list of recorded tv. I have tried to update that list through the "import" function in the setup but it did not make any changes. Looking through the Recoded Tv folder with explorer, I even found very old recordings which MP would not show in the list.

 

Do I need to go through clean re-install of Media Portal? I believe there is a database file somewhere which if you delete, it will be created at next start-up as the system cannot work without it. Which file is this - and where is it located? It would be so much easier than going through all the settings for the various codecs, etc to get good picture.

 

The "videos" folder works OK, I can delete files and folders in there from MP interface - no errors at all. These two folders however, are located on two separate physical HDDs. There is no error from the HDDs, they are in good condition.

 

 

 

Any idea is much appreciated. The recorded tv list looks really messy after a couple of months of manually deleting files in there...

 

Thank you.





mobo Intel DH55PJ, RAM: 4GB RAM, Nova-T 500 HD + Avermedia Trinity tuner card, Geforce 520 video, 120GB SSD Sandisk + 640 WD + 1000SG, Win7 Home Prem 64-bit, Media Portal 1.15.0; BTC 9019URF Cordless Keyboard, Panasonic 55" (HDMI cable), HTPC Case Silverstone Grandia GD05B.


Create new topic
485 posts

Ultimate Geek


  # 1806219 24-Jun-2017 21:24
Send private message

Have you checked the logs for error messages?  Also, when MP has gone strange on me in the past, I have had to run a full check and repair on the database.  That is easy enough to do if you are using MySQL.




391 posts

Ultimate Geek


  # 1806332 25-Jun-2017 11:19
Send private message

yes... repairing of the database... this is what I am trying to do, I hope this will help.

 

I have tried this, but with no result:

 

https://www.team-mediaportal.com/wiki/display/MediaPortal1/Repairing+database+-+MySQL

 

Is there another way, please?

 

 

 

It says in the instructions that "mysqlcheck must be used when the mysqld server is running" but there is no service called mysqld running... I identified it in the MySQL folder and double -clicked it but nothing happened (it did not show up in the list of running services)...





mobo Intel DH55PJ, RAM: 4GB RAM, Nova-T 500 HD + Avermedia Trinity tuner card, Geforce 520 video, 120GB SSD Sandisk + 640 WD + 1000SG, Win7 Home Prem 64-bit, Media Portal 1.15.0; BTC 9019URF Cordless Keyboard, Panasonic 55" (HDMI cable), HTPC Case Silverstone Grandia GD05B.


 
 
 
 


4108 posts

Uber Geek

Lifetime subscriber

  # 1806340 25-Jun-2017 11:40
Send private message

I generally manually delete files using explorer then in the TVServer-Configuration go to Recording - Database Import and select "Remove invalid entries". Is that what you meant by the 'import' function?
I must admit I'm still running version 1.11. but it ain't broke, so I'm not fixing it.




Areas of Geek interest: Home Theatre, HTPC, Android Tablets & Phones, iProducts.

485 posts

Ultimate Geek


  # 1806644 25-Jun-2017 22:30
Send private message

It is possible to install MediaPortal to use other SQL servers than MySQL.  So if you did that, you would need to look up the instructions for doing a database repair for that software.

 

If you are using MySQL, then Windows Task Manager should show mysqld.exe in its Processes tab when MySQL is running.  On Win 7 from Start > Administrative Tools > Services you should find MySQL listed as a service and find out if its running status from there also.  From Windows Task Manager if you right click on the mysqld.exe entry and select "Open File Location", you will find the directory where your running version of MySQL is installed.  It may be a later version than the one in those instructions and be in a slightly different directory.  From a command prompt, go to that directory and run:

 

mysqlcheck mptvdb --auto-repair -e -u root -p

 

I do not know why the MediaPortal Wiki has screwed up the formatting of the command, but if you just cut and paste what is on that page it will not work properly.  You will need to enter the database password for the command to work - if you have not changed it it should be "MediaPortal" (case matters).


Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Chorus to launch Hyperfibre service
Posted 18-Nov-2019 15:00


Microsoft launches first Experience Center worldwide for Asia Pacific in Singapore
Posted 13-Nov-2019 13:08


Disney+ comes to LG Smart TVs
Posted 13-Nov-2019 12:55


Spark launches new wireless broadband "Unplan Metro"
Posted 11-Nov-2019 08:19


Malwarebytes overhauls flagship product with new UI, faster engine and lighter footprint
Posted 6-Nov-2019 11:48


CarbonClick launches into Digital Marketplaces
Posted 6-Nov-2019 11:42


Kordia offers Microsoft Azure Peering Service
Posted 6-Nov-2019 11:41


Spark 5G live on Auckland Harbour for Emirates Team New Zealand
Posted 4-Nov-2019 17:30


BNZ and Vodafone partner to boost NZ Tech for SME
Posted 31-Oct-2019 17:14


Nokia 7.2 available in New Zealand
Posted 31-Oct-2019 16:24


2talk launches Microsoft Teams Direct Routing product
Posted 29-Oct-2019 10:35


New Breast Cancer Foundation app puts power in Kiwi women's hands
Posted 25-Oct-2019 16:13


OPPO Reno2 Series lands, alongside hybrid noise-cancelling Wireless Headphones
Posted 24-Oct-2019 15:32


Waikato Data Scientists awarded $13 million from the Government
Posted 24-Oct-2019 15:27


D-Link launches Wave 2 Unified Access Points
Posted 24-Oct-2019 15:07



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.