Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




106 posts

Master Geek
+1 received by user: 35


Topic # 248101 10-Mar-2019 15:39
Send private message quote this post

Wondering if anyone can help diagnose an issue im having with Veon tv (65 inch 4k model) think I got it in May 2017. Basically over the last couple of months ive noticed the tv is having trouble responding to the remote. It got worse over the last couple weeks where it seems like its decided it wont even acknowledge when I press the off button. It still responds to some other inputs from the remote as well like I can access the settings but I cant move up or down nor can I confirm any change. Weirdly I can still change the volume up or down. I cant tell if its a failed or failing IR sensor or its the remote. Any thing I can do to try and confirm what the main cause of the issue is?


Create new topic
784 posts

Ultimate Geek
+1 received by user: 96

Trusted

  Reply # 2195125 10-Mar-2019 15:56
One person supports this post
Send private message quote this post

Wear and tear, oil from your fingers, possible hairline crack.
If some buttons work it wont be the sensor , LED etc.

45 posts

Geek
+1 received by user: 13


  Reply # 2195166 10-Mar-2019 17:15
Send private message quote this post

Yes all those previous posters tips will apply.

 

The symptoms sound exactly the same as what happened with my AKAI 50", and it's cheap generic remote. The problem with these remotes is that the programming with them is very nonstandard and if my theory is correct - specific to rebranding by either Tempo Australia,TWG Ltd or the controller board manufacturer which is known as MSTAR. So good luck using an "all for one" or other highend replacement universal remote, as they don't work or at least with my Akai. The warehouse sylvia park used to stock replacement remotes for these I have been told, but you'd want to go instore and find a knowledgeable staff member who has been around in the AV department long enough to know where to look. I had trouble finding anyone on the phone who could determine whether there were replacements in stock. There is an Australia based company which does exact replacement remotes for this model and Veon as well which can be found with a simple search in ecosia or your search engine of choice. They are about $60 or less from memory.

 

In my case I chose to repair the remote manually. Here is what worked for me, what didn't, and possibly why:

 

1) Opened the remote and cleaned all contacts with WD40. Bad idea as it turns out WD40 not only contains ISO alcohol but also a lubricating grease. Any type of oil will have a dielectric effect upon conductivity, thus resulting in intermittent contact between the electrically conductive coating on the rubber button pads and the PCB tracks which are bridged by the button.

 

2) Cleaned all contacts with Acetone, used a tin foil mini cake tin to bridge conductive button switch tracks on the PCB with the battery in (to isolate the button contact pads not conducting from the PCB tracks not conducting) when the Acetone had all evaporated, then used my multimeter on the IR LED output leads to check for pulsing of the voltage. Be very careful cleaning the rubber buttons with Acetone (never use ISO alcohol on these or WD40) as the rubber reacts to the chemical and shrinks slightly, so you will have trouble getting the rubber button overlay back into the remote evenly. Learn from my mistakes there. ;-) Soap and water is your best bet for the rubber button portion.

 

3) The infrared LED on mine was visibly weak when viewed on a CMOS sensor based digital camera, compared to other remotes with the same nominal operating voltage for the IR-LEDs, so I replaced the IR LED with a pulled 20 year-old japanese made one from a spare circuit board lying around. I had not thought an IR LED manufactured within the last 10 years would have failed but could not get the remote to transmit reliably further than about 2 metres from the TV so I had to figure this in as a possible fault causation. This restored the relative IR brightness to the same as my other working remotes.

 

4) Despite all the above several buttons still were not working so I tested the input lines from the remote controller chip with my multimeter once again on the IR LED output tracks from the control chip and found that a few of them were completely dead at the point where the surface mount chip (SMT) leads met the PCB.

 

On closer visual inspection I noticed that almost all of the SMT chip leads had what appeared to be dry joints (eg mottled dull grey appearance) and a tiny bit less solder than what would be needed for the ideal join if hand soldered rather than in a flow process solder bath as would be found in a large factory. I then proceeded to remove all the solder from the joints with a solder sucker but left two pads connected at diagonal ends of the chip to sink heat and keep a mechanical connection in place. After this I reflowed fresh lead based solder into the joints and wicked a few of them onto the PCB pads where the pad was showing signs of oxidative damage and deterioration, and also did this finally on the two remaining pads. I scraped some of the protective coating off the PCB on some of them to make the solder pad longer with more surface area also. After this I tested the output and all button contacts with tin foil again to bridge them and found the output was working perfectly. I then snapped the remotes plastic click-locks around the case back together again, and tested it upstairs on the TV and all was working again, from the other side of my lounge. Success finally.

 

So in my case it was a multi-systemic failure caused by a dying infrared LED and bad initial soldering in the factory of the controller chips joints most likely. I can't tell you all how much frustration and time it caused to fix this,but the feeling of success beat all the difficulty and "wasted time" along the way hands down. ;-) And before you ask - Yes I checked for fresh batteries numerous times before the self torture of this repair.

 

On another note I've been trying with no success to enter factory service mode on my "AKAI" AK50FDLED (warranty expired) to attempt to fix a different issue and also access the TV over the RS232 service port contained in the DB15 connector for the VGA in. According to my detailed research and inferred conclusions into MSTAR controller board - based rebadged AKAI Televisions as sold by the warehouse NZ, these won't enter RS232 (5 volt TTL) serial console mode without enabling the option in the service menu, which I can't access. I have tried probably about 20-30 possible codes and simply cannot get it to come up. Other than wasting time trying to build a brute-force factory mode infra-red code scanner to enter service mode I would really rather just buy anyone here a $25 box of beer, who can give me a code that works! PM me if you have one please, along with your contact details.

 

Also has anyone ever managed to find a working firmware update for this model or similar that didn't brick their TV? I haven't tried any yet, and as I found out when calling the useless warehouse tech support number when it was under warranty they simply refuse to give any out for updating using the USB port. Which leaves me with one last option - decompiling my TVs firmware which is another upcoming project. For anyone else interested in doing this on theirs I can furnish you with copious amounts of extra information privately, and save you time searching online. The CPU architecture is MIPS32 I believe, and they run a customized version of Linux on the MSTAR SOC as with so many other rebadged TVs by this Chinese company found around the world. The panel in my AKAI and probably most Veons seems to be Samsung from what I saw but I may be wrong. It's a very sharp image anyway.

 

One other thing. The noisy switchmode PSU board (which spews out a lot of RFI) in my model at least - had signs of serious overheating issues, and there was actually Scorch marks on the PCB around the Regulators and High wattage resistor leads, where smoke or some type of gaseous vapor had over time moved up the vertically mounted PCB towards the heat vents on the upper portion of the plastic case. Either the components are way outside the engineering specs tolerance levels, or the whole PSU is a bit too weak for the rest of the TV, which leads me to claim that some of these TVs represent an actual fire risk. In my case I just make sure I don't leave it on too long un-attended, but I'm considering either fitting a cooling fan to the back or else just buying a whole new PSU board. You've got to wonder if some of these products are even tested for fire regulation compliance at all before entering the market here... *Makes me wonder if that applies to certain brands of cellular basestation also.*


 
 
 
 


176 posts

Master Geek
+1 received by user: 29


  Reply # 2195167 10-Mar-2019 17:19
One person supports this post
Send private message quote this post

If you have a webcam or a digital camera you can see the transmit Led of the remote light up or flash as each remote button is pushed. If it doesn't light up on certain buttons only it is the remote at fault. Also I assume the batteries have been replaced. 


21912 posts

Uber Geek
+1 received by user: 4604

Trusted
Subscriber

  Reply # 2195169 10-Mar-2019 17:33
Send private message quote this post

My warehouse tv remote is one of the most sensitive to low battery I have had. Needs fresh alkalines to actually work well.





Richard rich.ms

685 posts

Ultimate Geek
+1 received by user: 171

Subscriber

  Reply # 2195184 10-Mar-2019 17:57
One person supports this post
Send private message quote this post

Every 3 to 4 months I have to take our Panasonic remote apart and give it a clean using isopropyl alcohol from Jaycar. Using a cotton bud I gently clean the carbon contacts on the back of the rubber touch pad plus a gentle wipe with the cotton bud on the circuit board.

 

As the dam remote is difficult to separate the two plastic half's I have damaged the sides a tad and will properly be up for a new remote this year from Trademe for $60.

 

Have you checked on Trademe for your remote? A quick search using; Veon tv remote yielded these results. I do not know how to identify Veon remotes but there is usually a product code somewhere on the back, try searching for that or the model number of the Veon TV.





iMac 27" (late 2013), Airport Time Capsule + Airport Express, iPhone7, iPad6, iPad Mini2

 

Panasonic Blu-ray PVR DMR-BWT835 + Panasonic Viera TH-L50E6Z, Chromecast Ultra




106 posts

Master Geek
+1 received by user: 35


  Reply # 2195584 11-Mar-2019 09:51
Send private message quote this post

Yea it ended up being the remote. I think the sensor in the remote must have come a bit loose somehow. Messed around with it a bit and got it going again. Will look at getting a new remote. cheers. 


45 posts

Geek
+1 received by user: 13


  Reply # 2195739 11-Mar-2019 11:48
Send private message quote this post

If you "fixed it" by wiggling the remote around, then it could be as simple as either cleaning the metal battery contact pads with fine grain sandpaper and some ISO alcohol or Acetone, or else there may be cracks in the circuit board which could be fixed with a simple bit of hookup wire soldered across the two points which need to be bridged again.

 

A simple test for deteriorated battery contacts is: Roll the AA batteries around in their axis of movement a few turns, and see if the remote works again. Sometimes the oxidation is very fine, but affects the voltage just enough to have the encoder chip fail momentarily.

 

Take it apart, inspect it, look at the solder joints to see if they look dull and slightly crystalline and cracked. If there's any suspect ones grab a soldering iron and just melt the solder then let it set while being careful not to move things. It could be as simple as 5 minutes of your time.


Create new topic


Donate via Givealittle


Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Amazon introduces new Kindle with adjustable front light
Posted 21-Mar-2019 20:14


A call from the companies providing internet access for the great majority of New Zealanders, to the companies with the greatest influence over social media content
Posted 19-Mar-2019 15:21


Two e-scooter companies selected for Wellington trial
Posted 15-Mar-2019 17:33


GeForce GTX 1660 available now
Posted 15-Mar-2019 08:47


Artificial Intelligence to double the rate of innovation in New Zealand by 2021
Posted 13-Mar-2019 14:47


LG demonstrates smart home concepts at LG InnoFest
Posted 13-Mar-2019 14:45


New Zealanders buying more expensive smartphones
Posted 11-Mar-2019 09:52


2degrees Offers Amazon Prime Video to Broadband Customers
Posted 8-Mar-2019 14:10


D-Link ANZ launches D-Fend AC2600 Wi-Fi Router Protected by McAfee
Posted 7-Mar-2019 11:09


Slingshot commissions celebrities to design new modems
Posted 5-Mar-2019 08:58


Symantec Annual Threat Report reveals more ambitious, destructive and stealthy attacks
Posted 28-Feb-2019 10:14


FUJIFILM launches high performing X-T30
Posted 28-Feb-2019 09:40


Netflix is killing content piracy says research
Posted 28-Feb-2019 09:33


Trend Micro finds shifting threats require kiwis to rethink security priorities
Posted 28-Feb-2019 09:27


Mainfreight uses Spark IoT Asset Tracking service
Posted 28-Feb-2019 09:25



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.