Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


mentor

99 posts

Master Geek

Lifetime subscriber

#60761 2-May-2010 20:56
Send private message

Hi all, first off thank you to everyone involved for the wealth of info and special thanks to forum members who have taken time to compile all this info in one place.

I've been trying to get my jaycar reader working with NewCS and need some help on this. 

MySetup:
- Win7 x64 (X2 5000+ / Core 2 Duo)
- Jaycar reader with Diode Mod and Inverse Mod
- Jaycar reader without any mods
- Sunix Serial PCI card
- USB to Serial (FTDI chipset) 
- Sun VirtualBox with ClearOS

I have built 2 readers, one with the two mods described above and one without. Both the builds have been tested using a magnifying lens to ensure correct resistor values including tests with a multimeter before and after soldering.

Issue: 

Both the readers seem to work the first time (First test after the build). i can get the keys off NewCS (1.65 on Core2 and 1.67RC1 on X2 w/ ClearOS). Once I removed the card and inserted it again, NewCS doesn't seem to work. Also the yellow LED is not fully bright. At this point all I get is "rest failed" messages. If I disconnect power (tested with 12 V plug pack and internal PSU power), insert the card first and then apply power, the yellow LED is bright and now instead of "reset failed" messages, I get "Card 0900 on Com1 failed".

My card is recent myS*yHdi NZ45XX. I have tried pulling the card out by 1mm but no luck there. As stated above, the reader worked out of the box the first time. I'm out of ideas.

Questions:

- Has anyone experienced this before. Working the first time and not again?
- Does your yellow LED on the reader changes intensity when you pull out and re-insert the card?
- Any suggestions you might have which could help me resolve my issue. Thanks for reading.
 

Create new topic
mentor

99 posts

Master Geek

Lifetime subscriber

  #329941 13-May-2010 22:15
Send private message

bump..anyone?

RustyGonad
495 posts

Ultimate Geek

Trusted

  #329961 13-May-2010 23:15
Send private message

NewCS likes to lock the serial port after being shutdown.

This prevents itself and any other app from getting access to the serial port.

You can fix it by either disabling/re-enabling the serial port after every restart or by rebooting every time you take the card out.

If you need to remove the card power down before you reinsert it. This will reset both the Jaycar reader and the serial port.


 
 
 
 


mentor

99 posts

Master Geek

Lifetime subscriber

#335947 28-May-2010 21:06
Send private message

Thanks Rusty.

I finally managed to get it to work. The issue was with the usb-> serial cable and the Sunix PCI serial card. I got hold of a DSE usb-> serial and I can confirm everything works on a Win7 x64 using NewCS 1.65 and 1.67 RC1 on a linux VM.

 

mentor

99 posts

Master Geek

Lifetime subscriber

  #338376 4-Jun-2010 20:47
Send private message

Hi all, a little embarrassed to admit this but the issue was with the serial cable. I had bought one off trademe for $4 and later when tried a "decent" cable, did not need the usb->serial adapter. In case any of you are having issues with your readers, make sure you test your cable first Embarassed

Create new topic




News »

Amazon introduces new Echo devices
Posted 25-Sep-2020 11:56


Mad Catz introduces new S.T.R.I.K.E. 13 Mechanical Gaming Keyboard
Posted 25-Sep-2020 11:34


Vodafone NZ upgrades international submarine network
Posted 25-Sep-2020 09:09


Jabra announces wireless noise-cancelling airbuds, upgrade existing model
Posted 24-Sep-2020 14:43


Nokia 3.4 to be available in New Zealand
Posted 24-Sep-2020 14:34


HP announces new HP ENVY laptops aimed at content creators
Posted 24-Sep-2020 14:02


Logitech introduce MX Anywhere 3
Posted 21-Sep-2020 21:17


Countdown unveils contactless shopping with new Scan&Go tech
Posted 21-Sep-2020 09:48


HP unveils new innovations for businesses adapting to rapidly evolving workstyles and workforces
Posted 17-Sep-2020 15:36


GoPro launches new HERO9 Black camera
Posted 17-Sep-2020 09:45


Telecommunications industry launches new 5G Facts website
Posted 17-Sep-2020 07:56


New Zealand ranks 3rd in world in GSMA index
Posted 15-Sep-2020 10:13


Trend Micro Security Suite adds web monitoring to prevent identity theft
Posted 14-Sep-2020 15:37


NVIDIA to acquire Arm for US$ 40 billion
Posted 14-Sep-2020 12:27


Epson launches its next gen A3+ colour EcoTank multi-function printer
Posted 10-Sep-2020 16:08



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.