Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


437 posts

Ultimate Geek
+1 received by user: 7

Trusted

Topic # 7329 6-Apr-2006 18:26
Send private message

TVersity apparently requires that the computer be on-line with a broadband connection. I wanted to set it up on a laptop hooked to the TV, but it wouldn't start without connecting to the web server. I hooked up a dial-up connection, but after initializing connection to the server it fails.

Both TVersity and the DLink software will work on another computer, but will not on the set-up I want to use. Firewalls off, player and computer seem to communicate but can't find media server, etc.


By: Laszlo, 6-APR-2006 15:50 (DD/MM/YY)


---------------------------------------------------------------------------------


No not at all.

TVersity is a server running on your pc and you dont need a internet connection - your laptop and your the dsm320 need to be on the same network ie the dsm320 is just like a pc it needs a ip address or dchp, firewall access etc. check your dsm320 network setup.

see the tversity forums

2.1. My Media Hub does not detect the Tversity Media Server

^

Try the following possible solutions in the order they are listed until the problem is solved:

  • Make sure the TVersity Media Server is running i.e. the Windows service that corresponds to it, is started. The easiest way to do it is to go to the start menu and choose "TVersity Tools -> Start TVersity Media Server" option from the TVersity menu. This should open a black window in which the progress of the starting operation will be displayed. If it starts successfully then you most likely have solved your problem. If it says that the server was already running please check the other possible solutions below. If starting the service seems to fail please refer to the next question in this FAQ which deals with problems in getting the media server to start as a service.
  • Make sure that the Windows Firewall (and any other personal firewall installed on your computer) does not block the media server from accpeting incoming connections. This is a very common problem so please take the time to check this issue. You will need to make sure that the executable MediaServer.exe located under the installation folder of the software (c:\Program Files\TVersity\Media Server by default) is allowed to accept incoming connections on port 41952 (it is not necessary to specify the port on most personal firewalls).
  • Make sure you are not runnung two or more instances of the software on some computers in your home network. This is currently not supported , i.e. there should be only one copy of the software running on your network. TIP: If your content is located on multiple computers, you can use the TVersity Media Server to share content on network drives as long as you follow the instructions here.
  • Some media hubs do not allow you to choose which media server to use and therefore you first need to terminate the media server you were using before and only then will the media hub be able to identify the TVersity Media Server, please make sure no other media server software is running.
  • Make sure that no other program is listening on port 41952 (this is the port used by the TVersity Media Server). Currently it is not possible to configure a different port, but this will be possible in future versions.
  • If the computer running the media server has more than one network interface, you need to make sure that the the TCP binding order on your machine is such that the network interface on which it is supposed to communicate with the media hub appears first. Here is how to do that:
    • Goto to the Windows Start menu and slect Setting / Network Connections (alternatively open the Network Connections icon from the Windows control panel). This should open a window titled Network Connections.
    • In this window go to the main menu and select Advanced / Advanced Settings. This should open a window titled Advanced Settings.
    • In this window make sure the Adapters and Bindings tab is selected. Inside this tab under Connections change the order of the network interfaces such that the one you need is first and then click OK.
    • Now restart the media server and check if the problem is solved.
  • Make sure your router allows multicast traffic and allows UPNP. Some routers block certain types of multicast traffuic or UPNP traffic over a wireles connection even when they are configured not to do so, therefore try using a wired connection (at least for testing purposes) and see if it helps.
  • Frequent disconnections in your home network could cause errors with some media hubs from which they cannot recover without a reboot. Try rebooting your media hub (or shutting it off and then turning it back on) and see if the problem persists
  • Try putting the media hub in media server search mode and then restart the TVersity Media Server from the Windows start menu or from the GUI.
  • Try to reboot your computer and your router.

 






"The only way to learn some- thing is to do it"

Create new topic
5 posts

Wannabe Geek


  Reply # 32467 7-Apr-2006 02:35
Send private message

When I try to start the server, I get the black box you mention, but then I get an error saying the
service could not be started. You direct me to this link to address the 'service won't start issue, but I can't find anything there that even mentions the problem:
http://www.geekzone.co.nz/#cant-start-service
What "next question" are you referring to?

When I use the computer with a broadband connection, TVersity fires right up. On the unconnected computer, if I open the media server desktop link, it tells me my browser is unable to link to the page I requested. If I use the Start menu link, the program starts, but if I try to access anything, it tells me 'Error, Unable to connect to the server, please make sure it is running."

On another screen, it tells me the TVersity service cannot start up and tells me to reboot. But when I reboot, I go back through the same error sequences. I uninstalled and reinstalled it, and I tried debugging it, as mentioned in the FAQ, but after fifteen minutes with no response I gave up.

*sigh*

5 posts

Wannabe Geek


  Reply # 32471 7-Apr-2006 03:53
Send private message

I think I figured out the problem with "next question" link -- it is meant to go to the tversity faq, but the link is broken..

The tversity FAQ tells me to debug the server, as I had tried. Then:

"If no errors are displayed and you do not get back to the command prompt it means that you successfully started the media server as an application. This means that there are some problems with the way the Windows service that corresponds to the TVersity Media Server is configured on your computer. Please try again to uninstall all previous version and re-install the latest, this should fix the problem."

No errors are coming up. So I uninstall -- I had no previous version -- and re-install, but it does not fix the problem, and they include no further instructions.

Heaven help me I'm back to trying to get the crippled D-Link software to work. Maybe I'll call a service rep and have them tell me there is nothing they can do. Again.



437 posts

Ultimate Geek
+1 received by user: 7

Trusted

  Reply # 32495 7-Apr-2006 13:00
Send private message

Yeah sorry about that I cut and pasted. Have a read below I suggest you have a read of the forums over at tversity as we are a freindly lot here on geekzone and we like to help and will help but Im just repeating the info from over there.

It sounds if you have network errors or firewall errors as it connects when you have a broadband connection.  What is your network you have ie pc => D-link 504 ADSL Modem => or netgear ??? router => Alcatel adsl usb modem etc Wireless or cable etc

FAQ

The FAQ and the support forums on tversity are excellent and this dsm320 is well supported.

I think I had a few issues getting to go as I had firewall issues with Zone Alarm.

if you go Ctrl Alt Delt => task manager => process you should see media server running

If so and the dsm320 is seen on your network and your pc and the dsm 320 are talking to each other.

then you need to share the content on your drive. Under programs you will see tversity tools =>MShare "c:\music etc etc " and Mshare -R to refresh content - I find this easyier than the GUI.

see this below I had to do this.

2.3. While I successfully add content located on network drives to my shares (using the MShare utility), I cannot play it on my media hub instead when I try to play something the media hub either gives an error message or just scrolls from one file to another without ever playing anything

^

The TVersity Media Server will not be able to access content on the network unless the Windows service that corresponds to it has a log-on account of an administrative user of your choice. By Default the TVersity Media Server is installed such that it uses the system account. This account is very limited when it comes to networking and therefore it is necessary to modify it to a different account that is not limited in that respect. You can use your own account or if you prefer you can set-up a separate account for the media server. Here are the steps involved in changing the log-on account on Windows XP/2K:

  • Go to the Start menu / Settings / Control Panel. The control panel window should open.
  • Double click the Administrative Tools icon. The administrative tools window should be displayed.
  • Double click the Services icon from this window. The Services window should open.
  • Locate the TVersityMediaServer in the list of service and double click on it. A properties window should open. Select the Log On tab at the top of the property window. The Log On options should be displayed.
  • In this window, the Local System Account should appear as selected, and you should change it to This account. Enter your user name (or the user name of the account you wish the TVersity Media Server to use) in the text box next to the This Account label. Enter your password and confirm it and the click OK. This should close the properties window and the Services windows should now be visible again.
  • In the service window, make sure the TVersityMediaServer is still selected and click the underlined Restart (or if not available click the Start) on the top left corner of this window. This should restart the server using the newly entered account. If no error occurs you have successfully completed the process.
  • If some error occured please repeat the entire process and make sure you follow each step carefully.
Also, avoid using mapped network drives since these become available only upon log in and therefore are not visible to services. Instead use a full path starting with two slash characters on Windows, followed by the name of the computer on which the media resides, followed by another slash character and then followed by the name of the shared folder (and optionally also a path under this folder).





"The only way to learn some- thing is to do it"

5 posts

Wannabe Geek


  Reply # 32606 9-Apr-2006 07:56
Send private message

I pursued this issue through the TVersity forum here:
http://forums.tversity.com/viewtopic.php?t=1357

I sent in the log that they requested just now.





437 posts

Ultimate Geek
+1 received by user: 7

Trusted

  Reply # 32611 9-Apr-2006 08:52
Send private message

Thats great as you have ronenmiz Site Admin looking at at. On a standard install of XP the media server installation and running just works. On your pc something has been changed, added removed or there is a conflict somewhere. Turn off all firewalls, popup blockers, spy tools, antivurus have you any beta software running, have you turned off any Windows (NT/2000/XP) services.

I use a programe called Service Controller XP 2.2.61

Last week I unistalled and reinstalled the tversity software and the dlink 320 software a couple times under windows xp service pack 2 no worries the software runs ok undwer xp.

I will keep a eye on your tversity forum post.




"The only way to learn some- thing is to do it"

5 posts

Wannabe Geek


  Reply # 32613 9-Apr-2006 09:19
Send private message

I've tried what he instructed, but it hasn't solved the problem.

On the computer that will run the D-Link software, the firewall, anti-virus, and spy sweepers are all on. Very inconvenient to use that computer, but looks like it will be the only way I can use the player (which makes the player not very useful). On the computer I'm trying to hook-up, everything is off, yet something is still keeping it from communicating with the player.

Two evenings and an afternoon lost, and still, No Server Found.

*sigh*



437 posts

Ultimate Geek
+1 received by user: 7

Trusted

  Reply # 32614 9-Apr-2006 09:27
Send private message

Yep as you said it runs on machine and not the other - so theres a issue on this machine.  You dont really want to reinstall xp again it will be something is conflicting - Are you running XP Service Pack 2?  Are your wireless or a wired connection

On the computer I'm trying to hook-up, everything is off, yet something is still keeping it from communicating with the player.


The above suggests the media server is running now but the dsm320  cant see it - if thats correct its a wired or wireless, network issues, firewall etc.




"The only way to learn some- thing is to do it"

5 posts

Wannabe Geek


  Reply # 32616 9-Apr-2006 09:49
Send private message

No, the server is not starting correctly, as described here:
http://forums.tversity.com/viewtopic.php?t=1357

When I run the debug, the server will run, but then cannot be found.

The connection is wired. Not sure whether service pack 2 is installed because a new hard drive was recently put into the machine.

I've sent more info to Ronen, but I'm running out of time to work on it today.

Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Microsoft Dynamics 365 Business Central launches
Posted 10-Jul-2018 10:40


Spark completes first milestone in voice platform upgrade
Posted 10-Jul-2018 09:36


Microsoft ices heated developers
Posted 6-Jul-2018 20:16


PB Technologies charged for its extended warranties and warned for bait advertising
Posted 3-Jul-2018 15:45


Almost 20,000 people claim credits from Spark
Posted 29-Jun-2018 10:40


Cove sells NZ's first insurance policy via chatbot
Posted 25-Jun-2018 10:04


N4L helping TAKA Trust bridge the digital divide for Lower Hutt students
Posted 18-Jun-2018 13:08


Winners Announced for 2018 CIO Awards
Posted 18-Jun-2018 13:03


Logitech Rally sets new standard for USB-connected video conference cameras
Posted 18-Jun-2018 09:27


Russell Stanners steps down as Vodafone NZ CEO
Posted 12-Jun-2018 09:13


Intergen recognised as 2018 Microsoft Country Partner of the Year for New Zealand
Posted 12-Jun-2018 08:00


Finalists Announced For Microsoft NZ Partner Awards
Posted 6-Jun-2018 15:12


Vocus Group and Vodafone announce joint venture to accelerate fibre innovation
Posted 5-Jun-2018 10:52


Kogan.com to launch Kogan Mobile in New Zealand
Posted 4-Jun-2018 14:34


Enable doubles fibre broadband speeds for its most popular wholesale service in Christchurch
Posted 2-Jun-2018 20:07



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.