Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




302 posts

Ultimate Geek

Subscriber

# 214382 9-May-2017 09:27
Send private message

I've rebuilt 2 faulty SP4's into 1 - essentially swapping mainboard & SSD into another chassis. All good there, tricky but not impossible. 

 

Now though, I have a problem booting into Windows, & it's killing me. If I let it boot by itself, it'll end up with a black screen - except for once (!) when I got the login screen for about 1 minute before it went dark on me. So I know it's not a hardware issue, it's just Windows & UEFI combining to frustrate.

 

 

 

If I boot from USB recovery disk or into SP4 recovery, it acts as though it has no SSD, except for the Reset option that tells me my hard drive is locked, please unlock & try again. The recommended treatment for that is recboot commands, which I've tried repeatedly to no avail - /scanos always reports 0 Windows installations. I know it's lying to me, I've seen the login page. (Telling SP4's to stop lying is, unfortunately, ineffectual. Cortana isn't available from Recovery.)

 

 

 

Booting from regular Win10 USB install key shows no hard drive available. Diskpart lists only the USB key. 

 

 

 

I'm sure there's an answer - blindingly obvious, simple & elegant - but I haven't found it. Has anyone here been through this "drive is locked, unlock & try again" drama & found the solution that I'm searching for? 

 

 

 

FWIW - i5, 8GB, 256GB. Transplanted into chassis that previously held i5, 8GB, 128GB. 





Megabyte - so geek it megahertz


Create new topic
3336 posts

Uber Geek

Trusted
Lifetime subscriber

  # 1778268 9-May-2017 09:32
Send private message

Did you have bitlocker enabled before doing all this?

 

 


3336 posts

Uber Geek

Trusted
Lifetime subscriber

  # 1778273 9-May-2017 09:41
Send private message

Also can you boot off a linux USB drive to see if that can see the drive?  


 
 
 
 


634 posts

Ultimate Geek

Subscriber

  # 1778289 9-May-2017 10:18
Send private message

I never had the "unlock and try again" issue so can't offer any help there, but I do remember having major issues when re-installing Windows from USB that went away after downloading the specific recovery image for my SP4 from MS - https://www.microsoft.com/surface/en-nz/support/warranty-service-and-recovery/downloadablerecoveryimage

 

Using our corporate Win10 Enterprise image or a Win10 Pro image (downloaded via the MS Media creation tool) just wouldn't work no matter what I tried.




302 posts

Ultimate Geek

Subscriber

  # 1778863 10-May-2017 03:46
Send private message

Oh yeah, I tried all the obvious solutions before I posted here. Parted Magic 2017 is the Linux option I tried, & I also used a Win10 PE built in WinBuilder also.

There's some discussion online about NVMe drivers provided by the Intel Rapid Storage Technology not being available for Linux kernels, so after Parted Magic had consumed my time/patience/energy for no good reason at all, I added the latest RST drivers to a WinBuilder iso, compiled that to USB & promptly failed again. *sigh*

Of course I've also tried the official Surface recovery USB (the one that downloads at snail's pace for 8 out of 9Gb before failing) too - same result. No SSD on display.




Megabyte - so geek it megahertz


Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Intel expands 10th Gen Intel Core Mobile processor family
Posted 23-Aug-2019 10:22


Digital innovation drives new investment provider
Posted 23-Aug-2019 08:29


Catalyst Cloud becomes a Kubernetes Certified Service Provider (KCSP)
Posted 23-Aug-2019 08:21


New AI legaltech product launched in New Zealand
Posted 21-Aug-2019 17:01


Yubico launches first Lightning-compatible security key, the YubiKey 5Ci
Posted 21-Aug-2019 16:46


Disney+ streaming service confirmed launch in New Zealand
Posted 20-Aug-2019 09:29


Industry plan could create a billion dollar interactive games sector
Posted 19-Aug-2019 20:41


Personal cyber insurance a New Zealand first
Posted 19-Aug-2019 20:26


University of Waikato launches space for esports
Posted 19-Aug-2019 20:20


D-Link ANZ expands mydlink ecosystem with new mydlink Mini Wi-Fi Smart Plug
Posted 19-Aug-2019 20:14


Kiwi workers still falling victim to old cyber tricks
Posted 12-Aug-2019 20:47


Lightning Lab GovTech launches 2019 programme
Posted 12-Aug-2019 20:41


Epson launches portable laser projector
Posted 12-Aug-2019 20:27


Huawei launches new distributed HarmonyOS
Posted 12-Aug-2019 20:20


Lenovo introduces single-socket servers for edge and data-intensive workloads
Posted 9-Aug-2019 21:26



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.