Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


2 posts

Wannabe Geek


Topic # 13870 2-Jun-2007 01:07
Send private message

I have a Creattive MP3 Zen player (1GB) . It was working quite well for long time. But I have a problem now..

While transfering mp3 from my PC to player...my Explorer was hanging. So I thought removing player from USB and connecting again will solve the problem.I just removed plyer from USB and connected again. But after that my PC didn't detect the player and it used to display "Unknown USB device". Even I am unable to switch on my player .  I went thruogh solutions in lot of forums.... and tried these options .

1)tried to reset . It didn't work
2)I tried to recharge connecting my player to my PC USB. I am able to see the blue light in play/return buttons -when I rub my hands on buttons. But even after charging for  more than a hour , I am unable to switch on and still the play/return button's lights on.

If anybody have a solution please help me.

Thanks a lot.

Create new topic
48 posts

Geek


  Reply # 73207 2-Jun-2007 09:13
Send private message

My daughter had one of these. It also froze early last year. Took it back to retailer (DSE) who sent it away for repair. The repaired unit turned out to be a brand new player.



2 posts

Wannabe Geek


  Reply # 73398 4-Jun-2007 20:29
Send private message

Atlast Now my mp3 player works.

I was trying all solutions as in Creative site..and lot of forums. Even after that it didn't work ... I got frustrated and took a large paper pin and hit the reset button with full force. To my surprise , It's switched on and started working fine.
But after this pin goes into reset button very deep... don't know whether it got damaged.

Anyway my player works now. First thing I did is Updated the firmware. Hope i will not get the problem in the future.

Creative didn't explain about the 'Reset' option in it's user manual. It would have helped in many instances as i had another froze in my player while viewing pictures last time...and restarted when battery is fully drained.

1677 posts

Uber Geek
+1 received by user: 7

Trusted

  Reply # 73411 4-Jun-2007 22:57
Send private message

yip, it's the same on the zen. The reset button is quite deep, nothing that a wall pin won't fix though. I've had to use it twice in the 8 months or so I have my Zen (Vision M)

1 post

Wannabe Geek


  Reply # 73727 7-Jun-2007 04:12
Send private message


I had this same problem.
It's likely a failed hard drive.  I didn't realize it ZEN devices dont' use flash drives, they use micro drives.
So if you drop them or use them jogging the drive gets wrecked.

A simple way to check
1.  Turn off the device
2.  Turn device on
3.  Put device next to ear and listen closely for a crunching or chirping sound

If you hear that then you're hard drive is dead and it needs to be replaced.

Check ourt www.zenrepair.com 


Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.