Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




234 posts

Master Geek
+1 received by user: 5


Topic # 131014 5-Oct-2013 12:46
Send private message

I recently upgraded to VDSL, replacing my old ADSL modem (half bridge mode) and Linksys BEFSX41 router with the Telecom provided Technicolor TG589vn v2. Everything went very well except that the Linksys Media Extenders will no longer connect to my Media Centre PC. 

I tried removing the Technicolor router from the network, and put the BEFSX41 back on and the extenders all happily reconnected.

I am at the end of my network knowledge, but it appears to me that the Technicolor is preventing the connection somehow: Maybe the intrusion detection which I cannot see how to disable? 

Any ideas? I tried to put the Technicolor in bridge mode but could not get it to work with my BEFSX41, however I would prefer to resolve this (if possible) without introducing additional equipment.



Filter this topic showing only the reply marked as answer View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2 | 3
Mad Scientist
19623 posts

Uber Geek
+1 received by user: 2604

Trusted
Lifetime subscriber

  Reply # 908426 5-Oct-2013 13:26
Send private message

I cant remote desktop my computers i wonder if this is related to your problem




Swype on iOS is detrimental to accurate typing. Apologies in advance.


458 posts

Ultimate Geek
+1 received by user: 131


  Reply # 908427 5-Oct-2013 13:32
Send private message

I'm guessing the extenders are using multicast to find the media centre and Technicolor's multicast settings are the problem

No guarantees this will work but you could try

1. Take a backup of your config.
2. Telnet to the Technicolor (user:Administrator blank password)
3. Try the following command

ip ifconfig intf=LocalNetwork mcastpromisc=enabled

4. if that works type "saveall" and you're done.
5. If it doesn't work either reboot or just repeat the command with disabled instead of enabled.



 
 
 
 


458 posts

Ultimate Geek
+1 received by user: 131


  Reply # 908442 5-Oct-2013 13:47
Send private message

hashbrown: I'm guessing the extenders are using multicast to find the media centre and Technicolor's multicast settings are the problem

No guarantees this will work but you could try

1. Take a backup of your config.
2. Telnet to the Technicolor (user:Administrator blank password)
3. Try the following command

ip ifconfig intf=LocalNetwork mcastpromisc=enabled

4. if that works type "saveall" and you're done.
5. If it doesn't work either reboot or just repeat the command with disabled instead of enabled.




If you are comfortable mucking around in the config via telnet some other stuff you could try the following.  You will need to do it for the ports you have your media centre and extenders plugged into (ethport1 = port 1 on the router)

Once again TAKE A BACKUP FIRST

eth bridge ifconfig intf ethport1 mcastfilter disabled igmpsnooping disabled



234 posts

Master Geek
+1 received by user: 5


  Reply # 908448 5-Oct-2013 14:08
Send private message

eth bridge ifconfig intf ethport1 mcastfilter disabled igmpsnooping disabled


Thanks for your replies. I entered the commands provided but there is no change.

The Extender says it can't find a network even though it has got its address settings from DHCP. I can ping the unit from the network. I have tried manually setting address settings including changing the default gateway to the Windows Media PC but the result is the same - no connection.



234 posts

Master Geek
+1 received by user: 5


  Reply # 908449 5-Oct-2013 14:10
Send private message

joker97: I cant remote desktop my computers i wonder if this is related to your problem

Yes, I am sure it is as the Media Extenders are remote users. I noticed that I cannot make a remote connection either, but used to be able to. 



234 posts

Master Geek
+1 received by user: 5


  Reply # 908567 5-Oct-2013 18:25
Send private message

It isn't intrusion detection either. I tried disabling it :-

ids config state=disabled

I am assuming I don't need to reboot the router for any of these changes to take affect.

21823 posts

Uber Geek
+1 received by user: 4566

Trusted
Subscriber

  Reply # 908580 5-Oct-2013 18:57
Send private message

There is something wrong with the switches in these routers. I had to give a friend an old 100 meg 8 port switch to get their lan working again, their wired printer/scanner thing and a wired computer would not communicate with both plugged into the technicolor, whereas with a switch and then a single uplink to the router it all works perfectly.




Richard rich.ms



234 posts

Master Geek
+1 received by user: 5


  Reply # 908582 5-Oct-2013 19:03
Send private message

richms: There is something wrong with the switches in these routers. I had to give a friend an old 100 meg 8 port switch to get their lan working again, their wired printer/scanner thing and a wired computer would not communicate with both plugged into the technicolor, whereas with a switch and then a single uplink to the router it all works perfectly.


This is not the problem in my case, as I only use one port on my router. This is connected to a switch (Allied Telesis AT-GS900) which connects all devices. 

21823 posts

Uber Geek
+1 received by user: 4566

Trusted
Subscriber

  Reply # 908589 5-Oct-2013 19:39
Send private message

Wow, ok then its even worse than I thought!




Richard rich.ms

Mad Scientist
19623 posts

Uber Geek
+1 received by user: 2604

Trusted
Lifetime subscriber

  Reply # 908594 5-Oct-2013 20:13
Send private message

Hmm i wonder how to fix this i need remote desktop ...




Swype on iOS is detrimental to accurate typing. Apologies in advance.


8029 posts

Uber Geek
+1 received by user: 387

Trusted
Subscriber

  Reply # 908659 6-Oct-2013 01:42
Send private message

Well I just said it another thread but I'm gonna say it again.... these Technicolor/Thomson devices that Telecom supply are garbage they have a history of annoying issues like this, there are many of threads on geekzone ever since Telecom started using them several years ago. Everything from dns issues, nat issues with xbox live and ps3 network, dhcp issues, compatability with mac issues etc.

Most annoyingly the bugs are often fixed by the oem in later firmware yet the oem does not distribute their firmware updates directly because of the white label relationship with ISP's. The fixes never get to users.

I don't see how you can solve this without spending money I'm afraid. I've never seen Telecom distribute a firmware update for these supplied modems.

Bridging which is a good solution (get the Technicolor to be just a dumb modem and do as little as possible) but likely won't work for you because the BEFSX41 doesn't do vlan tagging.  Worse with the small size of the flash rom in that device there is no potential to flash it with open source third party firmware that does do vlan tagging. 

So either you need to replace the BEFSX41 or the Technicolor, suspect replacing the BEFSX41 is going to be cheaper.



234 posts

Master Geek
+1 received by user: 5


  Reply # 908673 6-Oct-2013 08:08
Send private message

Ragnor: Bridging which is a good solution (get the Technicolor to be just a dumb modem and do as little as possible) but likely won't work for you because the BEFSX41 doesn't do vlan tagging.  Worse with the small size of the flash rom in that device there is no potential to flash it with open source third party firmware that does do vlan tagging.


There was an option to disable VLANs on the Technicolor. Is this relevant with regard to bridging the BEFSX41?

Ragnor: So either you need to replace the BEFSX41 or the Technicolor, suspect replacing the BEFSX41 is going to be cheaper.


Would you recommend a router please? I bought the BEFSX1 a long time ago to get a VPN working. Many thanks for the reply - it is always reassuring to know that I am not going insane. I have spent many hours trying to resolve this. 



1345 posts

Uber Geek
+1 received by user: 313


  Reply # 908707 6-Oct-2013 10:21
Send private message

TG589Vn still does VLAN tagging when set up to run in bridge mode using the wizard.
As long as BEFSX41 can terminate PPPoE. (for your previous half-bridge mode setup it would have been on DHCP or something so make sure you've changed those settings)

Mad Scientist
19623 posts

Uber Geek
+1 received by user: 2604

Trusted
Lifetime subscriber

  Reply # 908722 6-Oct-2013 11:20
Send private message

Any suggestion for my remote desktop?




Swype on iOS is detrimental to accurate typing. Apologies in advance.


8029 posts

Uber Geek
+1 received by user: 387

Trusted
Subscriber

  Reply # 908765 6-Oct-2013 13:55
Send private message

yitz: TG589Vn still does VLAN tagging when set up to run in bridge mode using the wizard.
As long as BEFSX41 can terminate PPPoE. (for your previous half-bridge mode setup it would have been on DHCP or something so make sure you've changed those settings)


If this is correct it's just a matter of configuration in your Linksys, maybe try setting up bridging again first in the Technicolor then in the Linksys change the WAN/internet to PPPoE (instead of DHCP).

Telecom PPPoE settings:
Account Name: (leave blank)
Domain Name: (leave blank)
Internet IP Address - Select Get dynamically from ISP
DNS Server Address - Select Get Automatically from ISP
Login user@xtra.co.nz 
Password  abc123
Router MAC Address Use Default Address

Telecom pretty much ignores the login/password and does authentication so they can be anything iirc.

 1 | 2 | 3
Filter this topic showing only the reply marked as answer View this topic in a long page with up to 500 replies per page Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.