Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


View this topic in a long page with up to 500 replies per page Create new topic
1 | 2 


16 posts

Geek


  # 923749 29-Oct-2013 19:03
Send private message

Hi Guys

I have a Cisco SR520w-ADSL-K9 router and I cannot connect it to the internet and also I need to configure Wifi on it as well, please could someone help me.

I can ping my default-gateway, but cannot ping any other websites out there. I am receiving packets from my ISP so that is all setup, I cant assign IP addresses to my ethernets, so I will need to assign an IP on my vlan 1 and assign that to my ethernet port if somebody could help me with the commands for all this so I can learn.

Heres my current config:


Current configuration : 1963 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname (Username...)
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
logging buffered 4096
enable secret 5 $1$qnqr$8HiSGNN52LIokMezQBvW5.
!
no aaa new-model
!
!
dot11 syslog
ip source-route
!
!
!
ip dhcp pool inside
import all
network 192.168.1.0 255.255.255.0
default-router 192.168.1.254
dns-server 192.168.1.254 8.8.8.8
!
!
ip cef
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
username (username....) privilege 15 password 0 (Password...)
!
!
!
archive
log config
hidekeys
!
!
!
!
!
interface ATM0
no ip address
no atm ilmi-keepalive
bundle-enable
!
interface ATM0.1 point-to-point
description WAN via ADSL
ip nat inside
ip virtual-reassembly
pvc 0/100
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Dot11Radio0
no ip address
shutdown
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
!
interface Vlan1
ip address 192.168.1.254 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface Dialer0
ip address negotiated
ip nat outside
no ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname (Username....)
ppp chap password 0 (password...)
ppp pap sent-username (Username....) password 0 (password...)
ppp ipcp dns request
ppp ipcp route default
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
ip nat inside source list 1 interface Dialer0 overload
!
!
!
!
!
!
control-plane
!
!
line con 0
exec-timeout 5 0
password (password...)
login
no modem enable
line aux 0
line vty 0 4
exec-timeout 5 0
password (Password...)
login
!
scheduler max-task-time 5000
end

724 posts

Ultimate Geek

Trusted
Spark NZ

  # 923853 29-Oct-2013 22:21
Send private message

Again can you turn on some debug? Sorry I'm not cisco expert, but if I were looking at it I'd try and figure out if you're exchanging any PPP packets. So can you turn on PPP negotiation debug? I.e. debug ppp negotiation.
If you're sending, but getting nothing back, then I'd be looking at the ATM layer and port config on your WAN port.

Post some debug output here, and I'll take a look at it. As I say, I'm not a cisco guru though.




My views are my own, and may not necessarily represent those of my employer.


 
 
 
 


2092 posts

Uber Geek


  # 923858 29-Oct-2013 22:29
Send private message

ip nat inside source list 1 interface Dialer0 overload 

do you have an access-list 1?

sh ip access-lists please.

if not

access-list 1 permit 192.168.1.0 0.255.255.255

then also:

sh ip int brief

does your Dialer0 have an external IP associated?

sh ip route

Gateway of last resort is what to what?

ip route 0.0.0.0 0.0.0.0 Dialer0

you also don't need ip nat inside on ATM0.1 - it's not an IP interface.



16 posts

Geek


  # 924405 30-Oct-2013 20:33
Send private message

Hi thank you for your responses, I have removed the ip nat from the ATM0.1 interface, I am indeed getting a ip address from my dialer0 interface from the sh ip int br command. I have issued the ip route 0.0.0.0 0.0.0.0 dialer0 command and lastly created my access-list, however I am not able to ping my default gateway now and there is nothing in my routing table:

#sh ip route
Default gateway is not set

Host Gateway Last Use Total Uses Interface
ICMP redirect cache is empty

I think it may have to do with the nat overload command?

I am receiving the correct authentication from the debug ppp packets. This is really messy but will be please once Its figured out :)

2092 posts

Uber Geek


  # 924554 31-Oct-2013 08:38
Send private message

Can you post a full show run please?

that nat overload command is fine - I have it on mine.

You can do a sh ip nat translations to see if it is trying to do translations.

the default route bit is a bit odd - you have NO routes?

You should at least have your local network as direct attached, then 0.0.0.0/0 through Dialer0.

If you don't have a route to use Dialer0 your traffic won't go anywhere!



113 posts

Master Geek

Trusted
Spark NZ
Lifetime subscriber

  # 924696 31-Oct-2013 12:03
Send private message

Agree that the new default route should be there, config looks like mine as well.


you may want to;
change
   dns-server 192.168.1.254 8.8.8.8
to
   dns-server 202.27.158.40 202.27.156.72
from your DHCP configuration.


remove
  ppp chap hostname (Username....)
  ppp chap password 0 (password...)
from your dialer interface

the ACL 1 for nat should be -
   access-list 1 permit 192.168.1.0 0.0.0.255

and as well as a new running config - when you say you can't ping your gateway - do you mean your 192.168.1.254 router IP address from your PC ? you haven't got your old DSL router plugged into your LAN at the same time with same address ?




My comments and remarks are not necessarily of my employer.



16 posts

Geek


  # 926952 4-Nov-2013 12:56
Send private message

Hi Guys sorry been busy on the weekend

here is my latest config, still no 0.0.0.0 in routing table? I am able to ping my default gateway on router 192.168.1.254, but cannot ping anything outside of that eg 8.8.8.8. sh ip nat translations is showing nothing, i am receiving an p address from my ISP so no problems there.

sh run
Building configuration...

Current configuration : 2122 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname (name)
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
logging buffered 4096
enable secret 5 $1$qnqr$8HiSGNN52LIokMezQBvW5.
!
no aaa new-model
!
!
dot11 syslog
ip source-route
no ip routing
!
!
ip dhcp excluded-address 192.168.1.40 192.168.1.254
!
ip dhcp pool inside
import all
network 192.168.1.0 255.255.255.0
default-router 192.168.1.254
dns-server 192.168.1.254 8.8.8.8
!
!
no ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
username (name) privilege 15 password 0 (password)
!
!
!
archive
log config
hidekeys
!
!
!
!
!
interface ATM0
no ip address
no ip route-cache
no atm ilmi-keepalive
bundle-enable
!
interface ATM0.1 point-to-point
description WAN via ADSL
ip virtual-reassembly
no ip route-cache
pvc 0/100
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Dot11Radio0
no ip address
no ip route-cache
shutdown
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
!
interface Vlan1
ip address 192.168.1.254 255.255.255.0
ip nat inside
ip virtual-reassembly
no ip route-cache
!
interface Dialer0
ip address negotiated
ip nat outside
no ip virtual-reassembly
encapsulation ppp
no ip route-cache
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname (Name)
ppp chap password 0 (Password)
ppp pap sent-username (username) password 0 (Password)
ppp ipcp dns request
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
!
no ip http server
no ip http secure-server
ip nat inside source list 1 interface Dialer0 overload
!
access-list 1 permit 192.168.1.0 0.0.0.255
!
!
!
!
!
control-plane
!
!
line con 0
exec-timeout 5 0
password (password)
login
no modem enable
line aux 0
line vty 0 4
exec-timeout 5 0
password (password)
login

 
 
 
 


2092 posts

Uber Geek


  # 926959 4-Nov-2013 13:11
Send private message

So the first major red flag:
no ip routing

that would be bad. remove it. no wonder nothing is going anywhere!

Once that is removed, add in your ip route 0.0.0.0 Dialer0

That should get you up and running.

Second:
You don't want this line:
no ip cef

you want ip cef.

Third:
As has been said before, your clients are pointing to your router for DNS - which I don't believe it will be providing (if you do an nslookup and lookup google.com you will probably get no response), but you have 8.8.8.8 as a backup, but just add your ISP DNS in there.

You are getitng an IP, so your adsl and ppp must be ok.








16 posts

Geek


  # 927203 4-Nov-2013 19:48
Send private message

Hi wasabi2k

Thank you very much for the help much appreciated, it now works.

Now Ill try setup the wifi :)

I need to setup a password for my wifi and make my authentication type as WPA-2, then broadcast my SSID so it is hidden, and lastly is there anything else I need to make the configuration work via wifi and ADSL?

Thanks

2092 posts

Uber Geek


  # 927318 4-Nov-2013 23:01
Send private message

thats great news! huzzah!
can't help with the wifi sorry - no experience there. 

place to start: http://www.cisco.com/en/US/tech/tk722/tk809/technologies_configuration_example09186a0080c1e3ce.shtml

1 | 2 
View this topic in a long page with up to 500 replies per page Create new topic



Switch your broadband provider now - compare prices


Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Chorus to launch Hyperfibre service
Posted 18-Nov-2019 15:00


Microsoft launches first Experience Center worldwide for Asia Pacific in Singapore
Posted 13-Nov-2019 13:08


Disney+ comes to LG Smart TVs
Posted 13-Nov-2019 12:55


Spark launches new wireless broadband "Unplan Metro"
Posted 11-Nov-2019 08:19


Malwarebytes overhauls flagship product with new UI, faster engine and lighter footprint
Posted 6-Nov-2019 11:48


CarbonClick launches into Digital Marketplaces
Posted 6-Nov-2019 11:42


Kordia offers Microsoft Azure Peering Service
Posted 6-Nov-2019 11:41


Spark 5G live on Auckland Harbour for Emirates Team New Zealand
Posted 4-Nov-2019 17:30


BNZ and Vodafone partner to boost NZ Tech for SME
Posted 31-Oct-2019 17:14


Nokia 7.2 available in New Zealand
Posted 31-Oct-2019 16:24


2talk launches Microsoft Teams Direct Routing product
Posted 29-Oct-2019 10:35


New Breast Cancer Foundation app puts power in Kiwi women's hands
Posted 25-Oct-2019 16:13


OPPO Reno2 Series lands, alongside hybrid noise-cancelling Wireless Headphones
Posted 24-Oct-2019 15:32


Waikato Data Scientists awarded $13 million from the Government
Posted 24-Oct-2019 15:27


D-Link launches Wave 2 Unified Access Points
Posted 24-Oct-2019 15:07



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.