Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




1635 posts

Uber Geek
+1 received by user: 781


Topic # 178998 21-Aug-2015 21:45
Send private message

My internet connection has been giving me grief for quite some time now. It seems my connection to the Spark DNS servers falls over on a fairly regular basis. Restarting the modem or resetting DNS settings fixes it.

I don't think it's the modem for two reasons.
1) It's happened on two modems
2) If I set the modem to use google's DNS servers, the problem goes away.

The problem resurfaced tonight after I set the modem back to automatic DNS a day or two ago.
My partner had no access using Spark DNS, I had no problem using Google. I changed my tablet back to automatic (Spark) and couldn't connect.
Changed the modem to google then back to auto, and we're away again.

The modem is a TP link TD-W8950N, the previous one was a linksys wag200g. When the DNS servers don't respond, the modem reports no problems.

I haven't tried pinging the servers when it's not working, I'll try that next time.




Location: Dunedin

Create new topic


1635 posts

Uber Geek
+1 received by user: 781


  Reply # 1371906 22-Aug-2015 07:17
Send private message

Right, it's happened again.

I cant ping either DNS server.

Before I correct the problem, is there anything i can do to gain more info on the problem.




Location: Dunedin

628 posts

Ultimate Geek
+1 received by user: 159

Trusted
Spark NZ

  Reply # 1371909 22-Aug-2015 07:32
Send private message

Spark DNS servers do not respond to ping.  Can you do nslookup from a command prompt and resolve host names?




My views are my own, and may not necessarily represent those of my employer.

 
 
 
 




1635 posts

Uber Geek
+1 received by user: 781


  Reply # 1371913 22-Aug-2015 07:58
Send private message

So if I go "nslookup live.geekzone.co.nz" it uses my modems address as the dns and fails.
If I specify the spark dns server, it works.

Specifying spark servers in my network adapter settings works too, but thats not a good solution.

Why are my devices using the modem address as the dns, is that normal?
the modem is saying it has the correct dns addresses.




Location: Dunedin

1130 posts

Uber Geek
+1 received by user: 115

Trusted

  Reply # 1371930 22-Aug-2015 08:59
Send private message

Can you disable DNS proxy on your router? I think this should then forward the external DNS addresses to your devices instead of using the router as a proxy
Cheers,
Josepn



1635 posts

Uber Geek
+1 received by user: 781


  Reply # 1371935 22-Aug-2015 09:15
Send private message

It doesn't appear that I can.

I seem to remember having the same issue even when i specify the dns in the nic settings. I guess i'll find out soon enough, that's what I've done for now.

I'm going to have to restart the modem soon or er-indoors is going to get cranky.




Location: Dunedin

628 posts

Ultimate Geek
+1 received by user: 159

Trusted
Spark NZ

  Reply # 1371945 22-Aug-2015 10:09
Send private message

What OS are you using?




My views are my own, and may not necessarily represent those of my employer.



1635 posts

Uber Geek
+1 received by user: 781


  Reply # 1371956 22-Aug-2015 10:44
Send private message

Win 10 / Win 7 / Windows Phone 8.1 / iPhone / Mac OSX
Happens on everything on the network.




Location: Dunedin

1791 posts

Uber Geek
+1 received by user: 202


  Reply # 1371961 22-Aug-2015 10:51
Send private message

I get a very similar problem as you with the Orcon supplied NF4V if I let the modem perform on auto for DNS servers it alwats sets itself as the DNS server, If I set the actual primary and secondary servers to Orcon's DNS servers or google or Opendns the problem goes away which leads me to believe that there is a problem with the firmware or more to the point the bit that deals with how Automatic DNS is worked  




Asus Crosshair V Formula AMD FX8320 (4.0GHz), 8GB Mushkin BlackLine DDR2400, 1x Sapphire RX580 8GB OC 1352/2000 (BIOS upgraded), 2x Kingston V300 SSD's RAID0 Boot, 1x WDC WD2003FYYS RE4 2TB, 1X WDC WD1003FZEX 1TB, 1X  SAMSUNG HD103SJ 1TB, SilverStone ST75F-P (750W) Full Modular PSU, OS WIN10 pro x64, SilverStone RaVeN RV02B-W (with USB3.0 upgrade)




1635 posts

Uber Geek
+1 received by user: 781


  Reply # 1371980 22-Aug-2015 12:10
Send private message

It's been a while since i tried, but i'm pretty sure if i manually set the router to use Spark's dns it fails after x time just like automatic does. If I set it to use Google's dns, I have no such problems.

Manually setting the dns on every connected device isn't a solution, and using Googles isn't ideal.

This is something that should just work.




Location: Dunedin

2201 posts

Uber Geek
+1 received by user: 613

Trusted

  Reply # 1371990 22-Aug-2015 12:41
Send private message

Have you checked to see if there is newer firmware for your router?? And/or done a factory reset on it and tried setting it up from scratch?





Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Red Hat unveils production-ready open source hyperconverged infrastructure
Posted 23-Jun-2017 22:10


Whatever ailed Vodafone broadband … seems to be fixed
Posted 23-Jun-2017 14:10


VMware NSX Meets Stringent Government Security Standards with Common Criteria Certification
Posted 22-Jun-2017 19:05


Brother launches next-generation colour laser printers and all-in- ones for business
Posted 22-Jun-2017 18:56


Intel and IOC announce partnership
Posted 22-Jun-2017 18:50


Samsung Galaxy Tab S3: Best Android tablet
Posted 21-Jun-2017 12:05


Wellington-based company helping secure Microsoft browsers
Posted 20-Jun-2017 20:51


Endace delivers high performance with new 1/10/40 Gbps packet capture card
Posted 20-Jun-2017 20:50


You can now integrate SMX security into Microsoft Office 365, Google and other cloud email platforms
Posted 20-Jun-2017 20:47


Ravensdown launches new decision-making tool HawkEye
Posted 19-Jun-2017 15:38


Spark planning to take on direct management of all consumer stores
Posted 19-Jun-2017 10:03


Qrious acquires Ubiquity
Posted 14-Jun-2017 12:21


Spark New Zealand prepares for 5G with Nokia
Posted 14-Jun-2017 12:16


The future-proof 10.5-inch iPad Pro
Posted 13-Jun-2017 18:16


Mandatory data breach reporting in Australia
Posted 13-Jun-2017 11:30



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.