Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




5 posts

Wannabe Geek


# 202006 13-Sep-2016 15:21
Send private message

Hi,

 

I am trying to connect to my home PC from outside of my home network. I have Spark at home. I used to be able to do this over a year ago without any problems but now I cannot. I have all the port forwarding set up (VDSL router -> wireless router -> home PC)

 

I tried a tracert from my work to my Spark IP and it appears to be timing out of a jetstream node (the IP of which is NOT my home WAN IP)

 

 

 

 1  XXX  0.540 ms  0.468 ms  0.440 ms
 2  ge-1-1-1-240.core-1.ive.chc.unleash.net.nz (116.90.138.221)  1.436 ms * *
 3  * * *
 4  ae5-4020.core-0.que.akl.unleash.net.nz (116.90.129.73)  14.800 ms * *
 5  * * *
 6  * * *
 7  tengigabitethernet1-1-0-331.wntnz-rt1.fx.net.nz (202.53.187.30)  29.971 ms  29.991 ms  29.972 ms
 8  tengigabitethernet0-2-0-540.wnmur-rt1.fx.net.nz (202.53.187.237)  29.983 ms  29.906 ms  30.100 ms
 9  tengige0-0-2-0-317.chrev-rt1.fx.net.nz (202.53.187.46)  29.213 ms  29.368 ms  29.529 ms
10  122-56-224-12.mobile.spark.co.nz (122.56.224.12)  31.172 ms * 122-56-224-12.mobile.spark.co.nz (122.56.224.12)  30.831 ms
11  125-237-160-1.jetstream.xtra.co.nz (125.237.160.1)  34.135 ms  31.568 ms  30.606 ms
12  * * *
13  * * *
14  * * *
15  * * *
16  * * *
17  * * *
18  * * *
19  * * *
20  * * *
21  * * *
22  * * *
23  * * *
24  * * *
25  * * *
26  * * *
27  * * *
28  * * *
29  * * *
30  * * *

 

 

I tried contacting Spark and got put through to their "Broadband Expert" (in India?!) who told me that they "do not support port forwarding or VPN so I should contact my IT support"...

 

This sounds like baloney to me. Does anyone have any advice as to whether this looks like a problem on my end or Spark's end?

 

Cheers

 

 


Create new topic
285 posts

Ultimate Geek


  # 1628631 13-Sep-2016 15:25
Send private message

 Ok first we need a bit more information.

 

 

 

1. What sort of remote access are you trying to use? RDP? VPN? Other?

 

2. You mention you are using two routers. Is this double NAT or is the wireless router just running as an access point?

 

3. Where is that tracert from / to? What were you hoping to discover with it?


1423 posts

Uber Geek


  # 1628633 13-Sep-2016 15:30
Send private message

It seems at first you need to verify whether your port forwarding and firewall set up is still configured as you expect.

 

 

Modem/router configuration can be reset by (automatic) firmware upgrades, operating system firewalls can be reset when connected to different networks/profiles.

 
 
 
 




5 posts

Wannabe Geek


  # 1628636 13-Sep-2016 15:33
Send private message

ghettomaster:

 

1. What sort of remote access are you trying to use? RDP? VPN? Other?

 

2. You mention you are using two routers. Is this double NAT or is the wireless router just running as an access point?

 

3. Where is that tracert from / to? What were you hoping to discover with it?

 

 

Hey, thank you for the quick reply.

 

1. I am trying to RDP on a custom port

 

2. It is double NAT. I port forward from the VDSL router to my wireless router, and then from my wireless router to my home PC. All connections are ethernet (no wireless)

 

3. The tracert is from my work to my Spark WAN IP. I am trying to see where the connection is dropping. If it is my VDSL router I would expect to see my WAN IP at the last step there, but instead it appears to be a Spark server somewhere


285 posts

Ultimate Geek


  # 1628671 13-Sep-2016 15:54
Send private message

nem2k2:

 

2. It is double NAT. I port forward from the VDSL router to my wireless router, and then from my wireless router to my home PC. All connections are ethernet (no wireless)

 

 

With your custom port, have you configured the OS to use this port and are you using the same port all the way, or are you using PAT somewhere?

 

 

 

nem2k2:

 

3. If it is my VDSL router I would expect to see my WAN IP at the last step there, but instead it appears to be a Spark server somewhere

 

 

Not necessarily. A lot of routers these days are configured to not respond to ping, and there is no need to enable it. RDP will work fine without ping being enabled.

 

 

 

So long as the port forwarding on both routers is correct, and you have double checked it, my first suspect would be the firewall on your PC. Are you using the windows firewall or another firewall or both? What happens if you disable the windows firewall or create an entry to allow RDP traffic on the custom port?
 

 

 


285 posts

Ultimate Geek


  # 1628684 13-Sep-2016 15:57
Send private message

In case you are wondering what PAT is, it is where you use one port externally, and have your router forward the traffic to a different port internally.

 

 


3344 posts

Uber Geek

Trusted
Vocus

  # 1628700 13-Sep-2016 16:12
One person supports this post
Send private message

Just my 2c - don't use RDP remotely - even if it is on a custom port.  It's horribly insecure.  Set up a VPN or something - with 2fa and/or a key.  And I'm out.


xpd

SysOp
10246 posts

Uber Geek

Mod Emeritus
Trusted
Lifetime subscriber

  # 1628703 13-Sep-2016 16:16
2 people support this post
Send private message

Teamviewer. THat is all. ;)

 

 





XPD / Gavin / DemiseNZ

 

Server : i5-3470s @ 3.50GHz  16GB RAM  Win 10 Pro    Workstation : Ryzen 5 3600 / 16GB DDR4 / RX580 4GB    Console : Xbox One

 

Now on BigPipe 100/100 and 2Talk  Add me on Steam   My Lego

 

*** AMIGA UNLIMITED REDUX BBS - SOON***


 
 
 
 


3944 posts

Uber Geek

Trusted
Lifetime subscriber

  # 1628705 13-Sep-2016 16:18
Send private message

What Ubergeek and XPD said





Information wants to be free. The Net interprets censorship as damage and routes around it.




5 posts

Wannabe Geek


  # 1628752 13-Sep-2016 17:00
Send private message

ghettomaster:

 

With your custom port, have you configured the OS to use this port and are you using the same port all the way, or are you using PAT somewhere?

 

 

I am using the same port all the way. I am not using PAT

 

 

 

ghettomaster:

 

So long as the port forwarding on both routers is correct, and you have double checked it, my first suspect would be the firewall on your PC. Are you using the windows firewall or another firewall or both? What happens if you disable the windows firewall or create an entry to allow RDP traffic on the custom port?

 

 

I am using Windows Firewall. I have tried disabling it entirely and it does not fix the issue.

 

I changed the RDP port in Windows as outlined here: https://support.microsoft.com/en-us/kb/306759

 

 

 

And thank you everyone for the PSA about RDP - I am simply using this as a test case to try and work out why I cannot connect to my home PC remotely.


285 posts

Ultimate Geek


  # 1629079 14-Sep-2016 09:18
Send private message

 

 

While I agree with the comments about public RDP, it is a good learning experience and the OP has said he is aware of that.

 

 

 

nem2k2, did you get it working? Your post isn't quite clear.




5 posts

Wannabe Geek


  # 1641833 28-Sep-2016 13:43
Send private message

No, I did not. I started using TeamViewer instead of RDP, haven't looked into it further as I haven't had to use any other services on my home network remotely lately


Create new topic



Switch your broadband provider now - compare prices


Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Vodafone integrates eSIM into device and wearable roadmap
Posted 17-Jan-2020 09:45


Do you need this camera app? Group investigates privacy implications
Posted 16-Jan-2020 03:30


JBL launches headphones range designed for gaming
Posted 13-Jan-2020 09:59


Withings introduces ScanWatch wearable combining ECG and sleep apnea detection
Posted 9-Jan-2020 18:34


NZ Police releases public app
Posted 8-Jan-2020 11:43


Suunto 7 combine sports and smart features on new smartwatch generation
Posted 7-Jan-2020 16:06


Intel brings innovation with technology spanning the cloud, network, edge and PC
Posted 7-Jan-2020 15:54


AMD announces high performance desktop and ultrathin laptop processors
Posted 7-Jan-2020 15:42


AMD unveils four new desktop and mobile GPUs including AMD Radeon RX 5600
Posted 7-Jan-2020 15:32


Consolidation in video streaming market with Spark selling Lightbox to Sky
Posted 19-Dec-2019 09:09


Intel introduces cryogenic control chip to enable quantum computers
Posted 10-Dec-2019 21:32


Vodafone 5G service live in four cities
Posted 10-Dec-2019 08:30


Samsung Galaxy Fold now available in New Zealand
Posted 6-Dec-2019 00:01


NZ company oDocs awarded US$ 100,000 Dubai World Expo grant
Posted 5-Dec-2019 16:00


New Zealand Rugby Selects AWS-Powered Analytics for Deeper Game Insights
Posted 5-Dec-2019 11:33



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.