Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


Filter this topic showing only the reply marked as answer View this topic in a long page with up to 500 replies per page Create new topic
1 | ... | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 14 | 15 | ... | 29
allio
770 posts

Ultimate Geek


  #1756269 4-Apr-2017 13:01
Send private message

allio:

 

Detruire:

 

One router firmware upgrade later and I'm connected again. The old version had a bug that stopped IPv6 settings from being saved.

 

Very easy with Advanced Tomato

 

 

Working fine here too on Advanced Tomato 132. Very easy. Changed settings and rebooted. Didn't have to do a thing with the bridged Vigor 130.

 

 

Small correction - all works perfectly except DNS. Even after manually entering the Bigpipe DNS servers into the router settings, they're not being served up to any of my devices. Works fine once I manually set the DNS servers on the client. This is almost certainly at my end.

 

Detruire: does IPv6 DNS work correctly for you? What version of Tomato were you having trouble with, and what did you update to?


Affiliate link
 
 
 

Affiliate link: Norton 360 antivirus provides enhanced security for your connected devices, a secure VPN for online privacy, Password Manager, Firewall, SafeCam, PC Cloud Backup, Dark Web Monitoring, Parental Control, and more. An all-in-one cybersecurity solution backed by 100% Virus Protection Promise and 60 Day Money Back Guarantee.
robcreid
242 posts

Master Geek


  #1756317 4-Apr-2017 13:44
Send private message

With ipv4 I never got around to getting a static address and setting up remote access/port forwarding etc but am now considering setting up remote access with my nice new sticky IPv6 addresses.

 

As someone who only has a consumer grade modem/router (Netcomm NF8AC) and Win 10 desktop and various other devices, what is the best way to do this? I assume configuring the desktop to accept incoming VPN connections on IPv6 and allowing the relevant port through on the firewall on the router is more secure than allowing access on the firewall to multiple devices directly.    

 

Win 10 seems to have the ability to configure incoming PPTP connections builtin. Is there other free/cheap VPN server software that people recommend.

 

Assuming I get it working, what happens if the place I'm trying to remote from only supports IPv4?

 

Sorry for all the questions, I'm trying to google the answers myself but don't yet have enough knowledge to to tell the right answers from the wrong ones.


michaelmurfy
/dev/ttys0
11027 posts

Uber Geek

Moderator
ID Verified
Trusted
Lifetime subscriber

  #1756322 4-Apr-2017 13:49
Send private message

@1xnRWP just make sure you add the firewall rules on that page since IPv6 is public (no NAT).




Michael Murphy | https://murfy.nz | https://keybase.io/michaelmurfy - Referral Links: Sharesies | Electric Kiwi
Are you happy with what you get from Geekzone? Please consider supporting us by making a donation.




Aaroona
3067 posts

Uber Geek


  #1756464 4-Apr-2017 17:48
Send private message

Had IPv6 enabled last night (Thanks team!) 

 

I thought dropping my WAN and WAN6 connection would be sufficient, but needed to reboot the modem.

 

 

 

Currently running IPv6 on all devices connected to my router running LEDE (OpenWRT) with the latest 4.4 linux kernel. 

 

 

 

Will do some more testing over the next few days, but as it's most basic, Web and other IPv6 capable traffic seem to be flowing! 


OmniouS
377 posts

Ultimate Geek

Trusted
Lifetime subscriber

  #1756845 5-Apr-2017 10:02
Send private message

I lost IPv6 connectivity at around 4:04am this morning while I was sleeping. I won't have much free time today - I'll try to look at the logs later tonight or tomorrow morning


mitchtay
26 posts

Geek


  #1756890 5-Apr-2017 11:23
Send private message

Message sent. Hopefully I can get in on the action too.

 

Otherwise I may have a spare pfSense machine I could lend to michaelmurfy if needed, though I am in Hamilton and not Wellington :)


SirHumphreyAppleby
1989 posts

Uber Geek


  #1756900 5-Apr-2017 11:36
Send private message

mitchtay:

 

Otherwise I may have a spare pfSense machine I could lend to michaelmurfy if needed, though I am in Hamilton and not Wellington :)

 

 

Perhaps you could loan it to Bigpipe. I'm testing on my production router, otherwise I would have shipped it to them to test with last week.

 

I've tried the production, current, and experimental releases of pfSense, with no apparent difference in behaviour. I've also tried the release of OPNsense with the same issue. Both distributions have been actively working on IPv6 issues over recent months/weeks, so hopefully the fix isn't too far away.

 

The issue I have is that I am not able to reliably get an IPv6 address assigned on the LAN interface. There are numerous threads about not getting addresses on the LAN, and a number of suggested causes, including the use of VLANs, a difference in expected command sequences between the DHCP client and server, the bogon network setting, the order settings are applied, and multiple instances of DHCP on the interface. None of the suggested solutions have worked for me.




hio77
'That VDSL Cat'
12970 posts

Uber Geek

ID Verified
Trusted
Voyager
Subscriber

  #1756910 5-Apr-2017 11:45
Send private message

mitchtay:

 

Message sent. Hopefully I can get in on the action too.

 

Otherwise I may have a spare pfSense machine I could lend to michaelmurfy if needed, though I am in Hamilton and not Wellington :)

 

 

 

 

What sort of formfactor are we talking?

 

 

 

I likely will be able to bridge the gap between hamilton and the office @IPv6pipe is in.

 

Obviously lugging around a full machine could be a tad, unpractical. 





#include <std_disclaimer>

 

Any comments made are personal opinion and do not reflect directly on the position my current or past employers may have.

 

 


michaelmurfy
/dev/ttys0
11027 posts

Uber Geek

Moderator
ID Verified
Trusted
Lifetime subscriber

  #1756912 5-Apr-2017 11:50
Send private message

SirHumphreyAppleby:

 

mitchtay:

 

Otherwise I may have a spare pfSense machine I could lend to michaelmurfy if needed, though I am in Hamilton and not Wellington :)

 

 

Perhaps you could loan it to Bigpipe. I'm testing on my production router, otherwise I would have shipped it to them to test with last week.

 

I've tried the production, current, and experimental releases of pfSense, with no apparent difference in behaviour. I've also tried the release of OPNsense with the same issue. Both distributions have been actively working on IPv6 issues over recent months/weeks, so hopefully the fix isn't too far away.

 

The issue I have is that I am not able to reliably get an IPv6 address assigned on the LAN interface. There are numerous threads about not getting addresses on the LAN, and a number of suggested causes, including the use of VLANs, a difference in expected command sequences between the DHCP client and server, the bogon network setting, the order settings are applied, and multiple instances of DHCP on the interface. None of the suggested solutions have worked for me

 

If this is a fullsize computer it may be a little expensive to ship :) but I heard @IPv6Pipe has a drawer of courier tickets. I am happy to take a look if it is something that is easy to ship.





Michael Murphy | https://murfy.nz | https://keybase.io/michaelmurfy - Referral Links: Sharesies | Electric Kiwi
Are you happy with what you get from Geekzone? Please consider supporting us by making a donation.


mitchtay
26 posts

Geek


  #1756915 5-Apr-2017 11:54
Send private message

michaelmurfy:

 

<SNIP>

 

If this is a fullsize computer it may be a little expensive to ship :) but I heard @IPv6Pipe has a drawer of courier tickets. I am happy to take a look if it is something that is easy to ship.

 

 

It's Mini-ITX so not too large. I'd like to have a play myself if possible (I enjoy a challenge.) but failing that am happy to relinquish it for a while as I'm actually using a Fritz!Box as my modem/router at the moment given I'm in a temporary living arrangement and couldn't be bothered setting all the nerd stuff up.

 

 


IPv6pipe
98 posts

Master Geek

Trusted
BigPipe

  #1757186 5-Apr-2017 16:32
Send private message

Thanks for the offers of testing pfSense boxes. I may PM one of you about it in the near future, as I've been unable to find an unused dual NIC box. To those waiting for v6 activation: Check your PMs. :)


Detruire
1401 posts

Uber Geek


  #1757358 6-Apr-2017 08:11
Send private message

allio:

 

allio:

 

Detruire:

 

One router firmware upgrade later and I'm connected again. The old version had a bug that stopped IPv6 settings from being saved.

 

Very easy with Advanced Tomato

 

 

Working fine here too on Advanced Tomato 132. Very easy. Changed settings and rebooted. Didn't have to do a thing with the bridged Vigor 130.

 

 

Small correction - all works perfectly except DNS. Even after manually entering the Bigpipe DNS servers into the router settings, they're not being served up to any of my devices. Works fine once I manually set the DNS servers on the client. This is almost certainly at my end.

 

Detruire: does IPv6 DNS work correctly for you? What version of Tomato were you having trouble with, and what did you update to?

 

 

The router acts as a DNS proxy, and responds on its v6 address, but I'm not sure what it does in the background. I upgraded from a ~1 year old version to the latest one. The old one wouldn't save the IPv6 settings (JS error on the UI.)





rm *


allio
770 posts

Ultimate Geek


  #1757370 6-Apr-2017 09:25
Send private message

Detruire:

 

The router acts as a DNS proxy, and responds on its v6 address, but I'm not sure what it does in the background. I upgraded from a ~1 year old version to the latest one. The old one wouldn't save the IPv6 settings (JS error on the UI.)

 

 

Thanks for that. To make it a bit clearer - do you pass all three DNS tests at this site?

 

Might be time I upgraded to the latest version. 1.32 has been so stable I've been reluctant to.


jimbob79
665 posts

Ultimate Geek


  #1757395 6-Apr-2017 10:08
Send private message

I believed I got it working on my TP-LINK (no sure witch model). Here are the setting I used which worked for me:

 

WAN Setup:

 

Enable IPv6: tick

 

WAN Connection  Type: Tunnel 6to4

 

MTU Size: 1480

 

LAN Setup:

 

IPv6 Address Assign Type: DHCPv6 Server

 

 

 

Click to see full size

 

 

 

 

 

 

 

 


IPv6pipe
98 posts

Master Geek

Trusted
BigPipe

  #1757456 6-Apr-2017 12:06
Send private message

That setup doesn't look correct. It appears from your screenshot that your router is configured for a tunnelling service, not the native v6 connectivity available from Bigpipe.

 

Your router needs to request a v6 prefix over DHCPv6-PD, and the request needs to come through over the same PPP session your v4 traffic is running over.


1 | ... | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 14 | 15 | ... | 29
Filter this topic showing only the reply marked as answer View this topic in a long page with up to 500 replies per page Create new topic





News and reviews »

GoTo Launches IT Helpdesk Functionality Within GoTo Connect
Posted 18-Aug-2022 16:55


HP on Track With Recycling Program
Posted 18-Aug-2022 16:51


Belkin Screenforce Tempered Glass Screen Protector and Bumper - Apple Watch
Posted 15-Aug-2022 17:20


Samsung Introducing Galaxy Z Flip4 and Galaxy Z Fold4
Posted 11-Aug-2022 01:00


Samsung Unveils Health Innovations with Galaxy Watch5 and Galaxy Watch5 Pro
Posted 11-Aug-2022 01:00


Google Bringing First Cloud Region to Aotearoa New Zealand
Posted 10-Aug-2022 08:51


ANZ To Move to FIS Modern Banking Platform
Posted 10-Aug-2022 08:28


GoPro Hero10 Black Review
Posted 8-Aug-2022 17:41


Amazon to Acquire iRobot
Posted 6-Aug-2022 11:41


Samsung x LIFE Picture Collection Brings Iconic Moments in History to The Frame
Posted 4-Aug-2022 17:04


Norton Consumer Cyber Safety Pulse Report: Phishing for New Bait on Social Media
Posted 4-Aug-2022 16:50


Microsoft Announces New Solutions for Threat Intelligence and Attack Surface Management
Posted 3-Aug-2022 21:54


Seagate Addresses Hyperscale Workloads with Enterprise-Class Nytro SSDs
Posted 3-Aug-2022 21:50


Visa Launching Eco-friendly Payment Solutions in New Zealand
Posted 3-Aug-2022 21:48


NCR Delivers Services to Run Bank of New Zealand ATM Network
Posted 30-Jul-2022 11:06









Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.







Backblaze unlimited backup