Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


View this topic in a long page with up to 500 replies per page Create new topic
1 | 2 


634 posts

Ultimate Geek


  # 1786959 23-May-2017 17:23
Send private message

Cheers, have emailed the output file.




634 posts

Ultimate Geek


  # 1787014 23-May-2017 19:36
Send private message

I just pulled the 2011ils-in out (it has older firmware) and reset it's configuration and set it up from scratch.

 

It too won't establish a connection.

 

The Ethernet interface is 1512, VLAN 1508 (with 10 tagging) and PPPoE client set to MTU/MRRU 1500 (which makes Mikrotik set the max payload info as 1500).

 

Reverting to defaults (1500MTU on interfaces) and using the defaults for PPPoE client it still won't connect either, which would normally connect at 1492 or 1450 or whatever the default usually is.

 

I was thinking firmware bug on the 750GL that I always use and leave alone, but that doesn't explain the 2011ils-in or 951ui-2hnd refusing to work too. The 951 has new (current) firmware, the 2011 older. The 750GL has the bugfix only release.

 

If I plug the Huawei in... it's away and laughing. Unfortunately, I can not set port mapping to IP address on the Huawei, only to MAC address which is no good to me due to my config.

 

This really has me stuck, but I've gone over this on all three routers and all three refuse to establish a PPPoE. Unless the older firmware on the 2011 is buggy too.

 

 

 

 

 

 


 
 
 
 


1374 posts

Uber Geek


  # 1787027 23-May-2017 20:00
Send private message

Keen to know more about the cause also.

 

 

 

Here is also a thread with similar symptoms but on ADSL with third party Draytek modem/router, ISP provided modem/router connects but not third party CPE.

 

https://www.geekzone.co.nz/forums.asp?forumid=82&topicid=214605 

 

 

 

In the olden days Telecom Wholesale would proxy PPP requests for authentication purposes and there would be rate limits etc. but nowadays with Ethernet/EUBA traffic takes a direct path into the terminating ISP. Also Orcon and Spark to my knowledge both use Alcatel-Lucent BNG routers so something in common.




634 posts

Ultimate Geek


  # 1787181 24-May-2017 02:02
Send private message

I just got home, tried the 2011ils-in still no go. Reset the ONT again, plugged back in the 750GL and the 750GL has connected about 1:45am. I'm super glad it's going again however I'm perplexed as to why previous resets of the ONT didn't work or the other routers either. The configurations were identical even after resetting the configs in them.

It was logging in, but it stalled come time to get its static IP. I have no idea why it failed at this point, on each router. The 750GL didn't drop the PPPoE and kept re-requesting the IP at a phenomenal rate of re-tries. The Alcatel BNG kept rejecting so I thought it must be firmware. I'm back on the 750GL same firmware and same config. The firmware on the other routers is different with fresh config but still had issues.

I don't know if I'm game enough to reset anything now it's working again.

714 posts

Ultimate Geek

Trusted
Spark NZ

  # 1787245 24-May-2017 08:48
Send private message

Hi Gavin,

 

Thanks for the packet capture.  Yes your analysis was correct - for some reason your router was insistent on requesting IP address: 172.16.0.254, which our BNG was rejecting.  The BNG was then suggesting (via the NAK) that it request your static IP, but your router was refusing to do that.  Your router eventually gives up requesting an Ip address, and just requests the DNS servers, which our BNG rejects as it does not contain an IP address for your end of the PPP link.

 

The BNG is behaving correctly.  Why your router is behaving this way I have no idea.

 

I find it odd that the connection came up at 1:45 on the Mikrotek (with your static IP).  Good, but odd. Without seeing a packet capture of why it is now working, I would not like to speculate on what has changed.  Certainly we have made no changes at our end.

 

I see you've reverted back to the Huawei router now?

 

 

 

Dave.





My views are my own, and may not necessarily represent those of my employer.




634 posts

Ultimate Geek


  # 1787301 24-May-2017 10:22
Send private message

Thanks beyond gratitude for your time Dave.

 

I did use the Huawei one point before I went to work last night. I haven't used it since last night though.

 

I've updated the 2011ils-in - it's working and reconnecting (it's now updated to the same firmware the 750GL was on) so I'll leave it as that and bin the 750GL.

 

I tried a software config reset (including hard reset button reset) and finally a firmware downgrade on the 750GL. It still wasn't having a bar of it - then it was iffy trying to connect to it by MAC to set it back up again, so it's R.I.P. for it. After the ONT reboot (which would have just re-started the ethernet interface the PPPoE was on yet again) it came right but I don't trust it.

 

It was a good time to test my MF910 hotspot as a backup for fetching news bulletins. The only thing I ran in to with it was the IP range can't be changed, and was on the same as the one between the Production PC and On-Air computer. The On-Air isn't connected to the general LAN or Spark Fibre, it's a seperate secured segment and the MF910 doesn't allow you to change IP range so a quick change of the On-Air segment fixed this.

 

At least it all happened at once, so it's stressed tested everything.

 

 

 

Cheers,

 

Gavin.

 

 

 

edit: and now I know what packet capture and Wireshark is all about :) Very handy.


1 | 2 
View this topic in a long page with up to 500 replies per page Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Disney+ streaming service confirmed launch in New Zealand
Posted 20-Aug-2019 09:29


Industry plan could create a billion dollar interactive games sector
Posted 19-Aug-2019 20:41


Personal cyber insurance a New Zealand first
Posted 19-Aug-2019 20:26


University of Waikato launches space for esports
Posted 19-Aug-2019 20:20


D-Link ANZ expands mydlink ecosystem with new mydlink Mini Wi-Fi Smart Plug
Posted 19-Aug-2019 20:14


Kiwi workers still falling victim to old cyber tricks
Posted 12-Aug-2019 20:47


Lightning Lab GovTech launches 2019 programme
Posted 12-Aug-2019 20:41


Epson launches portable laser projector
Posted 12-Aug-2019 20:27


Huawei launches new distributed HarmonyOS
Posted 12-Aug-2019 20:20


Lenovo introduces single-socket servers for edge and data-intensive workloads
Posted 9-Aug-2019 21:26


The Document Foundation announces LibreOffice 6.3
Posted 9-Aug-2019 16:57


Symantec sell enterprise security assets for US$ 10.7 billion to Broadcom
Posted 9-Aug-2019 16:43


Artificial tongue can distinguish whisky and identify counterfeits
Posted 8-Aug-2019 20:20


Toyota and Preferred Networks to develop service robots
Posted 8-Aug-2019 20:11


Vodafone introduces new Vodafone TV device
Posted 7-Aug-2019 17:16



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.