Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


3123 posts

Uber Geek
+1 received by user: 946

Trusted
Lifetime subscriber

Topic # 115732 4-Apr-2013 19:49
Send private message

Been getting a strange problem when visiting Geekzone for the last 2 days. No login and passwords fields:




Running W7 (fully up-to-date) - happens on both Chrome and IE10. Anyone else been seeing this?

Create new topic
BDFL - Memuneh
61185 posts

Uber Geek
+1 received by user: 11967

Administrator
Trusted
Geekzone
Lifetime subscriber

  Reply # 793445 4-Apr-2013 19:57
Send private message

Someone noticed it, then.

This is a change we've done yesterday to improve password security.

Although the previous form submitted the login information to a SSL page, a man-in-the-middle attack (a transparent proxy at an ISP, wireless hotspot or even corporate) could easily add javascript code to read the fields when clicked, before being submitted to the SSL form.

To login now you click the button labelled [Click to login] and that will give you the SSL-enabled login page, which cannot be modified by a MITM attack.




Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.