Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




8 posts

Wannabe Geek


# 106574 26-Jul-2012 14:18
Send private message

We have an Xnet configured LinkSys SPA2102 box to handle our phone calls. Whenever we turn the unit off and on again (e.g. reset, powercut etc), the unit resets its time and date (back to  12:00 am on 1/1/1900, I think?) That means that when calls come in, our Uniden cordless phone shows the wrong date and time. Log entries will also be based on time since last restart.

The only way that I can remedy this is by doing a factory reset on the SPA2102, entering the NZ daylight savings rules and saving, entering the configuration file address on the provisioning tab, powering the unit off and on again and then (very quickly!) setting date and time before Xnet’s configuration file locks me out! Needless to say, this is a bit of a pain!

I have a couple of questions ...
  • Is it normal that the SPA2102 loses its time settings when powered off and on again? Or should it be retaining its settings?
  • Why can't World Exchange either configure the SPA2102 to pick up the correct time from a timeserver on the internet? Or ... why can't they leave access to the time settings unlocked so that it is possible to update these without all the rigmarole?
PastorMike

Create new topic
174 posts

Master Geek

Trusted

  # 662418 26-Jul-2012 14:49
Send private message

Hello Pastormike,

I'm unable to reproduce this error in testing with my 2102 and your config has the correct daylight saving rule set. I can see some issues with your device picking up its config however where it is getting 304 errors on most config downloads. As a precaution I have recreated your config, if you could reset the 2102 and have it download a fresh default and final config and let me know the result.




Nicholas Cuc

Network Support
WorldxChange Communications
www.xnet.co.nz





8 posts

Wannabe Geek


  # 662424 26-Jul-2012 15:01
Send private message

Nicholas

Thanks for your quick reply.

Could you please clarify your reply for me?

Do I simply need to power off the device and power it on again? Or do I need to do a factory reset and then re-enter the address for the config file? Also, should I set the date and time before adding the address for your config file to the provisioning tab? Or should it pick up the correct time once your config file is activated?

The reason that I said I needed to set the daylight savings rule is that when daylight savings stopped, the SPA2102 was then an hour out (though that may have been an older version of the config file?) Also, after a factory reset, the rule shows as wrong and I have no way of checking how the rule is set after your config file has loaded since I am then locked out of the regional tab (+ I have to connect an ethernet cable to the device and hook up my laptop because your config file disables webadmin (though your original config file did not?))

PastorMike

 
 
 
 


174 posts

Master Geek

Trusted

  # 662427 26-Jul-2012 15:06
Send private message

Factory reset it to clear any residual configs and settings on it. Web admin is off by default but you should be able to reenable it.





Nicholas Cuc

Network Support
WorldxChange Communications
www.xnet.co.nz



174 posts

Master Geek

Trusted

  # 662431 26-Jul-2012 15:09
Send private message

enable web admin.

lift handset press "*" 4 times
enter 7932#
Press 1 to enable WAN access

use wan IP to access 2102.




Nicholas Cuc

Network Support
WorldxChange Communications
www.xnet.co.nz





8 posts

Wannabe Geek


  # 662456 26-Jul-2012 15:44
Send private message

Nicholas

I've tried this after your config file is activated. When I go to (re)enable web admin, it asks me for a password (which has been set by WxC) and so I am unable to enable it.

PastorMike



8 posts

Wannabe Geek


  # 662465 26-Jul-2012 15:51
Send private message

Nicholas

Also you've not answered my other questions ...

Should I set the date and time before adding the address for your config file to the provisioning tab? Or should it pick up the correct time once your config file is activated?




8 posts

Wannabe Geek


  # 663292 28-Jul-2012 14:33
Send private message

Problem all solved! Thanks Andrei!

I was setting up a static IP address for the SPA2102 so that it would not get an address in the range that I have set up for my kids' PCs. You don't want your phone line dropping out at 9:45pm and not coming on again till 7am the next morning!

This meant that the SPA2102 did not pick up all of its configuration settings from WxC. Apparently then I would have needed to manually enter Xnet's DNS servers in order for the time settings to propogate.

Anyway, I've now set up my main router to always assign a particular IP address to the SPA2102 (one outside of the time-limited range) and it all works beautifully.

Thanks WxC for top-notch service!

PastorMike

Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Dunedin selects Telensa to deliver smart street lighting for 15,000 LEDs
Posted 18-Jul-2019 10:21


Sprint announces a connected wallet card with built-in IoT support
Posted 18-Jul-2019 08:36


Educational tool developed at Otago makes international launch
Posted 17-Jul-2019 21:57


Symantec introduces cloud access security solution
Posted 17-Jul-2019 21:48


New Zealand government unveils new digital service to make business easier
Posted 16-Jul-2019 17:35


Scientists unveil image of quantum entanglement
Posted 13-Jul-2019 06:00


Hackers to be challenged at University of Waikato
Posted 12-Jul-2019 21:34


OPPO Reno Z now available in New Zealand
Posted 12-Jul-2019 21:28


Sony introduces WF-1000XM3 wireless headphones with noise cancellation
Posted 8-Jul-2019 16:56


Xero announces new smarter tools, push into the North American market
Posted 19-Jun-2019 17:20


New report by Unisys shows New Zealanders want action by social platform companies and police to monitor social media sites
Posted 19-Jun-2019 17:09


ASB adds Google Pay option to contactless payments
Posted 19-Jun-2019 17:05


New Zealand PC Market declines on the back of high channel inventory, IDC reports
Posted 18-Jun-2019 17:35


Air New Zealand uses drones to inspect aircraft
Posted 17-Jun-2019 15:39


TCL Electronics launches its first-ever 8K TV
Posted 17-Jun-2019 15:18



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.