Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


428 posts

Ultimate Geek
+1 received by user: 130


Topic # 165522 12-Feb-2015 12:10
Send private message

Hi Guys
After a little guidance as I am having an issue sending email from my Vodafone account when connected to my work account which is telecom.
The error is showing
Sender address  "mine" was rejected by the server.

Followed this link;
http://help.vodafone.co.nz/app/answers/detail/a_id/5288/~/vodafones-email-settings-for-your-pc-or-tablet
And believe the fail point is due to my outbound settings being like I was connected to my home connection, have tried adding another smtp server including the required SSL and my account settings and the message coming back is that it is rejected by the server.
What is likely to cause this? Telecom blocking access, or something else I need to tweak in my settings?

Cheers


Edit-Defo something on my settings or Telecom, I connected the ipad to my phone using the original setup and all mails cleared.
Never noticed this before?!!?!

Filter this topic showing only the reply marked as answer Create new topic
19282 posts

Uber Geek
+1 received by user: 2600
Inactive user


  Reply # 1236480 12-Feb-2015 12:25
Send private message

You are trying to relay email from a Spark internet connection via the Vodafone smtp server so we will reject it,

When you added the new smtp server address what did you add?



428 posts

Ultimate Geek
+1 received by user: 130


  Reply # 1236513 12-Feb-2015 12:54
Send private message


smtp.Vodafone.co.nz
user name
password
SSL ON
Port 25

Was rejected saying server was not responding.



19282 posts

Uber Geek
+1 received by user: 2600
Inactive user


  Reply # 1236816 12-Feb-2015 20:35
Send private message

You need to use the smtp server address / settings for the ISP you are connected to



428 posts

Ultimate Geek
+1 received by user: 130


  Reply # 1236914 13-Feb-2015 07:26
Send private message

Ok, thanks for that.
Never noticed it not working before but this is not a primary account. Likely been this was for ages ( I'm observent!)

BDFL - Memuneh
61503 posts

Uber Geek
+1 received by user: 12219

Administrator
Trusted
Geekzone
Lifetime subscriber

  Reply # 1236917 13-Feb-2015 07:39
One person supports this post
Send private message

Actually different things in play there.

First most ISPs only relay emails from their own connections. You get around this when connecting from other ISPs by using an authenticated connection so your ISP knows it's you even though not using their network.

You're right in using the SSL and that SHOULD solve the case (despite John's comments).

The second problem, the one REALLY affecting you is that Spark blocks outgoing connections to port 25 leaving their network, to prevent hijacked PCs from sending spam.

If you want your Spark connection to be allowed to connect to other SMTP servers then you need to request this feature here.




19282 posts

Uber Geek
+1 received by user: 2600
Inactive user


  Reply # 1236921 13-Feb-2015 08:24
Send private message

enable smtp authentication and use same details as used for incoming server, Then email should send no matter what ISP you are connected to

BDFL - Memuneh
61503 posts

Uber Geek
+1 received by user: 12219

Administrator
Trusted
Geekzone
Lifetime subscriber

  Reply # 1236938 13-Feb-2015 08:26
One person supports this post
Send private message
19282 posts

Uber Geek
+1 received by user: 2600
Inactive user


  Reply # 1236962 13-Feb-2015 08:38
Send private message

You can do this online if you are the account holder

http://help.spark.co.nz/app/answers/detail/a_id/1218



428 posts

Ultimate Geek
+1 received by user: 130


  Reply # 1237142 13-Feb-2015 11:01
Send private message

OK
Can I leave the primary server as Vodafone (home account) and add the spark smtp as a secondary for when I am in the office?
No issues requesting an un-block, but what does that open me to from outside spam attacks?


BDFL - Memuneh
61503 posts

Uber Geek
+1 received by user: 12219

Administrator
Trusted
Geekzone
Lifetime subscriber

  Reply # 1237145 13-Feb-2015 11:04
Send private message


428 posts

Ultimate Geek
+1 received by user: 130


  Reply # 1237150 13-Feb-2015 11:13
Send private message

johnr: enable smtp authentication and use same details as used for incoming server, Then email should send no matter what ISP you are connected to


What s involved here?
I don't see anything related to SMTP authentication in the settings




428 posts

Ultimate Geek
+1 received by user: 130


  Reply # 1237151 13-Feb-2015 11:16
Send private message

freitasm: It's for OUTGOING connections, not incoming, so it won't open you to any inbound messages.



Cheers
Will fill it out and see if they allow me the privilege!
Not fully understanding this, it seems like it been made harder than it needs to be for sending mail.

BDFL - Memuneh
61503 posts

Uber Geek
+1 received by user: 12219

Administrator
Trusted
Geekzone
Lifetime subscriber



428 posts

Ultimate Geek
+1 received by user: 130


  Reply # 1237157 13-Feb-2015 11:29
Send private message

freitasm: Not harder. Safer.


Fair call
For average Joe like me, I expected to be able to aquire a connection and send e-mail regardless of what provider.  Will educate myself as to why these are restricted though.
Thanks for the input



Filter this topic showing only the reply marked as answer Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.