Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




17 posts

Geek


# 177673 11-Aug-2015 10:55
Send private message

Hi All, I am new to this however have got incoming calls to work.
I am unsure if I have got my peer details correctly
they are as follows

type=peer
fromuser=my nnumber
host=pan.wxnz.net
insecure=invite,port
canreinvite=no
nat=yes
secret=my password

I have tried many different combinations of settings from forums
but have come up unsuccessful. Any help with this matter would 
be greatly appreciated.




Filter this topic showing only the reply marked as answer View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2
571 posts

Ultimate Geek

Trusted
Lifetime subscriber

  # 1362705 11-Aug-2015 11:24
Send private message

Others more qualifed than me will likely pipe up and more than likely say this is a NAT problem.

Have you made sure you have SIP ALG turned off in your router, this usually borks things up.

http://www.voip-info.org/wiki/view/Routers+SIP+ALG




17 posts

Geek


  # 1362712 11-Aug-2015 11:28
Send private message

Hi 

due to having 2 servers on site, we have modified port settings of this server to 5070, we are registering with WXNZ and are receiving calls
just not dialling out. Our other server is working fine but connecting to 2Talk

 
 
 
 


266 posts

Ultimate Geek


  # 1362901 11-Aug-2015 15:17
Send private message

Hi, have you had a look on at your SIP traffic when you attempt to make a call out?

I can see that we challenge your INVITE and never get a new INVITE with the auth info added to it, then you keep sending us the same initial INVITE, this leads to the call to fail as it has not been authorized:



What we would expect to see, is once you receive the 401 Unauthorized challenge (if this challenge makes it to your PBX in the first place), is a new INVITE with added auth info.

Regards,
Andrei.

28199 posts

Uber Geek

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  # 1362910 11-Aug-2015 15:25
Send private message

Those settings are incorrect and insufficient to have a working trunk. Correct settings are here on GZ if you use the search.

 



17 posts

Geek


  # 1363169 11-Aug-2015 20:26
Send private message

Hi Andrei,

Thanks for your reply, I shall research this tomorrow and see if I can get it resolved

28199 posts

Uber Geek

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  # 1363174 11-Aug-2015 20:36
Send private message

joshpotter: Hi Andrei,

Thanks for your reply, I shall research this tomorrow and see if I can get it resolved


That's occurring because you don't have a username field in your trunk settings.

Follow the correct settings that are on here and it'll work fine.

Assuming you're also using something higher than Asterisk 1.8 nat=yes is also obsolete, so you should be using the appropriate setting as required.





17 posts

Geek


  # 1363194 11-Aug-2015 21:02
Send private message

Hi as I have said I have tried many different settings in this, including all security passwords and users, but I find if I have it all in there then it comes back with all lines are busy

 
 
 
 


28199 posts

Uber Geek

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  # 1363200 11-Aug-2015 21:14
Send private message

Your settings above are not the ones listed on here in the VFX Asterisk post - you need username for a start which is the cause of the failed outbound call.

The outbound routen error is a generic message, but until you use the correct trunk settings you can't diagnose it further.



17 posts

Geek


  # 1363216 11-Aug-2015 21:32
Send private message

Hi is this my phone number or my authenticated user I'd? I have had this as the start previously with many other settings but have not had it working ever, outgoing however was easy which also has all of the authentication



17 posts

Geek


  # 1363218 11-Aug-2015 21:37
Send private message

If someone could give me the now required settings for peer that would be so helpful. I am using freepbx 6

28199 posts

Uber Geek

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  # 1363366 12-Aug-2015 07:11
Send private message

I'm guessing right now you still haven't used the correct VFX settings that are listed here on GZ in a sticky post at the top of this forum (http://www.geekzone.co.nz/forums.asp?forumid=65&topicid=17174)

This is what you should be using. Ignore anything elsewhere. The only thing you'll need to decide on is your codec support, but this is going to depend on what you support, but at a bare minimum you need to have support got G.711 alaw

There is no FreePXB6 - what version are you using?



266 posts

Ultimate Geek


  # 1363382 12-Aug-2015 07:55
Send private message

From what I can tell it's v12 :

User-Agent: FPBX-12.0.74(11.18.0)



17 posts

Geek


  # 1363384 12-Aug-2015 08:03
Send private message

Hey Grudge

Yes it is on the website, it is really confusing, as when you install and download it, it says it is 6, but yes we downloaded version 12



17 posts

Geek


  # 1363394 12-Aug-2015 08:30
Send private message

sbiddle: I'm guessing right now you still haven't used the correct VFX settings that are listed here on GZ in a sticky post at the top of this forum (http://www.geekzone.co.nz/forums.asp?forumid=65&topicid=17174)

This is what you should be using. Ignore anything elsewhere. The only thing you'll need to decide on is your codec support, but this is going to depend on what you support, but at a bare minimum you need to have support got G.711 alaw

There is no FreePXB6 - what version are you using?




Hi 

I am using 12, also these settings look like they are for a different system, I have seen this post before and have tried putting 

[VFX]

type=peer
fromdomain=pan.wxnz.net
fromuser=VFXNumber ; this is your VFX Number without the leading 0 i.e. 9950XXXX
host=pan.wxnz.net
insecure=invite,port
canreinvite=no
nat=yes
secret=PASSWORD
username=USERID

into the peer details and have had no luck, is this just because I am trying to use a different port for communication due to 2 servers. If i take the server to site and connect it will it just work if i change everything back to use port 5060, as has been said on here i am not getting authenticated, this could be because I am not receiving the string from WXC as my port is different?


266 posts

Ultimate Geek


  # 1363401 12-Aug-2015 08:41
Send private message

Your "fromuser" may be with the leading 0, check the email you received and if your userid has the phone number with a leading 0 then use that instead.

Yep just double checked your UserID has the leading 0.

 1 | 2
Filter this topic showing only the reply marked as answer View this topic in a long page with up to 500 replies per page Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

OPPO Showcases New CameraX Capabilities at Google Developer Days China 2019
Posted 15-Sep-2019 12:42


New Zealand PC Market returns to growth
Posted 15-Sep-2019 12:24


Home sensor charity director speaks about the preventable death which drives her to push for healthy homes
Posted 11-Sep-2019 08:46


Te ao Maori Minecraft world set to inspire Kiwi students
Posted 11-Sep-2019 08:43


Research reveals The Power of Games in New Zealand
Posted 11-Sep-2019 08:40


Ring Door View Cam now available in New Zealand
Posted 11-Sep-2019 08:38


Vodafone NZ to create X Squad
Posted 10-Sep-2019 10:25


Huawei nova 5T to be available 20th September
Posted 5-Sep-2019 11:55


Kogan.com launches prepay challenger brand Kogan Mobile in New Zealand
Posted 3-Sep-2019 11:42


Pagan Online available now
Posted 27-Aug-2019 20:22


Starship hopes new app will help combat antibiotic resistance challenges
Posted 27-Aug-2019 19:43


Intel expands 10th Gen Intel Core Mobile processor family
Posted 23-Aug-2019 10:22


Digital innovation drives new investment provider
Posted 23-Aug-2019 08:29


Catalyst Cloud becomes a Kubernetes Certified Service Provider (KCSP)
Posted 23-Aug-2019 08:21


New AI legaltech product launched in New Zealand
Posted 21-Aug-2019 17:01



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.