Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


47 posts

Geek


Topic # 192334 7-Mar-2016 10:26
Send private message

Hi,

 

I have a Fibre connection with Vodafone, with a Static IP.

 

I have the Fibre modem box, which then over ethernet connects to the standard VF router (Huawei Home Gateway HG659).

 

Everything works fine; expect for the fact this router/home gateway does not support LAN Loopback, which causes problems for my internet network

 

For background and "Why?" -- I am running a server on a publicly accessible IP, but without LAN Loopback funtionality, when within the LAN you cannot access the server - common problem and LAN Loopback feature resolves this... but this doesn't support LAN Loopback)

 

So I am trying to configure another router instead and have having trouble.

 

Using the TP-Link TD-W8980; this is a modem router ("N600 Wireless Dual Band Gigabit ADSL2+ Modem Router") but also has "Wireless Router Mode", i.e. turning off ADSL as just acting as my router.

 

Wireless Router Mode: https://goo.gl/gCUN9y

 

Once in this mode, within WAN settings I have entered my static IP, primary and secondary DNS servers and the default gateway; all of which were taken from the Ethernet Settings displayed on the standard Vodafone HG659:

 

IPv4 address: 203.xxx.xxx.51
Subnet Mask: 255.255.255.0 (this isn't shown on the HG659 but was confirmed with a phone call to VF IT)
IPv4 primary DNS server: 203.109.191.1
IPv4 secondary DNS server: 203.118.191.1
IPv4 default gateway: 203.118.129.254

 

Screenshot: https://goo.gl/QKr9EN

 

The Status screen then looks ok: https://goo.gl/IyWZP9 -- reports connected.

 

But, nope, it doesn't work; there is no internet connection available on the LAN.

 

The logs also report a few notices: https://goo.gl/7BMXkl

 

And the Diagnostic Tool cannot ping the default gateway (testing WAN): https://goo.gl/jyNaLY

 

I also tried the same as above, but left the optional settings (gateway and dns) blank: https://goo.gl/ZVW9NJ

 

Same issue though, no internet connection on the LAN - PCs on the LAN cannot ping the gateway, google etc.

 

I have tried the same on another router (Netgear WNR2000) again with no luck.

 

I rang VF technical support and they could offer no help at all; just told me all the settings I need are shown in the Internet_Ethernet screen of the HG659 (i.e. IP, gateway, DNS).

 

So any advice would be most appreciated, whether these routers would never support this set up for whatever reason (is the VF fibre modem > WAN different from "usual ASDL modem?" or do I have a setting wrong somewhere? Part of me thinks the gateway on the router should be a local IP address of the fibre modem but not sure what this is (it's obviously not on the LAN created by the router 192.168.1.x).

 

At the same time as I have the TP Link router (WAN port (LAN4/WAN)) connected to the Fibre Modem (LAN port 1), I have the HG659 connected (WAN port) as well using LAN 4 port of the Fibre modem, and it works fine.

 

Or, if no idea why it's not working, can anyone recommend a Fibre Router which definitely works with VF Fibre and supports LAN loopback?

 

Many thanks in advance

 

Rob

 

 

 

 


Create new topic
26792 posts

Uber Geek
+1 received by user: 6270

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  Reply # 1507370 7-Mar-2016 11:27
Send private message

I thought all Vodafone UFB was DHCP?

 

Based on my experience the majority of routers out there these days don't support hairpin NAT.

 

 




47 posts

Geek


  Reply # 1507376 7-Mar-2016 11:36
Send private message

sbiddle:

 

I thought all Vodafone UFB was DHCP?

 

 

No idea; is there different settings I should therefore try?

 

 

 

sbiddle:

 

Based on my experience the majority of routers out there these days don't support hairpin NAT.

 

 

 

Not familiar with hairpin NAT; is it required for the VF Fibre Modem connection?

 

 


26792 posts

Uber Geek
+1 received by user: 6270

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  Reply # 1507383 7-Mar-2016 11:45
Send private message

Hairpin NAT is the more common name for the "loopback" functionality you described.

 

If your fibre connection if DHCP when you should be configuring your router for DHCP. A static IP will not work.

 

 

 

 




47 posts

Geek


  Reply # 1507407 7-Mar-2016 12:30
Send private message

sbiddle:

 

Hairpin NAT is the more common name for the "loopback" functionality you described.

 

If your fibre connection if DHCP when you should be configuring your router for DHCP. A static IP will not work.

 

 

 

Both the two routers I have (TP Link and Netgear) and am trying to set up support Lan Loopback so that's not an issue - I have a device which will support it once I can get the fibre working.

 

I have a static IP from Vodafone hence why I set it up as static.

 

But even if I change the EWAN settings to Dynamic IP, it still doesn't work; it doesn't obtain any IP Address, subnet mask or gateway and fails trying to obtain them.

 

Cheers

 

Rob


1227 posts

Uber Geek
+1 received by user: 279


  Reply # 1507416 7-Mar-2016 12:48
One person supports this post
Send private message

Vodafone UFB is provisioned as tagged UNI as such you need to configure the WAN interface for tagging. It is usually referred to as Vlan Mux mode on those routers.

 

 

I would check what options are available under the hidden 'Advance' section on the 'EWAN settings' page, otherwise you will need to check whether there is a firmware upgrade that supports Vlan Mux mode or whether it can be configured through the command line interface.

26792 posts

Uber Geek
+1 received by user: 6270

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  Reply # 1507425 7-Mar-2016 13:04
One person supports this post
Send private message

Ahh yeah as above you will need VLAN10 tagging - if your hardware doesn't support this you'll need to look at buying better hardware than does support this or buying something such as a Mikrotik or cheap switch and follow the guides I've posted to add the tagging to non VLAN capable hardware.

 

 


2906 posts

Uber Geek
+1 received by user: 1098

Subscriber

  Reply # 1512160 13-Mar-2016 00:06
Send private message

Simplest way to access your Web site locally. Add your domain name to your hosts file and the local IP of the Web server. If you are going to buy a Mikrotik or Edge router to remove the VLAN tags. You might as well just use it as your main router.







47 posts

Geek


  Reply # 1512246 13-Mar-2016 12:27
Send private message

Aredwood: Simplest way to access your Web site locally. Add your domain name to your hosts file and the local IP of the Web server.

 

 

Hey,

 

Yeah, thanks but that isn't a feasible option for what I need to do due to the multitude of devices (unrooted phones, other peoples computers etc) which would need access and therefore cannot rely on host file entries.

 

Will investigate the router settings more now

 

Cheers

 

 


511 posts

Ultimate Geek
+1 received by user: 80

Subscriber

  Reply # 1512269 13-Mar-2016 13:12
Send private message

can u not add a static host in the Mikrotik router www.myhost.co.nz = 192.168.1.16 or so ???? so internally hosts will do a dns query for said domain from Mikrotik router, then receive the internal ip and go from there?






26792 posts

Uber Geek
+1 received by user: 6270

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  Reply # 1512745 14-Mar-2016 09:29
Send private message

phantomdb:

 

can u not add a static host in the Mikrotik router www.myhost.co.nz = 192.168.1.16 or so ???? so internally hosts will do a dns query for said domain from Mikrotik router, then receive the internal ip and go from there?

 

 

 

 

No need. If you're using a Mikrotik you'd simply configure hairpin NAT. By default (like many routers) it won't do it out of the box.

 

 




47 posts

Geek


  Reply # 1512747 14-Mar-2016 09:33
Send private message

sbiddle:

 

phantomdb:

 

can u not add a static host in the Mikrotik router www.myhost.co.nz = 192.168.1.16 or so ???? so internally hosts will do a dns query for said domain from Mikrotik router, then receive the internal ip and go from there?

 

 

 

 

No need. If you're using a Mikrotik you'd simply configure hairpin NAT. By default (like many routers) it won't do it out of the box.

 

 

 

 

 

 

Nope, I'm not using a Mikrotic router; have a TP Link and Netgear one, which DO support hairpin nat, but doesn't support VF UFB.

 

And the VF UFB modem doesn't support hairpin nat (or static hosts) hence my original post.

 

 

 

I have ordered a new Asus Router which will do it all plus some (ASUS RT-AC68U)

 

Cheers


Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Intel introduces new NUC kits and NUC mini PCs
Posted 16-Aug-2018 11:03


The Warehouse leaps into the AI future with Google
Posted 15-Aug-2018 17:56


Targus set sights on enterprise and consumer growth in New Zealand
Posted 13-Aug-2018 13:47


Huawei to distribute nova 3i in New Zealand
Posted 9-Aug-2018 16:23


Home robot Vector to be available in New Zealand stores
Posted 9-Aug-2018 14:47


Panasonic announces new 2018 OLED TV line up
Posted 7-Aug-2018 16:38


Kordia completes first live 4K TV broadcast
Posted 1-Aug-2018 13:00


Schools get safer and smarter internet with Managed Network Upgrade
Posted 30-Jul-2018 20:01


DNC wants a safer .nz in the coming year
Posted 26-Jul-2018 16:08


Auldhouse becomes an AWS Authorised Training Delivery Partner in New Zealand
Posted 26-Jul-2018 15:55


Rakuten Kobo launches Kobo Clara HD entry level reader
Posted 26-Jul-2018 15:44


Kiwi team reaches semi-finals at the Microsoft Imagine Cup
Posted 26-Jul-2018 15:38


KidsCan App to Help Kiwi Children in Need
Posted 26-Jul-2018 15:32


FUJIFILM announces new high-performance lenses
Posted 24-Jul-2018 14:57


New FUJIFILM XF10 introduces square mode for Instagram sharing
Posted 24-Jul-2018 14:44



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.