Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


View this topic in a long page with up to 500 replies per page Create new topic
1 | 2 | 3
11 posts

Geek


Reply # 24670 13-Dec-2005 13:30
Send private message

ddan,

Saw your other thread, lets hope we get some response.

I have been doing some investigating over past few days about cable networks, modems and routers.

At first I thought the cable modem was the cause of our problems as I found a reivew on the net from someone with the same modem and they had the same thing as us. They ended up purchasing a new modem (which unfortunately we can't do) and their problem went away.

I went into the modem's configuration (http://192.168.100.1) and reset everything to the default settings. This wipes all of the modem's learned MAC addresses. I restarted the modem so it could just learn the router's MAC address. Didn't work.

I have found out that cable networks can block certain MAC addresses, so I cloned my PC's MAC address into the router and did the same thing as above. Didn't work.

Although trying the above didn't completly work, I did improve my connectivity from about 1% to 50%, allbeit this only lasted until everything was powered off and on and now I am back to nothing again.

I also found an interesting forum which might shed some light on what our problem could be. (Not exactly sure how to post links here so I'll just paste it.)

http://www.cable-modems.org/forum/read.php?f=2&i=497&t=497

It is quite a long thread so I'll quote the main thing from someone who sounds like they know what they're talking about:

[start]Re: Comcast Linksys Router Problem
Author: Chip Schweiss (---.stl1.dsl.speakeasy.net)
Date: 05-29-05 22:05

I've been investigating this problems for quite the past several days. My background is very in depth with TCP/IP problem diagnosis at the network level, including writing my own TCP stack.

I've been examining the behavior of Linksys WRT54G(s) routers against Charter Pipeline by sniffing the packets on the wire as DHCP happens.

It looks to me that this truely is an ongoing problem of the cable companies believing they have a right to charge for every computer connected to the cable connection, just as they want to charge for every television set. The fed says they cannot, so they have to play technical warfare against routers. It just amases me the arrogance of Charter when I can prove the router working on any network besides theirs, and they will still say your router is broken.

DHCP is a very simple protocal, but has some very distinct fitures that give router devices away from Windows machines. Part of the DHCP discovery packet is an identifier of the client software sending the DHCP request. The MAC address seems to be the first approach the cable companies have taken against routers since the first part of all mac addresses identifies the manufacture of the ethernet device. Since MAC clone is a standard feature of many retail routers this has proven not to be that effective. The next step is to identify by the contents of the DHCP packets themselves. Since most routers are either embeded Linux or other platforms that fit in small packages they use specialty DHCP clients. I'd bet that nearly 90% of the home based routers (Linksys, Belkin, etc.) all use udhcpc which is part of the busybox package for embeded devices. This client clearly identifies itself in the DHCP discovery packet. Not to hard at all to detect.

I'm going to have a hack at udhcpc on my Linksys router and make it mimic a Windows XP DHCP client. I wouldn't be surprised all I have to do is change the client identification in the discovery packet to match Windows and all the problems will go away.

Once I have a solution to this problem these bastard cable companies keep saying "It's your unsupported router" I'll be the first to turn the proof of their nasty ways over to Linksys (Cisco) so they can sue Charter for anti-competive practics which the Fed has forbiden them from doing as part of their bargain to maintain a monopoly on the cable lines.[end]

If the above is correct then telstra is our problem and a big one at that. There are two things we could try:

1. Tricking telstra into thinking our routers are actually PC's (as above).
2. Hiding our routers behind something (my router worked at the PC shop because it was hidden behind a switchboard or something like that and the telstra couldn't see it).

Another thing I thought of is that telstra must have done some sort of software upgrade to their network around the end of last month, which would explain the fact that both our routers were working before and all of a sudden they stopped.

I am just typing this up at work and the IT guy just walked in so I asked him about it. He said that telstra has just done upgrades, but this was for the new digital tv and only in certain areas. He asked me to bring my router to work and he will test it at home on his cable network. Will let you know how that goes later.

Sorry this post is so big, I just thought I should share everything I find out in the hope that someone out there might be able to help us.



15 posts

Geek


Reply # 24671 13-Dec-2005 14:32
Send private message

Hi ktwhy,

thanks, that was great info, I will delve a little deeper into those links. Telstra have assured me on many occasions that it is not them and they have no need to block routers, so its starting to get interesting now.

I too have tried most of what you did, i.e. clone mac address of my PC and by directly looking at the cable modem settings.
One thing I noticed, is that at one stage with the d-link, when I would save a setting, I would suddenly get connectivity for about 1 second, then it would stop!?!

And as you suggested in 2) hiding my router behind a PC works great, no problems at all. This is my current "solution", although its not ideal as I have had to sacrifice my mame station PC and put it in the lounge by the cable outlet. :-(

Looking at the sinister side of things, the cable modem acquired the router MAC address even behine a PC and this still works, so they are obviously not blocking using MAC addresses or this would still block me. You can get your IT guy to test your router but I bet there is nothing wrong with it, as I still use my original router and it works fine.

(You have probably already done this but...)
In order to setup something that works, by fronting up with a PC, you just need to buy a 2nd network card ($13 at DSE), then setup the TCP/IP on that box with your static IP (standard TCL settings), then turn on Internet Connection Sharing (by default this will give your second port an IP Address of 192.160.0.1), plug this into the WAN port of your router.
Setup your routers public ip to something like 192.168.0.2, the gateway becomes your static ipaddress (i.e. 218.101.50.*) leave the routers private address at the default 192.168.1.1 (for linksys anyway)
(I believe the public/private addresses need to be on different subnets, so you may need to switch this around with your D-Link as it is 192.168.0.1 by default), then the rest of your network should spring back to life (mine did and has worked fine ever since). Bit of a pain though, if you are hosting servers you have to setup your port forwarding from the gateway PC to the router and then on to the private network.
Alternatively you can install a software firewall (Zone alarm, or use windows firewall) on the gateway PC, and then just use the LAN ports of your router. The router settings are then irrelevant as you are just using it as a switch. I didn't do this as I didn't trust windows firewall and you need the commercial version of Zone alarm to do port forwarding.




 
 
 
 


4699 posts

Uber Geek
+1 received by user: 75

Trusted

Reply # 24678 13-Dec-2005 15:42
Send private message

This all sounds very sinister. Have you guys tried a different brand of router? I have been using a Dlink for the past 3 years, switched to a Belkin Wireless A+G WAP router and now another Dlink wireless router and I have never had any problems with the router




System One: Popcorn Hour A200,  PS3 SuperSlim, NPVR and Plex Server running on Gigabyte Brix (Windows 10 Pro), Sony BDP-S390 BD player, Pioneer AVR, Raspberry Pi running Kodi and Plex, Panasonic 60" 3D plasma, Google Chromecast

System Two: Popcorn Hour A200 ,  Oppo BDP-80 BluRay Player with hardware mode to be region free, Vivitek HD1080P 1080P DLP projector with 100" screen. Harman Kardon HK AVR 254 7.1 receiver, Samsung 4K player, Google Chromecast

 


My Google+ page 

 

 

 

https://plus.google.com/+laurencechiu

 

 




15 posts

Geek


Reply # 24680 13-Dec-2005 16:14
Send private message

Yes, I have tried a Linksys and a D-Link, both exhibit the same behaviour. Given that the routers work fine when placed on other peoples networks, and work fine on my own network behind a PC, I don't think that the make or configuration of the router is the problem.

I think Ktwhy can confirm this behaviour as well.

11 posts

Geek


Reply # 24735 14-Dec-2005 16:08
Send private message

Yes I can.

My router was tested today and didn't work with my IP address, etc., but it did with the IT guy's one.

He phoned telstra who finally have admitted there is a problem with the line and it is affecting everyone in that IP range. Why they don't inform people is beyond me.

Anyway the telstra tech is coming tomorrow to look at the lines. Apparently all we may have to do is request a new IP address.

My IT person did think it was funny that it still worked when connected directly to the PC, so he is gone off to test my router further.

I have just had a call from telstra who gave me a new IP address, I have phoned this through to my IT and he is going to test it for me. If it doesn't work I have to give telstra a call back ... fingers crossed!

I will keep you posted.

11 posts

Geek


Reply # 24739 14-Dec-2005 16:41
Send private message

Router tested unsuccessful, but the IT guy says it probably just doesn't work in his area as there are specific IP's for each area (I think that's what he meant). Also apparently the 218 range is a fairly new one and that it is different from all the others.

I get the router back tomorrow so I'll let you know how it goes.



15 posts

Geek


Reply # 24740 14-Dec-2005 16:46
Send private message

Awesome, let me know if the new IP works.

Also when you switched IP addresses did they make you change to a new plan?


11 posts

Geek


Reply # 24746 14-Dec-2005 19:02
Send private message

Hey ddan,

I got an email saying there was a new post on here and the main page says you posted at 16:46, but I can't see it anywhere.

Can you post again?

Thanks,
ktwhy

BDFL - Memuneh
59053 posts

Uber Geek
+1 received by user: 10336

Administrator
Trusted
Geekzone
Subscriber

Reply # 24747 14-Dec-2005 19:05
Send private message
11 posts

Geek


Reply # 24749 14-Dec-2005 19:17
Send private message

ddan: Awesome, let me know if the new IP works.

Also when you switched IP addresses did they make you change to a new plan?



No, they just gave me the new number.

25576 posts

Uber Geek
+1 received by user: 5357

Moderator
Trusted
Biddle Corp
Subscriber

Reply # 24750 14-Dec-2005 20:33
Send private message

I have had an IP in the past that just "died" as well, I was able to access the net find and ping my gateway but was unable to access other TCL modems of a different subnet. After struggling with TCL's helpdesk who kept telling me this was perfectly normal and that a cable modem customer wasn't able to access a website hosted on another cable machine I gave up and got my IP changed by a somebody I know who works for them and the problem went away.

In regards to the router problem, TCL are now well aware of this issue and are definately looking into it. Without going into detail the issue only affects some brands of routers and will not affect a Windows or Linux PC hooked up straight to the cable modem. Hopefully a fix won't be too far away.

11 posts

Geek


Reply # 24810 15-Dec-2005 16:16
Send private message

Thanks for the info, sbiddle.

Problem Solved My router works fine with the new IP address ... well so far so good anyway. Hope it works out for you too ddan, post back when you have tried it and let me know.



15 posts

Geek


Reply # 24869 16-Dec-2005 15:44
Send private message

Got a new IP Address and now everything works perfectly!!!

I hate to think how many hours I've wasted on this.

It took me a while to convince the help desk to give me a new IP. Finally after dropping your name and your IP and after being put on hold a few times, they agreed to give me a new one.
They never admitted a fault, just pretty much went... there you are have a nice day.

Oh well I guess that's the end of that (until next time)
I would still like to know what the problem was for future reference... I emailed a support request to them a few days ago so it will be interesting to see if that gets a response.


11 posts

Geek


Reply # 24874 16-Dec-2005 16:57
Send private message

ddan,

I'm glad it all worked out for you.

I think telstra are so rude, their customer service really sucks. If they weren't the only cable internet company around I would've left them ages ago.

I will ring Robert at PCU and let him know in case he gets any other customers with the same problem.

6 posts

Wannabe Geek


Reply # 26226 12-Jan-2006 09:53
Send private message

Hi guys, just got 2Mbit cable on monday. Connected it to a router yesterday and it was great... for 10-20 seconds!!! Checking router logs and there are lots of timeout / unknown errors followed by another 10-20 seconds of it working.

Was going to call telstra last night but it was busy. Any suggestions in what I should say in convincing them to change my IP address?

Cheers.

1 | 2 | 3
View this topic in a long page with up to 500 replies per page Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

UFB killer app: Speed
Posted 17-Nov-2017 17:01


The case for RSS — MacSparky
Posted 13-Nov-2017 14:35


WordPress and Indieweb: Take control of your online presence — 6:30 GridAKL Nov 30
Posted 11-Nov-2017 13:43


Chorus reveals technology upgrade for schools, students
Posted 10-Nov-2017 10:28


Vodafone says Internet of Things (IoT) crucial for digital transformation
Posted 10-Nov-2017 10:06


Police and Facebook launch AMBER Alerts system in NZ
Posted 9-Nov-2017 10:49


Amazon debuts Fire TV Stick Basic Edition in over 100 new countries
Posted 8-Nov-2017 05:34


Vodafone VoIP transition to start this month
Posted 7-Nov-2017 12:33


Spark enhances IoT network capability
Posted 7-Nov-2017 11:33


Vocus NZ sale and broadband competition
Posted 6-Nov-2017 14:36


Hawaiki reaches key milestone in landmark deep-sea fibre project
Posted 4-Nov-2017 13:53


Countdown launches new proximity online shopping app
Posted 4-Nov-2017 13:50


Nokia 3310 to be available through Spark New Zealand
Posted 4-Nov-2017 13:31


Nest launches in New Zealand
Posted 4-Nov-2017 12:31


Active wholesale as Chorus tackles wireless challenge
Posted 3-Nov-2017 10:55



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.