I've also discovered that some Samsung TVs have similar behaviour. Turning the Power Save option off for these models will stop this automatic brightness change.

Gary