Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


View this topic in a long page with up to 500 replies per page Create new topic
1 | 2 | 3
tonyhughes

Hawkes Bay
8477 posts

Uber Geek

Mod Emeritus
Trusted
Lifetime subscriber

  #59531 1-Feb-2007 18:56
Send private message

I have outbound calling from Asterisk > SPA3102 > WAG54GP2 working perfectly, but not inbound.
Inbound calls are hitting the SPA3102 just fine, but after 5 or so rings, I just get a shaky dial tone coming back to me (from the SPA3102, not Asterisk). The call is not hitting the Asterisk logs at all.

Any ideas?







tonyhughes

Hawkes Bay
8477 posts

Uber Geek

Mod Emeritus
Trusted
Lifetime subscriber

  #59536 1-Feb-2007 19:18
Send private message

okay, i now have the calls hitting asterisk, and i guess the dialtone i was getting was from asterisk after all.

Trouble is, not matter what i dial with that new tone, I get a message saying "the number you have dialled is not in service, please check the number and try again".

The report in FreePBX says the destination for that incoming call was "s" and i cant get it to ring to any extensions, or ring groups.

There is no DISA or other routes affected this, I deleted all my inbound routes and created one of any/any that rings a known working extension.







 
 
 
 


sbiddle
29273 posts

Uber Geek

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  #59543 1-Feb-2007 20:42
Send private message

Where did you get the SPA3102 & Asterisk settings from Tony, another website?


tonyhughes

Hawkes Bay
8477 posts

Uber Geek

Mod Emeritus
Trusted
Lifetime subscriber

grant_k
3539 posts

Uber Geek

Trusted

  #59553 1-Feb-2007 22:12
Send private message

tonyhughes: Trouble is, not matter what i dial with that new tone, I get a message saying "the number you have dialled is not in service, please check the number and try again".

That is a VFX message you're hearing (recorded by Neil Waka).

What this means is that your incoming calls are being turned around and sent back out to VFX again through the WAN (Internet) port of the SPA3102.

That's strange...

Not having played with Asterisk, I can't offer any suggestions as to why this might be happening Frown but no doubt Steve or one of the other Asterisk Gurus will have some ideas.

tonyhughes

Hawkes Bay
8477 posts

Uber Geek

Mod Emeritus
Trusted
Lifetime subscriber

  #59555 1-Feb-2007 22:36
Send private message

most definitely not neil waka. its a north american female. very asterisk-esque







grant_k
3539 posts

Uber Geek

Trusted

  #59556 1-Feb-2007 22:43
Send private message

That's interesting.  The wording is almost EXACTLY the same as VFX use.  Here is what Neil Waka says:

"The number you have dialled is not in service, please check the number and try your call again".

Only 2 words different, hence my assumption (without knowing the details) that it was a VFX message.

Hmmm... the plot thickens...

 
 
 
 


tonyhughes

Hawkes Bay
8477 posts

Uber Geek

Mod Emeritus
Trusted
Lifetime subscriber

  #59608 2-Feb-2007 16:42
Send private message

I have the following working...

Inbound and outbound trunks for

Skype (using Uplink from a Windows box - works great, but havent figured out + dialling yet!!)
FWD
sipserve.co.nz
freecall.com
PSTN (x100p PCI card)
faktortel
sipphone.com

and outbound calling working fine on the SPA3102, but still no INCOMING - AArrrGGghh.

I had no set allow anonymous inbound SIP calls to yes in FreePBX, and this was affecting some trunks, but made no difference to the SPA3102.

I am considering ditching the SPA3102, and buying another x100p which works well plugged into the WAG54GP2 to provide the VFX connectivity.

I now have Asterisk in full time use at home finally.







grant_k
3539 posts

Uber Geek

Trusted

  #59612 2-Feb-2007 17:02
Send private message

tonyhughes: I am considering ditching the SPA3102, and buying another x100p which works well plugged into the WAG54GP2 to provide the VFX connectivity.

I now have Asterisk in full time use at home finally.

Well done Tony Smile

It's a very flexible setup you have there with access to all those SIP providers from your Asterisk box.  So now you can decide on the least-cost routing to outer Mongolia and program it accordingly with the Dial Plan Tongue out

The X100P cards sound like a much cheaper way to get FXO ports than the SPA3102.  I guess you can easily sell the SPA3102 on TradeMe and hopefully find another X100P card for around $70.

Can you get incoming calls from VFX working via the X100P card i.e.:

WAG54GP2 ==> X100P ==> Asterisk?

tonyhughes

Hawkes Bay
8477 posts

Uber Geek

Mod Emeritus
Trusted
Lifetime subscriber

  #59613 2-Feb-2007 17:11
Send private message

Grant17: Well done Tony Smile

It's a very flexible setup you have there with access to all those SIP providers from your Asterisk box. So now you can decide on the least-cost routing to outer Mongolia and program it accordingly with the Dial Plan Tongue out

The X100P cards sound like a much cheaper way to get FXO ports than the SPA3102. I guess you can easily sell the SPA3102 on TradeMe and hopefully find another X100P card for around $70.

Can you get incoming calls from VFX working via the X100P card i.e.:

WAG54GP2 ==> X100P ==> Asterisk?

^^^^^^^^^^^^^^^^^^^^^^^^^^^^ Yes this works perfectly, so would be the easiest way of doing it. I have now secured another x100p card, (which i couldnt get before), so thats going to be my best option i think.

I dont really need all those SIP trunks, but from a learning/knowledge point of view, its great.







tonyhughes

Hawkes Bay
8477 posts

Uber Geek

Mod Emeritus
Trusted
Lifetime subscriber

  #59676 3-Feb-2007 08:53
Send private message

After a LOT of stuffing around last night, had zero luck - I changed every relevant setting 1 or 2 at a time in different combinations on asterisk and the spa3102 with no avail.

This morning I altered the PSTN DP2 setting slightly....

from
(s0<:192.168.0.177>)

to
(S0<:192.168.0.177>)
(note the capital 'S')

and it starts working...

ugh.

Im not sure what other settings if any, helped it along the way.
I have managed to break my outbound capability on it, but I beleieve this is an Asterisk error, and should be quick to troubleshoot. I will post my Asterisk/SPA3102 config when I have outbound working again.

Darn - have already clicked buynow on the x100p card... maybe it will be useful for building a spare / test box...







sbiddle
29273 posts

Uber Geek

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  #59678 3-Feb-2007 09:09
Send private message

How is it that you've got a new baby and still have all this time to play with your toys? :-)

tonyhughes

Hawkes Bay
8477 posts

Uber Geek

Mod Emeritus
Trusted
Lifetime subscriber

  #59679 3-Feb-2007 09:10
Send private message

sbiddle: How is it that you've got a new baby and still have all this time to play with your toys? :-)

Play with toys while new baby and mom are still in hospital, and im home at night (or morning, waiting for them to be awake...)







tonyhughes

Hawkes Bay
8477 posts

Uber Geek

Mod Emeritus
Trusted
Lifetime subscriber

  #59680 3-Feb-2007 09:12
Send private message

Anyhoo.... just got ouotbound working again, will post all my spa/asterisk settings later. Am off to hospital now...







tonyhughes

Hawkes Bay
8477 posts

Uber Geek

Mod Emeritus
Trusted
Lifetime subscriber

  #59714 3-Feb-2007 21:29
Send private message

arrrgghhh brain fade, outbound not working, not sure what i did to it...







1 | 2 | 3
View this topic in a long page with up to 500 replies per page Create new topic





News »

Nanoleaf enhances lighting line with launch of Triangles and Mini Triangles
Posted 17-Oct-2020 20:18


Synology unveils DS16211+
Posted 17-Oct-2020 20:12


Ingram Micro introduces FootfallCam to New Zealand channel
Posted 17-Oct-2020 20:06


Dropbox adopts Virtual First working policy
Posted 17-Oct-2020 19:47


OPPO announces Reno4 Series 5G line-up in NZ
Posted 16-Oct-2020 08:52


Microsoft Highway to a Hundred expands to Asia Pacific
Posted 14-Oct-2020 09:34


Spark turns on 5G in Auckland
Posted 14-Oct-2020 09:29


AMD Launches AMD Ryzen 5000 Series Desktop Processors
Posted 9-Oct-2020 10:13


Teletrac Navman launches integrated multi-camera solution for transport and logistics industry
Posted 8-Oct-2020 10:57


Farmside hits 10,000 RBI customers
Posted 7-Oct-2020 15:32


NordVPN starts deploying colocated servers
Posted 7-Oct-2020 09:00


Google introduces Nest Wifi routers in New Zealand
Posted 7-Oct-2020 05:00


Orcon to bundle Google Nest Wifi router with new accounts
Posted 7-Oct-2020 05:00


Epay and Centrapay partner to create digital gift cards
Posted 2-Oct-2020 17:34


Inseego launches 5G MiFi M2000 mobile hotspot
Posted 2-Oct-2020 14:53









Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.