Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




309 posts

Ultimate Geek
+1 received by user: 32


Topic # 116608 4-May-2013 10:43
Send private message

I've got a Linksys SPA2101 at home, using 2talk (manual settings), was working OK but while talking on the phone the line would cut out at random, for a few seconds (so unable to hear caller).
A Grandstream VoIP phone on the same internet connection worked fine, no issues.

SPA2101 was running 5.2.12 firmware, so thought I would upgrade to 5.2.13, and then auto provision with 2talk.
Firmware upgrade failed, tried this: https://supportforums.cisco.com/docs/DOC-9907

Now the SPA2102 starts up (red LED flashes), then 2 green LED flash, then it switches off. This process then repeats, cycle of around 3-4 seconds.

Is it bricked?

I can't see any way to boot it up now?
Maybe time to buy a SPA122?

Create new topic
4804 posts

Uber Geek
+1 received by user: 1491


  Reply # 811145 4-May-2013 11:12
Send private message

Tried a different power supply?

26343 posts

Uber Geek
+1 received by user: 5918

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  Reply # 811148 4-May-2013 11:20
Send private message

How did you try and upgrade the firmware in the first place?

I manage literally hundreds of these and have only ever had one die. The red light isn't good though, suggesting you possibly have somehow bricked it.

 
 
 
 


Try Wrike: fast, easy, and efficient project collaboration software


309 posts

Ultimate Geek
+1 received by user: 32


  Reply # 811153 4-May-2013 11:27
Send private message

This was my upgrade attempt:

1. Download and run firmware upgrade application from here:
http://software.cisco.com/download/release.html?mdfid=282414111&softwareid=282463187&release=5.2.13

2. The upgrade application gave debug errors.
Quick google search found this page, which is the same error I got:
https://supportforums.cisco.com/thread/2156316

3. At the bottom of the forum above, I followed this suggested link to upgrade firmware via TFTP:
https://supportforums.cisco.com/docs/DOC-9907

4. Setup TFTP on my PC, tried upgrade, SPA2102 web page said device upgrade, don't reboot while LED flashing fast (which it was).
Not many seconds later, got the RED power LED, 2 green LED flashes, and cycle off/on (as described in first post).

Now unable to turn.
I don't have another power supply to try unfortunately.

4804 posts

Uber Geek
+1 received by user: 1491


  Reply # 811154 4-May-2013 11:30
Send private message

The reason I suggested a power supply is some of the older Linksys gear is prone to these failing, often with odd symptoms.

This may have been the cause of your original issues, as well as interfering with the firmware upgrade.

26343 posts

Uber Geek
+1 received by user: 5918

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  Reply # 811155 4-May-2013 11:31
Send private message

If you bricked it first time around TFTP isn't going to work.

Have you tried the SPA2102 firmware recovery application yet?





309 posts

Ultimate Geek
+1 received by user: 32


  Reply # 811488 5-May-2013 10:37
Send private message

sbiddle: Have you tried the SPA2102 firmware recovery application yet?


Where can I find this firmware recovery application?
Tried searching via google but nothing yet.

26343 posts

Uber Geek
+1 received by user: 5918

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  Reply # 811498 5-May-2013 11:27
Send private message

I'm not sure what you Googled for, I just had to use Google to find it again as I only have the file at work!

https://supportforums.cisco.com/thread/2021483




309 posts

Ultimate Geek
+1 received by user: 32


  Reply # 811587 5-May-2013 14:35
Send private message

sbiddle: I'm not sure what you Googled for, I just had to use Google to find it again as I only have the file at work!

https://supportforums.cisco.com/thread/2021483



Thanks, found the tool, rec-spa2102-5-2-12.

But can't get the tool to work, keeps coming up device not found.
Connected laptop via cat5 to a switch (no other devices), connected spa2102 via cat 5 to switch (from ethernet port of spa2102.
Set laptop IP to 192.168.0.10 and gateway to 192.168.0.1 (default spa2102 ethernet ip)

Recovery tool searches (after typing in Serial No), but nothing found.

Tried a number of other approaches, different IP's/subnet on laptop, connecting the spa2102 to switch via 'internet' port, but no luck.

With the spa2102 connected to the switch Port 1, the LED lights for Port 1 on the switch blink ON for 1 second, then back off, as the spa2102 reboots again.

The spa2102 LED sequence is:
Red power LED (short)
Green power LED (medium)
2 x Green Internet LED (very quick flashes)
Green power LED (long)
Then repeats process.

Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Exhibition to showcase digital artwork from across the globe
Posted 23-May-2018 16:44


Auckland tops list of most vulnerable cities in a zombie apocalypse
Posted 23-May-2018 12:52


ASB first bank in New Zealand to step out with Garmin Pay
Posted 23-May-2018 00:10


Umbrellar becomes Microsoft Cloud Solution Provider
Posted 22-May-2018 15:43


Three New Zealand projects shortlisted in IDC Asia Pacific Smart Cities Awards
Posted 22-May-2018 15:14


UpStarters - the New Zealand tech and innovation story
Posted 21-May-2018 09:55


Lightbox updates platform with new streaming options
Posted 17-May-2018 13:09


Norton Core router launches with high-performance, IoT security in New Zealand
Posted 16-May-2018 02:00


D-Link ANZ launches new 4G LTE Dual SIM M2M VPN Router
Posted 15-May-2018 19:30


New Panasonic LUMIX FT7 ideal for outdoor: waterproof, dustproof
Posted 15-May-2018 19:17


Ryanair Goes All-In on AWS
Posted 15-May-2018 19:14


Te Papa and EQC Minecraft Mod shakes up earthquake education
Posted 15-May-2018 19:12


Framing Facebook: It’s not about technology
Posted 14-May-2018 16:02


Vocus works with NZ Police and telcos to stop scam calls
Posted 12-May-2018 11:12


Vista Group signs Aeon Entertainment, largest cinema chain in Japan
Posted 11-May-2018 21:41



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.