Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.
Filter this topic showing only the reply marked as answer View this topic in a long page with up to 500 replies per page Create new topic
1 | 2 | 3 | 4 | 5


19 posts

Geek


  Reply # 858122 17-Jul-2013 16:16
Send private message

I did see that the call seemed to be directed to 192.168.1.100 - which is in my IP range.. BUT we have nothing above 192.168.1.35 and the Asterisk server is 192.168.1.30 / the handsets are all below that..I want to get rid of Elastix anyway - good opportunity.

I did wonder that 192.168.1.100 was unusual ... 

Thanks for the help will let you know what happens tomorrow - got to shoot


3621 posts

Uber Geek
+1 received by user: 1343

Subscriber

  Reply # 858207 17-Jul-2013 17:35
Send private message

If you are moving away from Elastix can I recommend the official FreePBX distro.
Really really good distro and gives access to commerical modules if they are required.

16 posts

Geek
+1 received by user: 4


  Reply # 861658 18-Jul-2013 15:08
Send private message

I was just wondering how you went as I have 2 raspbx devices that all of a sudden stopped working on monday as well

they have both been working fine with an italk sip trunk but now they will only allow incoming on the sip trunk and outbound I get the same error forbidden

I thought it was just me but good to hear someone else has the same issue

disallow=all
allow=ulaw
context=from-trunk
dtmfmode=auto&rfc2833
host=akl.italk.co.nz
insecure=very
qualify=yes
username=649XXXXXXX
secret=XXXXXXX
type=friend
canreinvite=no
fromuser=649XXXXXXX

Has worked fine and then all of a sudden stopped

3343 posts

Uber Geek
+1 received by user: 1089

Trusted
Vocus

  Reply # 861662 18-Jul-2013 15:09
Send private message

I wonder if they've done something to reject certain User-Agent strings... be interesting to see if there's any detail in the 403 message coming back



19 posts

Geek


  Reply # 861680 18-Jul-2013 15:33
Send private message

Rabsoft & ubergeeknz...

No i have not solved the problem, I thought I had a rogue device as Ubergeek mentioned a .100 in the trace.. but I think that is a red herring.

One other pointer to me is the phone I use which is an Audiocodes has a really nice diagnostic and I noticed that the codec was during a call ( the phone is currently across my main SIP line to receive incoming calls, usually it is ext 204 ) was using G729 and I dont have G729 licenced in my system - could it be if I put G729 in my asterisk this would cure the problem.

I didnt reload the Asterisk as I was busy on site vists and we have a 24 hr coverage with a Call Centre - so we can live with the issue till it solved

Ubergeeknz - is another trace of any use?

Any thoughts 
 

3343 posts

Uber Geek
+1 received by user: 1089

Trusted
Vocus

  Reply # 861684 18-Jul-2013 15:37
Send private message

Codec issues normally cause a "488 Not Acceptable Here" response, so I wouldn't think it's that.

Yes a capture including the INVITE and the 403 response may be helpful, even more helpful would be an INVITE from Asterisk that fails, AND an INVITE that does work (ie from the supported softphone client) - as it should be possible to spot the difference.



19 posts

Geek


  Reply # 861693 18-Jul-2013 15:50
Send private message

Ok here is two wireshark traces...


1)  italk3 is three calls two failures to italk and one successful to voipbuster using TCPdump

2) Call successful - uses xlite and italk settings to italk - call to 0800000000 - works perfectly


http://www.sendspace.com/file/o79fjf

Good luck PDE


3343 posts

Uber Geek
+1 received by user: 1089

Trusted
Vocus

  Reply # 861713 18-Jul-2013 16:10
Send private message

For one, check your caller ID ; this should be the number matching your italk service (it's different in the two traces, not sure if they're tied to different services though)

Secondly, there are too many digits being dialled in the Asterisk example; it's not actually a valid number.  Where as the X-Lite example has only the six zeros, which is correct.  That would be a valid reason to get 403 but I'm not convinced that's it.  Easy to test at any rate.

Another possibility is that they really are filtering on user agent string, and/or other hints, because they don't want people using unsupported devices.  I'd say given now there are two people in this thread complaining their Asterisk boxes suddenly stopped working at the same time, this is likely enough.  I've not seen it reported elsewhere but I don't think italk is a particularly common choice for Asterisk users.

There's no real clue in the 403 message as to why the call is rejected.  But when the X-Lite sends an initial request it's asked for proxy-auth, whereas Asterisk's request is rejected outright.

Hope something in there helps :/

14 posts

Geek


  Reply # 861829 18-Jul-2013 20:08
Send private message

Also having the same problem here - have 2 trunks between my Asterisk server and iTalk. Getting 403 Forbidden on an ongoing basis and when trying to make calls.

A couple of things have changed of late... in the last week or two I stopped getting responses to pings of the iTalk server and I'm pretty sure the IP address that all the *.italk.co.nz entries point to has changed.

Will do some more troubleshooting then complain loudly to Slingshot in the morning

27140 posts

Uber Geek
+1 received by user: 6579

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  Reply # 861836 18-Jul-2013 20:23
One person supports this post
Send private message

I guess it really does expose the problem of relying on a provider of any sort that doesn't offer support.

81 posts

Master Geek
+1 received by user: 3


  Reply # 861871 18-Jul-2013 21:27
Send private message

Same Problem here I think
"
[Jul 18 21:19:14] WARNING[16566]: chan_sip.c:20269 handle_response_invite: Received response: "Forbidden" from '"Sam B####" <sip:6472800###@120.138.27.###>;

"



14 posts

Geek


  Reply # 861883 18-Jul-2013 21:49
Send private message

Is anybody else with issues using Vodafone (and/or VF TelstraClear)?

81 posts

Master Geek
+1 received by user: 3


  Reply # 861893 18-Jul-2013 22:15
Send private message

Snap here



19 posts

Geek


  Reply # 861991 19-Jul-2013 09:02
Send private message

Going by the replies it looks as though I am not alone, I assume "snap here" means you have the same problem ( or does it?) and the Telstra Clear / Vodafone comment refers to Italks wholesaler.

OK so where to from here? I am a small business and my DR copes with this, however if there is no answer I need to goto a provider that works. I have been with Italk for 10 years and I have a fixed IP as well, I spend about $150 a month, so if Italk wont talk to me and my device that did work for the last three years ( I was a copper customer before that, now I am Naked DSL) is unsupported... great . 

I am assuming that we need a genius to work out new peer details ( which is not me) or I move - what are my options ? Is Orcon going to work for me? Since UbergeekNZ has been the most helpful, I may as wwell put my money in that direction and support his employer...

Thoughts Please?

Paul 
 

895 posts

Ultimate Geek
+1 received by user: 285


  Reply # 862004 19-Jul-2013 09:34
Send private message

I've had a similar issue with making SIP calls from the built-in dialer app on my Android phone.  My phone wasn't registering with their SIP server because I didn't want inbound calls and registration chews battery.

I rang up Slingshot and they confirmed that your SIP client had to be registered with their SIP server in order to make outgoing calls.  Found another android app which did that but made it easy to turn off the registration, now everything is OK.

I haven't had to deal with asterisk config for a while -- is there a way to associated outbound calls with a SIP registration?

1 | 2 | 3 | 4 | 5
Filter this topic showing only the reply marked as answer View this topic in a long page with up to 500 replies per page Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.