Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




2 posts

Wannabe Geek


# 177202 26-Jul-2015 11:38
Send private message

Hi, I try and set up the 2talk with freepbx, but I can make outbound calls fine. But inbound call and it goes to 2talk voice mail. According to 2talk the number is registered and online.

The PBX is behind a nat (pfsense)

Any help would be appreciated.

Thanks

Create new topic
27985 posts

Uber Geek
+1 received by user: 7467

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  # 1351885 26-Jul-2015 11:39
Send private message

I assume you haven't yet Googled the known issues and resolutions for VoIP issues with pfsense?





2 posts

Wannabe Geek


  # 1351886 26-Jul-2015 11:40
Send private message

sbiddle: I assume you haven't yet Googled the known issues and resolutions for VoIP issues with pfsense?




No

 
 
 
 


27985 posts

Uber Geek
+1 received by user: 7467

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  # 1352041 26-Jul-2015 16:43
Send private message

mikeeatr:
sbiddle: I assume you haven't yet Googled the known issues and resolutions for VoIP issues with pfsense?




No


That will be the best place to start. pfsense and VoIP don't necessarily play nicely together. It's one of the reasons I'd never go near it as a s solution.


4078 posts

Uber Geek
+1 received by user: 1768

Subscriber

  # 1352101 26-Jul-2015 19:14
Send private message

sbiddle:
mikeeatr:
sbiddle: I assume you haven't yet Googled the known issues and resolutions for VoIP issues with pfsense?




No


That will be the best place to start. pfsense and VoIP don't necessarily play nicely together. It's one of the reasons I'd never go near it as a s solution.



Agreed. It's a pain in the butt.

You need to add some nat rules so that pfsense doesn't muck around with the ports as they get nat'd out. I think they have a sip alg type package you can add now too but that is probably going to be just as useful as every other alg out there.

Perhaps TLS might solve the issue but then there is heaps more to do on your FreePBX box instead and is probably actually harder than getitng pfsense to do what you want.

267 posts

Ultimate Geek
+1 received by user: 8

Trusted

  # 1378253 2-Sep-2015 13:52
Send private message

Hey

If you got this resolved - would you mind seeing if you have the same issue as I do?

 

I have an issue where a remote party calling in to a FreePBX installation is able to make use of the Call Features (such as *1, *2, etc).

 

In my testing I have called in from my mobile to a FreePBX extension, and upon the call being answered I am able to dial *2 from my mobile, and I am able to transfer my own call to another extension.

 

If I call from my FreePBX extension to my mobile, I am not able to use the call feature codes - in fact I can not even hear the DTMF tones pressed on the mobile on the extension...

I'm trying to work out if this is something I have done, or a setting I have over looked, or expected behaviour.

Thanks

 

 

27985 posts

Uber Geek
+1 received by user: 7467

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  # 1378258 2-Sep-2015 14:01
Send private message

Glazza: Hey

If you got this resolved - would you mind seeing if you have the same issue as I do?
I have an issue where a remote party calling in to a FreePBX installation is able to make use of the Call Features (such as *1, *2, etc). In my testing I have called in from my mobile to a FreePBX extension, and upon the call being answered I am able to dial *2 from my mobile, and I am able to transfer my own call to another extension. If I call from my FreePBX extension to my mobile, I am not able to use the call feature codes - in fact I can not even hear the DTMF tones pressed on the mobile on the extension...

I'm trying to work out if this is something I have done, or a setting I have over looked, or expected behaviour.

Thanks

 


This is controlled by the Dial Command settings which should be at the default 'tr'

DO NOT under any circumstances play with this unless you fully understand what you're doing (and I'd suggest now you don't understand these settings) as it opens up some massive security holes.

You should not be able to call in and dial * feature codes and you should not allow this unless you're fully aware of the risks.

If you're not hearing DTMF tones when calling out it suggests you have your DTMF settings set incorrectly.



267 posts

Ultimate Geek
+1 received by user: 8

Trusted

  # 1378290 2-Sep-2015 14:31
Send private message

Hi Steve

FreePBX out of the box sets Asterisk Outbound Trunk Dial Options to Ttr (advanced settings)

And for each Trunk it defaults to Tt..

if I override this - removing the T - I believe this should stop the calling user (mobile in my example) being able to dial any 'Feature Code' - however it doesn't!

Cheers



 
 
 
 


27985 posts

Uber Geek
+1 received by user: 7467

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  # 1378294 2-Sep-2015 14:36
Send private message

Oops yes tr is what I use as default for lots of things on Asterisk, Ttr is the current settings in FreePBX

It's not an issue I've seen before.



267 posts

Ultimate Geek
+1 received by user: 8

Trusted

  # 1378299 2-Sep-2015 14:45
Send private message

Thanks - I have just run through a fresh build from the ISO - added a single extension, added a 2Talk trunk...  and issue is replicated...



I've tried to override the T - which by all accounts should resolve the issue.


Thanks



Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Dunedin selects Telensa to deliver smart street lighting for 15,000 LEDs
Posted 18-Jul-2019 10:21


Sprint announces a connected wallet card with built-in IoT support
Posted 18-Jul-2019 08:36


Educational tool developed at Otago makes international launch
Posted 17-Jul-2019 21:57


Symantec introduces cloud access security solution
Posted 17-Jul-2019 21:48


New Zealand government unveils new digital service to make business easier
Posted 16-Jul-2019 17:35


Scientists unveil image of quantum entanglement
Posted 13-Jul-2019 06:00


Hackers to be challenged at University of Waikato
Posted 12-Jul-2019 21:34


OPPO Reno Z now available in New Zealand
Posted 12-Jul-2019 21:28


Sony introduces WF-1000XM3 wireless headphones with noise cancellation
Posted 8-Jul-2019 16:56


Xero announces new smarter tools, push into the North American market
Posted 19-Jun-2019 17:20


New report by Unisys shows New Zealanders want action by social platform companies and police to monitor social media sites
Posted 19-Jun-2019 17:09


ASB adds Google Pay option to contactless payments
Posted 19-Jun-2019 17:05


New Zealand PC Market declines on the back of high channel inventory, IDC reports
Posted 18-Jun-2019 17:35


Air New Zealand uses drones to inspect aircraft
Posted 17-Jun-2019 15:39


TCL Electronics launches its first-ever 8K TV
Posted 17-Jun-2019 15:18



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.