Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


17 posts

Geek


Topic # 201533 23-Aug-2016 00:57
Send private message

Hey guys,  need some help sorting my issue here. 

 

I am using 2Talk with Cisco SPA122 and Asus Rt-AC5300. My home phone is Panasonic KX-TGF380AZM, it's a corded and cordless phone. I have ported my number from previous provider so it's not a 2Talk number but a normal landline number. 

 

Everything is running smoothly except when making outbound calls from home or outside trying to dial in, it's taking approximately 19 seconds for the calls to connect. Rather slow I'd say. 

 

SIP ALG is off, firewall from the router is off (turned back on afterwards coz it does not make a difference), plug the ATA straight to the lan port of the router (used to be behind a switch), check the setting on the phone, and none of the above is making the calls to connect faster.

 

I dnt know what else to try, does any1 know any other things that I can try, or is this just a normal waiting time for VoIP, first time user here obviously.

 

Many thanks in advance.    


Create new topic
5246 posts

Uber Geek
+1 received by user: 2264

Trusted
Lifetime subscriber

  Reply # 1616119 23-Aug-2016 07:14
Send private message

A bad dialing plan could explain outbound.




Chorus has spent $1.4 billion on making their xDSL broadband network faster. If your still stuck on ADSL or VDSL, why not spend from $150 on a master filter install to make sure you are getting the most out of your connection?
I install - Naked DSL, DSL Master Splitters, VoIP, data cabling and general computer support for home and small business.
Rural Broadband RBI installer for Ultimate Broadband and Full Flavour

 

Need help in Auckland, Waikato or BoP? Click my email button, or email me direct: [my user name] at geekzonemail dot com


157 posts

Master Geek
+1 received by user: 51


  Reply # 1616125 23-Aug-2016 07:32
Send private message

Is the problem still occurring for you this morning?

 

If you were only setting this up and testing last night for the first time then it may have been bad timing. 2talk were having issues overnight last night to do with changes they were making (see the @2talkNS posting on live.2talk.co.nz).

 

We had multiple services affected between approx 1am this morning and 6am this morning, but everything has stabilised now.

 

If it were only outbound calls delaying for you then I'd recommend pressing the # button after the number, to trigger the SPA122 to dial immediately. But since it was affecting inbound calls too, perhaps it was related to these other issues overnight.


2695 posts

Uber Geek
+1 received by user: 529


  Reply # 1616128 23-Aug-2016 07:51
Send private message

Seem to recall when I had a free 2talk account on voip/android tablet it was very slow in or outgoing.
It was suggested to turn off 'stun' server settings.
Calls became pretty much instant.

We now have our 'landline' with 2talk on a cisco spa112 and i slavishly followed all the setup instructions. It rings in/out pretty much instantly.




Nothing is impossible for the man who doesn't have to do it himself - A. H. Weiler



17 posts

Geek


  Reply # 1616160 23-Aug-2016 09:02
Send private message

Thank you for whoever replied. 

 

The problem has been persisting ever since I started using the service. 

 

@coffeebaron, the dialing plan is also one of the parts that I dnt understand, how do I set up one "good" dialing plan? I'm in Auckland. 

 

@robjg63, I should give it a try when I get home today, I just noticed that it says it's optional for the STUN server setup, I should have avoid that maybe in the first place. So STUN off and keep everything else tight?

 

One other thing, I notice how I made all those changes I made and it doesn't change a thing, does it mean SIP ALG on or off won't make a difference? I'm with Vodafone fibre. 

 

Thanks guys. 

 

 

 

 

Go Hawks!
877 posts

Ultimate Geek
+1 received by user: 49

Trusted
Subscriber

  Reply # 1616187 23-Aug-2016 09:44
Send private message

I've been using 2Talk on and off for a while, and to the best of my memory have never used a STUN server with 2Talk. 

 

I'll post a copy of my dial plan tonight - it is a specific to my setup, but should help out.

 

Cheers




17 posts

Geek


  Reply # 1616191 23-Aug-2016 09:51
Send private message

@wazzageek, thank you for your reply. Look forward to your dial plan. 

 

One other question, a call came in this morning, I picked up the phone but was instantly cut out, the call did not complete. I called back and the person said the call was simply cut. This has been an ongoing issue as well, but it never happen to me when I call back home, however, there are many unsuccessful inbound calls like this for many other people who are trying to call home, any idea?

 

 

 

 

 

 


2958 posts

Uber Geek
+1 received by user: 286


  Reply # 1616267 23-Aug-2016 12:42
Send private message

How did you provision the ATA?

 

Did you follow the guide on 2talk's website?







17 posts

Geek


  Reply # 1616277 23-Aug-2016 12:56
Send private message

@CYaBro, yes, configured everything manually with instruction from 2Talk. 

 

I have managed to turn off STUN server and inbound calls are now connecting without delay. Now only leaves the issue with outbound call delay and the disconnection at answering. 

 

 

 

 


Go Hawks!
877 posts

Ultimate Geek
+1 received by user: 49

Trusted
Subscriber

  Reply # 1617093 24-Aug-2016 23:13
Send private message

Sorry for this delay,  this is my SPA921 phone (I've edited out my local config, as it's unlikely to match your setup):

 

( [2356789]xxxxxxS0 | 0[34679]xxxxxxxS0 | x. | *x. )

 

The meanings of the above are as follows:

 

The braces go round the entire dialplan "( )"

 

The pipe (|) indicates an or.

 

An "x" can represent any digit (from 0 - 9)

 

Numbers within the square brackets ([2356789]) indicates that the number can be one of the numbers within the brackets.

 

An asterisk indicates the star from the phone.

 

A period (.) indicates one or more of the preceeding

 

S0 indicates to dial immediately (I don't know if this applies on your Cisco ATA, you will probably be able to omit it and it will work fine)

 

To break down the above:

 

The first string matches a "local" Hawkes Bay number: [2356789]xxxxxxS0 (In fact, this string should match any "local" number in NZ)

 

As local numbers are fixed at 7 digits, the ATA will start dialing immediately after the last digit.

 

The next matches any national number: 0[34679]xxxxxxxS0 

 

A national number is always 9 digits long - a zero, followed by the area code, then seven more digits.

 

The next string allows any number, followed by any further number for any length: x.

 

Of course, this won't dial immediately after the last digit - you will either need to wait for the timeout on the ATA, or press the hash key (#) for the ATA to start immediately dialling.

 

The final string allows an asterisk followed by any number: *x.

 

This allows special codes to be dialed eg. *55 to access mailboxes.

 

Further thoughts

 

This is quite a quick lazy dialplan, as I do most of the interesting work on my asterisk/freepbx setup - we generally do not call non NZ, non geographical numbers from our landline (with the exception of 0800 / 0900 numbers) - so it caters for all our needs so far.

 

It would probably be a good idea to prefix the entire dial plan with "111S0" so that if anyone picks up the phone and dials 111, the phone will immediately start trying to dial 111.

 

Some ATA's and Phones are quite limited in the length of the dial plan that you can have, which is the other reason I use quite a short dial plan on the phones / ATA's.

 

I hope all that helps and points you in the right direction.

 

Cheers!


310 posts

Ultimate Geek
+1 received by user: 21


  Reply # 1642060 28-Sep-2016 20:05
Send private message

If you press the hash button after dialing the number does it dial straight away?

 

If it does then the problem with out bound calls is the dial plan.





Now on 2talk Network and it's better.



21382 posts

Uber Geek
+1 received by user: 4333

Trusted
Subscriber

  Reply # 1642073 28-Sep-2016 20:24
Send private message

Also if you are using dect phones where you pre-dial then go off hook, you can drop the timeout in one of the settings to 1 second since it will never have delays between digits longer than a few 100 milliseconds as the phone is dialing. If you have old style phones too, then you can lower it but not to 1 seconds since some people are pretty slow on the dialing.





Richard rich.ms

Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.