Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.
View this topic in a long page with up to 500 replies per page Create new topic
1 | 2 
4 posts

Wannabe Geek


  Reply # 1983969 27-Mar-2018 08:18
quote this post

@meow

 

I spoke too soon, the problem with receiving incoming calls is still there. 

 

It seemed that setting the Register Expires to a lower value made as difference in terms of how long the system remained stable, so I will continue to play around with that to see if there is a sweet spot

 

 


26635 posts

Uber Geek
+1 received by user: 6140

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  Reply # 1983981 27-Mar-2018 08:59
One person supports this post
Send private message quote this post

Register expires shouldn't need to be any lower. If you have a poorly configured router that doesn't keep the NAT pinhole open long enough for UDP it could result in the inbound calls not connecting.

 

 

 

 


149 posts

Master Geek
+1 received by user: 50


  Reply # 1983984 27-Mar-2018 09:05
Send private message quote this post

sbiddle:

 

Register expires shouldn't need to be any lower. If you have a poorly configured router that doesn't keep the NAT pinhole open long enough for UDP it could result in the inbound calls not connecting.

 

 

 

 

Here here! This is precisely the cause of that problem (intermittent failure for inbound-call signalling to get through).

 

The fix is to either increase the NAT table timeout in the firewall, or reduce the keepalive interval in the ATA.

 

 


4 posts

Wannabe Geek


  Reply # 1984649 28-Mar-2018 08:03
quote this post

@Meow

 

I changed the following three settings:

 

Voice > Line1[2] > NAT Settings > NAT Keep Alive Enable:  Yes

 

(This is suggested by a number of overseas providers and is relevant to the previous comments in this thread)

 

Voice > SIP > NAT Support Parameters > Insert VIA rport:  Yes

 

and

 

Voice > SIP > NAT Support Parameters > Handle VIA rport:  Yes

 

My connection has been stable for 24 hours.

 

----

 

I have also read a suggestion that

 

Voice > Line1[2] > Proxy and Registration > Use DNS SRV: Yes

 

can also help in certain circumstances

 

----

 

I will also dial the Register Expires back up to minimise my impact on the ISP.

 

 

 

I hope this helps

 

 


4 posts

Wannabe Geek


  Reply # 1984884 28-Mar-2018 12:56
quote this post

@sbiddle @speed

 

My apologies for offering incorrect suggestions which negatively impact service providers or break the 'fair use of resources' rule that we should all abide by.

 

I joined up because I stumbled across a question from somebody who - like me - just wanted their phone to work and for whom there is very little concrete information available from their ISP or anyone else. As I had had some (incomplete) success I thought it appropriate to share.

 

I am not a network engineer, and have very little knowledge of VOIP or CISCO SPA configs. I also use a simple home router which gives no control over things like NAT tables, resources or timeouts. I completely understand why IT Professionals cringe when they see some of the things people suggest in their ignorance, but I hadn't realised that input from amateurs is not appropriate for these particular forums, I'll make sure I don't add any more to the pile.


149 posts

Master Geek
+1 received by user: 50


  Reply # 1984935 28-Mar-2018 13:52
Send private message quote this post

@happynut

 

Your previous post indicated you've had 24+ hrs of stability now. My guess is that this is because you enabled the NAT keepalives on the ATA.

 

 

 

Once the OP gets his registration issue resolved then I suspect he'll need the same keep-alive setting enabled. So your input is valuable to him I would have thought!

 

 

 

 




20 posts

Geek
+1 received by user: 1


  Reply # 1985577 29-Mar-2018 18:23
Send private message quote this post

Thanks to the config help here I was able to get it registered!




20 posts

Geek
+1 received by user: 1


  Reply # 2032093 8-Jun-2018 12:33
Send private message quote this post

Hi All,

 

I'm revisiting this thread because I've lost my config after I factory reset my devices and didnt have a backup for the spa122.

 

I'm having an issue with inbound calls and get the "the person at extension 64XXXXXXXX isnt available". I can make outbound calls. I've enabled the NAT keepalives and followed the advice in this thread again, but I'm not able to get it working.

 

Are there any reasons why it isnt working this time around?

 

 




20 posts

Geek
+1 received by user: 1


  Reply # 2032146 8-Jun-2018 13:58
Send private message quote this post

I thought it was the DND Serv which was on, so I turned all but call waiting off. 

 

Now I'm getting "the number you have dialed is temporarily out of service if you feel this is in error please ..." and it cycles between this message in a male voice to the other mentioned above in a females voice.

 

Help appreciated!

 

Settings images:

 

Click to see full size

 

Click to see full size

 

Click to see full size

 

Click to see full size

 

Click to see full size

 

Click to see full size

 

Click to see full size

 

Click to see full size

 

Click to see full size

 

@happynut if you're still available to help, I'd love to hear back from you.




20 posts

Geek
+1 received by user: 1


  Reply # 2032246 8-Jun-2018 17:30
Send private message quote this post

I think it might be the edgerouter I've placed in between:

 

UFB ONT <> EdgeRouter X <> SPA 122

 

 

 

I did perform the following on the Edgerouter CLI (no help):

 

configure

 

set system conntrack timeout udp stream 180

 

set system conntrack timeout udp other 30

 

set system conntrack modules sip disable

 

commit

 

save

 

exit

 

 

 

And I set the NAT Keep Alive Intvl: 15 on the ATA (no help). Can call out, cant accept calls.




20 posts

Geek
+1 received by user: 1


  Reply # 2032349 8-Jun-2018 20:49
Send private message quote this post

Okay I solved my problem by:

 

1. Setting up port forwarding for sip signalling and sip rtp packets

 

2. Using a Stun server


1 | 2 
View this topic in a long page with up to 500 replies per page Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Hawaiki Transpacific cable ready-for-service
Posted 20-Jul-2018 11:29


Microsoft Dynamics 365 Business Central launches
Posted 10-Jul-2018 10:40


Spark completes first milestone in voice platform upgrade
Posted 10-Jul-2018 09:36


Microsoft ices heated developers
Posted 6-Jul-2018 20:16


PB Technologies charged for its extended warranties and warned for bait advertising
Posted 3-Jul-2018 15:45


Almost 20,000 people claim credits from Spark
Posted 29-Jun-2018 10:40


Cove sells NZ's first insurance policy via chatbot
Posted 25-Jun-2018 10:04


N4L helping TAKA Trust bridge the digital divide for Lower Hutt students
Posted 18-Jun-2018 13:08


Winners Announced for 2018 CIO Awards
Posted 18-Jun-2018 13:03


Logitech Rally sets new standard for USB-connected video conference cameras
Posted 18-Jun-2018 09:27


Russell Stanners steps down as Vodafone NZ CEO
Posted 12-Jun-2018 09:13


Intergen recognised as 2018 Microsoft Country Partner of the Year for New Zealand
Posted 12-Jun-2018 08:00


Finalists Announced For Microsoft NZ Partner Awards
Posted 6-Jun-2018 15:12


Vocus Group and Vodafone announce joint venture to accelerate fibre innovation
Posted 5-Jun-2018 10:52


Kogan.com to launch Kogan Mobile in New Zealand
Posted 4-Jun-2018 14:34



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.