Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


View this topic in a long page with up to 500 replies per page Create new topic
1 | 2 | 3 | 4 | 5 | 6 | 7


29119 posts

Uber Geek

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  #320514 20-Apr-2010 07:54
Send private message

I'll be publishing a blog post with all the details probably later on today.

261 posts

Ultimate Geek

Trusted

  #320518 20-Apr-2010 08:22
Send private message

Great idea and happy to help with testing.

SPA2102 software version 5.2.10 with two italk lines.

 
 
 
 




29119 posts

Uber Geek

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  #320625 20-Apr-2010 12:16
Send private message

Full details are available here http://www.geekzone.co.nz/sbiddle/7208

261 posts

Ultimate Geek

Trusted

  #320637 20-Apr-2010 12:41
Send private message

After changing the provisioning settings and submitting all changes I waited a few minutes and it didn't auto update. I reset the device and it picked up the new settings.

Tested and working so far:
Correct NZ dial tone - nice
Placed a call from each line to my mobile and it rang.

Tested and no longer working:
Rang each line from my mobile, the mobile gets sent to voicemail but the italk line keeps ringing for a long period of time before finally stopping.

EDIT: Also rang one italk line from the other with the same result.

Obviously this is a major problem!!

SPA2102




Software Version:
5.2.10
Hardware Version:
1.3.5(a)



 
2x italk lines



29119 posts

Uber Geek

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  #320644 20-Apr-2010 12:50
Send private message

Hmm that's strange.

There is nothing in the SIP settings for each provider that I have changed, I'm a little puzzled as to how it could stop inbound calls. Do both lines show as registered in the main config menu?

Edit: You mention further up you have 2 italk lines but then say the iTalk one goes to VM. Are both lines iTalk? Are they in the same region or different regions?


261 posts

Ultimate Geek

Trusted

  #320648 20-Apr-2010 12:53
Send private message

EDIT: Both lines are registered, italk and auckland numbers.

261 posts

Ultimate Geek

Trusted

  #320655 20-Apr-2010 13:04
Send private message

I have changed Auth Invite back to No and we are working again.

 
 
 
 


5699 posts

Uber Geek

Trusted
Lifetime subscriber

  #320657 20-Apr-2010 13:05
Send private message

I suggest factory reset device.
Re-provision with Steve's config
Remove provisioning link
Configure your italk or 2talk settings




Chorus has spent $1.4 billion on making their xDSL broadband network faster and even more now as they are upgrading their rural Conklins. If your still stuck on ADSL or VDSL, why not spend $195 on a master filter install to make sure you are getting the most out of your connection?
I install - Naked DSL, DSL Master Splitters, VoIP, data cabling and general computer support for home and small business.

 

Cel-Fi supply and installer - boost your mobile phone coverage legally
Rural Broadband RBI installer for Ultimate Broadband and Full Flavour

 

Need help in Auckland, Waikato or BoP? Click my email button, or email me direct: [my user name] at geekzonemail dot com


261 posts

Ultimate Geek

Trusted

  #320661 20-Apr-2010 13:15
Send private message

You missed my earlier post, I had changed Auth Invite to yes as per Steve's blog post at the same time as I changed the provisioning settings.

Changing it back to No has the inbound calls working again.

Other test results:

Caller ID
Netgear SPH200D cordless phone shows as 06421xxxxxx
Philips VOIP433 cordless phone shows as 006421xxxxxx

Both phones are running as POTS cordless phones connected to the ATA.

Obviously only the Philips returns missed calls properly as the Netgear is not getting the right caller ID information. Both phones are telepermitted and purchased in NZ.

OT: Recommended codec?
Also OT: Should I be able to send an receive faxes? 



29119 posts

Uber Geek

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  #320665 20-Apr-2010 13:17
Send private message

polglase: I have changed Auth Invite back to No and we are working again.


You beat me to it. It was the only thing that could have affected things.

There is another setting in the ATA's that does a similair thing that locks down incoming SIP traffic to the IP of the registrar IP. Obviously iTalk are a little lax with their security for SIP INVITE messages.

This is under the Line settings and is "Restrict Source IP". Any chance you could try changing this to yes and letting me know whether this solves the issue?



261 posts

Ultimate Geek

Trusted

  #320672 20-Apr-2010 13:25
Send private message

I have changed Restrict Source IP to yes on both lines and inbound calls are fine.

With Restrict Source IP and Auth INVITE both set to yes calls are still sent to voicemail.

Have left Restrict Source IP on and Auth INVITE off.

3594 posts

Uber Geek

Trusted
WorldxChange

  #320674 20-Apr-2010 13:28
Send private message

polglase: You missed my earlier post, I had changed Auth Invite to yes as per Steve's blog post at the same time as I changed the provisioning settings.

Changing it back to No has the inbound calls working again.

Other test results:

Caller ID
Netgear SPH200D cordless phone shows as 06421xxxxxx
Philips VOIP433 cordless phone shows as 006421xxxxxx

Both phones are running as POTS cordless phones connected to the ATA.

Obviously only the Philips returns missed calls properly as the Netgear is not getting the right caller ID information. Both phones are telepermitted and purchased in NZ.

OT: Recommended codec?
Also OT: Should I be able to send an receive faxes? 



Caller ID info is being sent as e164 cc+nsn, Steves config does not touch the CallerID and the only seeting will be the method used.

Codec, up to your VOIP provider and type of connection you have, better connections use g711, connections with latency and jitter, lower bandwidth use g729

As for Faxing once again up to your service provider and they the weay they have it configured in their network, not all faxing is created equal with different networks and the config parts of devices requires fine tuning to match network settings, 2talk don't have their own actual network and uses callplus network...so ask your provider.  




Yes I am a employee of WxC (My Profile) ... but I do have my own opinions as well Wink

             

https://www.facebook.com/wxccommunications



29119 posts

Uber Geek

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  #320679 20-Apr-2010 13:37
Send private message

polglase: You missed my earlier post, I had changed Auth Invite to yes as per Steve's blog post at the same time as I changed the provisioning settings.

Changing it back to No has the inbound calls working again.

Other test results:

Caller ID
Netgear SPH200D cordless phone shows as 06421xxxxxx
Philips VOIP433 cordless phone shows as 006421xxxxxx

Both phones are running as POTS cordless phones connected to the ATA.

Obviously only the Philips returns missed calls properly as the Netgear is not getting the right caller ID information. Both phones are telepermitted and purchased in NZ.

OT: Recommended codec?
Also OT: Should I be able to send an receive faxes? 


Telepermit regulations specify that a device should insert the 0 or 00 as required. Telecom PSTN lines do not pass the 0 in the CID as it's merely an access code, not part of the phone number. Many phones have a menu option to specify whether the 0 should be inserted or not. There is nothing you can do in the device to change this. I know WxC do custom config files for people who have had issues with this and certain phones.

Codec depends entirely on your connection. ulaw and alaw offer the best voice quality but use around 87kbps in each direction for a voice call. G.729 uses around 1/2 that but only a slight reduction in voice quality.

Faxing is a whole different ballgame and ideally requires your VoIP provider supports T.38 - I have no idea if iTalk do or not.


261 posts

Ultimate Geek

Trusted

  #320680 20-Apr-2010 13:37
Send private message

Thanks for that.

Are we better with G711u or G711a here in NZ?

EDIT: Thanks Steve, will look in the phone's menu to see if this can be changed.




29119 posts

Uber Geek

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  #320681 20-Apr-2010 13:40
Send private message

polglase: Thanks for that.

Are we better with G711u or G711a here in NZ?

As for Caller ID, will changing the configuration of the ATA correct the behaviour on the Netgear phone, if so then continued discussion may be relevant to this thread.


Technically NZ uses alaw. ulaw is the ISDN codec used in the USA and Japan and alaw is used elsewhere. There is very little difference and if your VoIP provider supports both (as most so) there is no difference in what you use.

There is unfortunately no way to change the CID setup in the ATA. It just passes through what it sent to it.

1 | 2 | 3 | 4 | 5 | 6 | 7
View this topic in a long page with up to 500 replies per page Create new topic




News »

Freeview On Demand app launches on Sony Android TVs
Posted 6-Aug-2020 13:35


UFB hits more than one million connections
Posted 6-Aug-2020 09:42


D-Link A/NZ extends COVR Wi-Fi EasyMesh System series with new three-pack
Posted 4-Aug-2020 15:01


New Zealand software Rfider tracks coffee from Colombia all the way to New Zealand businesses
Posted 3-Aug-2020 10:35


Logitech G launches Pro X Wireless gaming headset
Posted 3-Aug-2020 10:21


Sony Alpha 7S III provides supreme imaging performance
Posted 3-Aug-2020 10:11


Sony introduces first CFexpress Type A memory card
Posted 3-Aug-2020 10:05


Marsello acquires Goody consolidating online and in-store marketing position
Posted 30-Jul-2020 16:26


Fonterra first major customer for Microsoft's New Zealand datacentre
Posted 30-Jul-2020 08:07


Everything we learnt at the IBM Cloud Forum 2020
Posted 29-Jul-2020 14:45


Dropbox launches native HelloSign workflow and data residency in Australia
Posted 29-Jul-2020 12:48


Spark launches 5G in Palmerston North
Posted 29-Jul-2020 09:50


Lenovo brings speed and smarter features to new 5G mobile gaming phone
Posted 28-Jul-2020 22:00


Withings raises $60 million to enable bridge between patients and healthcare
Posted 28-Jul-2020 21:51


QNAP integrates Catalyst Cloud Object Storage into Hybrid Backup solution
Posted 28-Jul-2020 21:40



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.