Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


671 posts

Ultimate Geek
+1 received by user: 10


Topic # 41057 8-Sep-2009 21:02
Send private message

I've noticed over the last few months that YouTube performance is really bad on cable for me. Only some videos will download as fast or faster than they play (low quality videos). Most download at perhaps 70% play speed, which means constant buffering, or pausing for many minutes at the start. Is this the case for others on cable, or even TelstraClear ADSL?

Here's an example video: http://www.youtube.com/watch?v=F1jmhbw3JHw

If I let it run in non-HD, it plays for 2 seconds, then buffers for 5 seconds (repeat). For HD, it's 2 and 7 respectively.

View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | ... | 33
6269 posts

Uber Geek
+1 received by user: 1061

Trusted
Lifetime subscriber

  Reply # 254176 8-Sep-2009 21:19
Send private message

No issues for me with that video on ADSL1. I have, however, seen the issues you describe with other videos.



671 posts

Ultimate Geek
+1 received by user: 10


  Reply # 254179 8-Sep-2009 21:20
Send private message

How fast does that particular video load compared to play rate? And what about HD?

6269 posts

Uber Geek
+1 received by user: 1061

Trusted
Lifetime subscriber

  Reply # 254251 9-Sep-2009 07:01
Send private message

It loads approximately 3x as fast as it plays. For HD, I'd say a little under 2x.



671 posts

Ultimate Geek
+1 received by user: 10


  Reply # 254420 9-Sep-2009 17:11
Send private message

Wow, that's crazy.

Can other people comment on their YouTube performance? (Especially cable users)



671 posts

Ultimate Geek
+1 received by user: 10


  Reply # 254436 9-Sep-2009 17:28
Send private message

Behodar (or others), if you don't mind, would you be able to tracert v21.lscache4.c.youtube.com?

Mine is as follows:

Tracing route to v21.lscache4.l.google.com [74.125.103.94]
over a maximum of 30 hops:

  1     1 ms     1 ms     1 ms  192.168.1.1
  2    13 ms    13 ms    13 ms  203-97-214-1.cable.telstraclear.net [203.97.214.1]
  3    18 ms    20 ms    20 ms  ie2-g-0-0-0.telstraclear.net [203.98.50.2]
  4    18 ms    19 ms    19 ms  ge-0-2-0-1.xcore1.acld.telstraclear.net [203.98.50.251]
  5    19 ms    20 ms    19 ms  203.167.233.10
  6   145 ms   145 ms   144 ms  static.net.reach.com [202.84.142.94]
  7   144 ms   145 ms   145 ms  i-1-1.tlot03.bi.reach.com [202.84.251.234]
  8   147 ms   144 ms   152 ms  72.14.197.53
  9   145 ms   145 ms   144 ms  216.239.43.12
 10   157 ms   158 ms   157 ms  72.14.238.130
 11   156 ms   208 ms   156 ms  72.14.239.253
 12   156 ms   156 ms   156 ms  72.14.236.19
 13   157 ms   158 ms   157 ms  74.125.103.94

6269 posts

Uber Geek
+1 received by user: 1061

Trusted
Lifetime subscriber

  Reply # 254457 9-Sep-2009 17:58
Send private message

traceroute to v21.lscache4.l.google.com (74.125.103.94), 64 hops max, 40 byte packets
1 RTA1320.home (192.168.1.1) 2.279 ms 6.066 ms 0.778 ms
2 lo0.internet.ivpn.pe24.telstraclear.net (218.101.61.122) 31.953 ms 37.561 ms 31.467 ms
3 ie2-g-0-0-0.telstraclear.net (203.98.50.2) 28.683 ms 29.506 ms 31.227 ms
4 ge-0-2-0-1.xcore1.acld.telstraclear.net (203.98.50.251) 31.041 ms 31.465 ms 29.281 ms
5 203.167.233.10 (203.167.233.10) 30.592 ms 32.325 ms 32.895 ms
6 i-3-1-1.wil-core02.bx.reach.com (202.84.142.133) 155.535 ms 154.810 ms 153.971 ms
7 i-1-1.tlot03.bi.reach.com (202.84.251.234) 154.568 ms 161.325 ms 157.751 ms
8 72.14.197.53 (72.14.197.53) 153.480 ms 155.834 ms 159.334 ms
9 216.239.43.12 (216.239.43.12) 155.908 ms 161.969 ms 155.535 ms
10 72.14.238.130 (72.14.238.130) 167.821 ms 166.270 ms 170.883 ms
11 209.85.240.230 (209.85.240.230) 168.330 ms 72.14.239.253 (72.14.239.253) 198.039 ms 209.85.240.230 (209.85.240.230) 266.040 ms
12 * * *
13 v21.lscache4.c.youtube.com (74.125.103.94) 169.470 ms 168.255 ms 172.930 ms



671 posts

Ultimate Geek
+1 received by user: 10


  Reply # 254471 9-Sep-2009 18:29
Send private message

Thanks. Damn, it's the same.

If anyone on cable is having EITHER good or bad YouTube performance, I want to know!

93 posts

Master Geek

Trusted

  Reply # 254501 9-Sep-2009 19:28
Send private message

Mines fine, 10Mbps connection.
tracert =
|------------------------------------------------------------------------------------------|
| WinMTR statistics |
| Host - % | Sent | Recv | Best | Avrg | Wrst | Last |
|------------------------------------------------|------|------|------|------|------|------|
| 121-73-154-1.cable.telstraclear.net - 0 | 26 | 26 | 0 | 17 | 47 | 16 |
| ie2-g-0-0-0.telstraclear.net - 0 | 26 | 26 | 15 | 21 | 47 | 31 |
| ge-0-2-0-1.xcore1.acld.telstraclear.net - 0 | 26 | 26 | 15 | 19 | 31 | 15 |
| 203.167.233.10 - 0 | 25 | 25 | 15 | 19 | 32 | 15 |
| i-14-1-0.wil-core02.bx.reach.com - 0 | 25 | 25 | 140 | 143 | 157 | 141 |
| i-1-2.tlot03.bi.reach.com - 0 | 25 | 25 | 140 | 143 | 157 | 156 |
| 72.14.197.53 - 0 | 25 | 25 | 140 | 147 | 172 | 140 |
| 216.239.43.12 - 0 | 25 | 25 | 140 | 144 | 157 | 141 |
| 72.14.238.130 - 0 | 25 | 25 | 156 | 157 | 172 | 156 |
| 72.14.239.253 - 0 | 25 | 25 | 156 | 158 | 203 | 156 |
| 72.14.236.19 - 0 | 25 | 25 | 156 | 158 | 172 | 156 |
| 74.125.103.94 - 0 | 25 | 25 | 156 | 156 | 172 | 157 |
|________________________________________________|______|______|______|______|______|____

Absolutely fine on TCL network, once it hits reach it slows a little.




Any opinions expressed on Geekzone are my own and not those of my employer.

42 posts

Geek
+1 received by user: 1


  Reply # 254527 9-Sep-2009 20:43
Send private message

I have the same delay problem, been getting it bad for a few months now. Am on Cable 4Mb service. Have also started to get lots of random disconects while gaming...getting very frustrated :o(

C:\>tracert v21.lscache4.c.youtube.com

Tracing route to v21.lscache4.l.google.com [74.125.15.158]
over a maximum of 30 hops:

1 11 ms 12 ms 11 ms 121-73-77-1.cable.telstraclear.net [121.73.77.1]

2 19 ms 18 ms 19 ms ie2-g-0-0-0.telstraclear.net [203.98.50.2]
3 20 ms 20 ms 18 ms ge-0-2-0-1.xcore1.acld.telstraclear.net [203.98.
50.251]
4 20 ms 20 ms 19 ms 203.167.233.10
5 144 ms 143 ms 146 ms i-3-1-2.wil-core02.bx.reach.com [202.84.142.189]

6 144 ms 145 ms 145 ms i-1-1.tlot03.bi.reach.com [202.84.251.234]
7 145 ms 145 ms 153 ms 72.14.197.53
8 154 ms 145 ms 146 ms 216.239.43.12
9 164 ms 157 ms 156 ms 72.14.238.130
10 157 ms 157 ms 157 ms 209.85.240.230
11 160 ms 156 ms 157 ms 216.239.48.95
12 156 ms 156 ms 158 ms 74.125.15.158

Trace complete.

What gets me proper annoyed is that I live only about 3 kms from Telstra clear headend in seaview!!! (don't know if internet comes from there though ;>)



671 posts

Ultimate Geek
+1 received by user: 10


  Reply # 254538 9-Sep-2009 21:06
Send private message

Alright, thanks, I can rule out routes I guess, since they're all the same. And location, since I live nowhere near Testerpot, though it could be a bunch of areas.

What could it possibly be? I get good performance downloading in general (10Mbps), just not with YouTube... very frustrating. I have noticed a few timeouts recently, though (pages not loading fully), but I figured it was the sites' problems. I haven't done any online gaming, so I don't know if that's affected.

2278 posts

Uber Geek
+1 received by user: 370

Trusted
Subscriber

  Reply # 257407 21-Sep-2009 18:54
Send private message

Screeb: Alright, thanks, I can rule out routes I guess,


You've only tested from you to youtube but not back. Sometimes the routing is asymmetric and will follow a slightly different path back. You'll need to use a 'looking glass' or routeviews site to test this.

these should be helpfull.
http://www.routeviews.org/

login to a server by going to say:
telnet route-views.routeviews.org
username: rviews
then to a : sh ip bgp [your ip address] | inc 9901

See what your results look like compared to someone who has got no problem at all.


easy way:
http://www.bgp4.as/looking-glasses




671 posts

Ultimate Geek
+1 received by user: 10


  Reply # 257424 21-Sep-2009 20:04
Send private message

insane:
Screeb: Alright, thanks, I can rule out routes I guess,


You've only tested from you to youtube but not back. Sometimes the routing is asymmetric and will follow a slightly different path back. You'll need to use a 'looking glass' or routeviews site to test this.

these should be helpfull.
http://www.routeviews.org/

login to a server by going to say:
telnet route-views.routeviews.org
username: rviews
then to a : sh ip bgp [your ip address] | inc 9901

See what your results look like compared to someone who has got no problem at all.


easy way:
http://www.bgp4.as/looking-glasses



But this isn't specific to YouTube, and like I said, I get good performance elsewhere.

Anyway, FWIW, here's my results from Sunnyvale CA using http://stat.qwest.net/looking_glass.html


  sh ip bgp 203.97.214.***

BGP routing table entry for 203.97.212.0/22, version 808780814
Paths: (2 available, best #1, table Default-IP-Routing-Table)
Not advertised to any peer
701 703 9901 4768, (aggregated by 4768 218.101.61.102)
137.39.2.149 (metric 285) from 205.171.0.153 (205.171.0.153)
Origin IGP, metric 10000, localpref 80, valid, internal, atomic-aggregate, best
Community: 209:888
Originator: 205.171.0.217, Cluster list: 205.171.0.153, 205.171.0.243
701 703 9901 4768, (aggregated by 4768 218.101.61.102)
137.39.2.149 (metric 285) from 205.171.0.154 (205.171.0.154)
Origin IGP, metric 10000, localpref 80, valid, internal, atomic-aggregate
Community: 209:888
Originator: 205.171.0.217, Cluster list: 205.171.0.153, 205.171.0.243


I'm not going to pretend to understand any of that, but anyway...

If anyone on cable who has good YouTube performance could do the same, that'd be great.

1027 posts

Uber Geek
+1 received by user: 96

Trusted

  Reply # 258081 24-Sep-2009 14:39
Send private message

Screeb: Wow, that's crazy.

Can other people comment on their YouTube performance? (Especially cable users)


I've found it a lot more sluggish than usual. It hasn't been overly bothersome though because I just let it buffer first.




My very metal Doctor Who theme



671 posts

Ultimate Geek
+1 received by user: 10


  Reply # 259100 28-Sep-2009 19:18
Send private message

Would anyone be so kind as to post some pings to their cable gateway? If you don't know it, just tracert www.paradise.net.nz for instance, and find the first external IP. I get an average of 11 or so ms, with some spikes and timeouts (though I don't get the timeouts if I ping somewhere else down the line).

2278 posts

Uber Geek
+1 received by user: 370

Trusted
Subscriber

  Reply # 259198 28-Sep-2009 23:21
Send private message

Can you do a Neotrace (free download) to 74.125.15.158? It shows you on a map of the world a graphical representation of your tracert.

When I tracert to that IP using my ISP it goes via Sydney and then to Tokyo and then to Taipei, and then finally to Sunnyvale/San Jose.

When I tracert to what appears to be the youtube cache I use ty-in-f118.google.com it skips the Taipei hop.

Finally download another program called SpeedBit video accelerator, its like a download manager for youtube :)

 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | ... | 33
View this topic in a long page with up to 500 replies per page Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.