Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




14753 posts

Uber Geek
+1 received by user: 2746

Trusted
Subscriber

# 137974 15-Dec-2013 18:41
Send private message

I'm having a weird problem. I noticed it because my MySQL backup failed (it's for XMBC). I can't ping localhost. I can ping other local addresses, I can use the internet, I just can't ping localhost.

I've reset my hosts file back to normal, that didn't do anything. My TCP settings are all set to automatic, IP4 only, IP6 disabled. Astrill VPN is installed but isn't currently loaded or running.

Any ideas? I'm stumped how to fix such a low level problem. Win 7-64, newly restored from a good system image to a new SSD after my last SSD failed, maybe 2 weeks ago. This backup was working fine last week.

ping localhost
Ping request could not find host localhost. Please check the name and try again.

ping 127.0.0.1
Pinging 127.0.0.1 with 32 bytes of data:
Reply from 127.0.0.1: bytes=32 time<1ms TTL=64

ping 192.168.1.10
Pinging 192.168.1.10 with 32 bytes of data:
Reply from 192.168.1.10: bytes=32 time<1ms TTL=64

sfc /scannow
Beginning system scan. This process will take some time.

Beginning verification phase of system scan.
Verification 17% complete.

Windows Resource Protection could not perform the requested operation.

Filter this topic showing only the reply marked as answer Create new topic
BDFL - Memuneh
63323 posts

Uber Geek
+1 received by user: 13853

Administrator
Trusted
Geekzone
Lifetime subscriber

  # 952637 15-Dec-2013 18:44
Send private message

It seems name resolution is affected, seeing that ping to 127.0.0.1 works.

Are you sure the hosts file has a line 127.0.0.1 localhost?







14753 posts

Uber Geek
+1 received by user: 2746

Trusted
Subscriber

  # 952650 15-Dec-2013 18:50
Send private message

I ran a Microsoft fixed tool that reset my hosts file to this. The bold part is my emphasis.

# Copyright (c) 1993-2006 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
# 102.54.94.97 rhino.acme.com # source server
# 38.25.63.10 x.acme.com # x client host

# localhost name resolution is handle within DNS itself.
# 127.0.0.1 localhost
# ::1 localhost

 
 
 
 


BDFL - Memuneh
63323 posts

Uber Geek
+1 received by user: 13853

Administrator
Trusted
Geekzone
Lifetime subscriber

  # 952652 15-Dec-2013 18:53
Send private message

Correct. I was wondering if there was a line perhaps pointing localhost to another IP - that was silly because if that was the case the IP would show up when doing ping.

Perhaps run Housecall?






14753 posts

Uber Geek
+1 received by user: 2746

Trusted
Subscriber

  # 952676 15-Dec-2013 19:34
Send private message

This isn't good... housecall64 can't sense my internet connection. It says to connect to the internet and try again. Housecall32 started to run, but hit an error and can't get past about 20 seconds in.

I'm also running Spybot and MSE. Any other suggestions?



14753 posts

Uber Geek
+1 received by user: 2746

Trusted
Subscriber

  # 952691 15-Dec-2013 20:16
Send private message

Nope. Spybot tells me I have a trojan, Win32.downloader.gen. It says it can remove it, but I'm getting malware bytes too.

I installed OpenOffice today, nothing else I can think of recently. Damn.



14753 posts

Uber Geek
+1 received by user: 2746

Trusted
Subscriber

  # 952727 15-Dec-2013 21:20
Send private message

Ok, virus fixed, and the following line is in my hosts file. I still can't ping localhost. Any other ideas? Thanks for the virus check idea, turned out to be a red herring but valuable.

127.0.0.1 localhost

74 posts

Master Geek
+1 received by user: 4


  # 952748 15-Dec-2013 21:55
One person supports this post
Send private message

Is the hash at the start of this line in you hosts file correct ??:
# 127.0.0.1 localhost
I thought that made the line a comment, try removing the hash


1358 posts

Uber Geek
+1 received by user: 319


  # 952755 15-Dec-2013 22:00
Send private message

Why would resolution of 'localhost' be handled by DNS??
As above, it's not working because you've modified the hosts file.

BDFL - Memuneh
63323 posts

Uber Geek
+1 received by user: 13853

Administrator
Trusted
Geekzone
Lifetime subscriber

628 posts

Ultimate Geek
+1 received by user: 56


  # 952834 16-Dec-2013 02:10
Send private message

Is there any particular reason IPV6 is disabled and how was it disabled?
I suspect your system might still be trying to use IPV6 to reach localhost.

Perhaps this helps?
http://bobstrand.com/totm/2010/04/hey-dude-wheres-my-localhost/




#include <standard.disclaimer>




14753 posts

Uber Geek
+1 received by user: 2746

Trusted
Subscriber

  # 952847 16-Dec-2013 07:21
Send private message

I've tried with and without the hash in front of the "127.0.0.1 localhost" line. IP6 has been disabled for a year.

I'll try enabling IP6 in case it's Microsoft having done something silly with their updates, thanks. Doesn't sound like it.

I may just have to tweak the configuration of things to use 127.0.0.1, MySQL especially.



14753 posts

Uber Geek
+1 received by user: 2746

Trusted
Subscriber

  # 953946 17-Dec-2013 21:06
Send private message

Well I still can't connect to localhost, regardless of whether IP6 is enabled. This could be related to the VPN client, I'll try uninstalling that tomorrow.

For now though, the reason I found the problem is the mysql backup problem.

C:\wamp\bin\mysql\mysql5.5.16\bin\mysqldump -h 192.168.1.10 -P 3306 -uroot -premoved xmbcmusicdatabase32 > xmbcmusicdatabase32.sql

mysqldump: Got error: 2004: Can't create TCP/IP socket (87) when trying to connect

Why is it trying to connect to port 87? I've tried it with and without the -P parameter. There's nothing on 87, but MySQL works fine on 3306.

Puzzling.



14753 posts

Uber Geek
+1 received by user: 2746

Trusted
Subscriber

  # 956564 23-Dec-2013 13:43
One person supports this post
Send private message

I tracked down the problem - it was the Astrill VPN software. Once I uninstalled that the ping worked, and it kept working after I reinstalled Astrill. Strange.

Filter this topic showing only the reply marked as answer Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

WLG-X festival to celebrate creativity and innovation
Posted 22-May-2019 17:53


HPE to acquire supercomputing leader Cray
Posted 20-May-2019 11:07


Techweek starting around NZ today
Posted 20-May-2019 09:52


Porirua City Council first to adopt new council software solution Datascape
Posted 15-May-2019 12:00


New survey provides insight into schools' technology challenges and plans
Posted 15-May-2019 09:30


Apple Music now available on Alexa devices in Australia and New Zealand
Posted 15-May-2019 09:11


Make a stand against cyberbullying this Pink Shirt Day
Posted 14-May-2019 20:23


Samsung first TV manufacturer to launch the Apple TV App and Airplay 2
Posted 14-May-2019 20:11


Vodafone New Zealand sold
Posted 14-May-2019 07:25


Kordia boosts cloud performance with locally-hosted Microsoft Azure ExpressRoute
Posted 8-May-2019 10:25


Microsoft Azure ExpressRoute in New Zealand opens up faster, more secure internet for Kiwi businesses
Posted 8-May-2019 09:39


Vocus Communications to deliver Microsoft Azure Cloud Solutions through Azure ExpressRoute
Posted 8-May-2019 09:25


Independent NZ feature film #statusPending to premiere during WLG-X
Posted 6-May-2019 22:13


The ultimate dog photoshoot with Nokia 9 PureView #ForgottenDogsofInstagram
Posted 6-May-2019 09:41


Nokia 9 PureView available in New Zealand
Posted 6-May-2019 09:06



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.