JWR:
Dreal:
JWR:
I can no longer shutdown my PC.

This  is an issue from one of the updates.

The initial Windows 10 upgrade didn't have this problem.

FWIW.. CPU: 5820K, AsRock X99 Extreme 4, Corsair 860i PSU, Gigabyte GeForce GTX 970 G1 Gaming - I think that is all that could affect the issue.

I have done searches. But, not found anything useful.

Also, I am familiar with all the control panel power settings. No problem there.

Probably some registry setting that updates have not dealt with correctly.


Ahhh, so you upgraded, rather than did a fresh install?

Well that hasn't really ever worked right. I tried windows xp and 7 to 8, and it just completely died. I also tried 7 to 10, and it failed during installation. Lucky really, those upgrades over wildly different OS versions, are always a major headache - much much much better to do a fresh install.

Worth just migrating your files, e-mail etc, and re-installing all the software on a fresh windows 10. 

No wonder your having problems there is some old obscure registry setting that windows 10 couldn't possibly have factored in.

I mean, I'd do an upgrade on a basically fresh system, such as the factory state of a windows 7 or 8 machine, just to better capture obscure drivers - with next to nothing program wise installed, or settings changes, but otherwise, just don't do it - fresh install has been the only clean/stable/safe way to upgrade a windows version, since IDK, like the 90s...


Well yes it was an upgrade from Windows 8.1.

However, the problem didn't occur immediately after the upgrade. But, instead after I applied some Windows updates.

The problem is possibly related to me upgrading rather installing. But, it could also be related to using an uncommon CPU/Chipset/PSU combo as well.

While I agree, a clean install is easiest. It isn't always desirable or practicable.

I have experienced a lot of Windows/Windows Server upgrades and versions (1-10).

Sometimes, you just have to work through the problems.

 

FWIW, I found a work around for this problem.

 

Control Panel\All Control Panel Items\Power Options\Choose what the power button does

uncheck option - Turn on fast startup (i.e. turn it off)

AFAIK fast startup saves part of the kernel to disk on shutdown. This saves time at startup because the PC can reload

 

an initialized kernel back off disk at startup.

However, in my case, it seems to be unable to save the kernel and therefore doesn't shutdown.

I have had to reset this option a few times. Windows updates sometime swap the setting back to the default value.