Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




82 posts

Master Geek


# 177428 2-Aug-2015 12:06
Send private message

Bit of a major eek after upgrade - serious issue with AMD driver, all graphics apps i.e. Photoshop Lightroom etc wouldn't run even though the most recent version of AMD Catalyst is meant to be W10 compatible so installed earlier version and now Windows won't even boot. Has anyone struck this?

View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2
17589 posts

Uber Geek

Trusted

  # 1357074 2-Aug-2015 12:07
Send private message

Trigger happy send button?



82 posts

Master Geek


  # 1357076 2-Aug-2015 12:10
Send private message

Lol yes! Am on the damn ipad because the PC is broken!

 
 
 
 


xpd

Chief Trash Bandit
9912 posts

Uber Geek

Mod Emeritus
Trusted
Lifetime subscriber

  # 1357144 2-Aug-2015 14:33
Send private message

When you say WIndows wont even boot, is it BSOD or something else ?




XPD / Gavin / DemiseNZ

 

Server : i5-3470s @ 3.50GHz  16GB RAM  Win 10 Pro    Workstation : i5-3570K @ 3.40GHz  20GB RAM  RX580 4GB Win 10 Pro    Console : Xbox One

 

https://www.xpd.co.nz - Games, emulation, geekery, and my attempts at photography.     Now on BigPipe 100/100 and 2Talk

 

Emulation - The art of getting your $4000 PC to run an 80's system - and still fails.




82 posts

Master Geek


  # 1357149 2-Aug-2015 14:48
Send private message

Yes BSOD. Have done a reinstall off a flash drive so now it will boot but I have no apps any more so am currently reinstalling everything. Happy days. Sounds like it's an AMD driver issue so hopefully they'll fix it quick. Shame, as I was loving Windows 10 til then! Until they sort the driver I have no graphics software so it's an absolutely pain. The error I get now is Internal_Power_Error but when I rolled back the graphics driver it was something else, didn't note it down.

4352 posts

Uber Geek

Moderator
Trusted
Lifetime subscriber

  # 1357187 2-Aug-2015 17:12
Send private message

I am using an AMD Radeon HD 5570, and W10 installed fine, I then ran the online update utility for AMD, and got the new drivers no problems.
I am yet to test Photoshop/Premiere/Lightroom.

2213 posts

Uber Geek


  # 1357212 2-Aug-2015 18:01
Send private message

I had a few issues on W10 preview, have a Radeon HD4550 card, for me i had to

 

Delete the AMD video driver that W10 installed
Download/install the driver from AMD website (driver was old, like 2013 or something)
Manually installed this driver 
Download/Install Catalyst control center

Windows update has since updated to a newer AMD driver than available from AMD website andtouchwood without any further issues

This was a couple of months ago so hopefully AMD might have sorted their stuff given the public release of W10



82 posts

Master Geek


  # 1357216 2-Aug-2015 18:04
Send private message

It's version 15.7.1 that I have that's giving me the trouble and pretty sure that's the latest. Is Catalyst necessary?

 
 
 
 


559 posts

Ultimate Geek

Trusted
Lifetime subscriber

  # 1357218 2-Aug-2015 18:07
Send private message

I am using an AMD Radeon Sapphire HD 6570, and W10 installed fine, I then ran the online update utility for AMD, and got the new drivers no problems. same driver as you are trying to run
Don't have photoshop but all running smoothly

Click to see full size



8033 posts

Uber Geek

Trusted

  # 1358088 3-Aug-2015 18:27
Send private message

vroom: It's version 15.7.1 that I have that's giving me the trouble and pretty sure that's the latest. Is Catalyst necessary?


What graphics card do you have?



82 posts

Master Geek


  # 1358096 3-Aug-2015 18:44
Send private message

H7600M - I'm wondering if it's too old for the new driver?



82 posts

Master Geek


  # 1358125 3-Aug-2015 19:27
Send private message

Update: I've managed to get an older driver on it - Vs 15.6 so far so good, fingers crossed.

2153 posts

Uber Geek


  # 1358211 3-Aug-2015 21:11
Send private message

I have an issue that I believe is related to my AMD A8-3510MX APU Graphics. Lots of HTML5 Video won't play, sometimes on chrome, sometimes on Edge



82 posts

Master Geek


  # 1358254 3-Aug-2015 22:37
Send private message

I think that's fairly common in my research on my issue - have a look at the AMD forums on their website - that's how I eventually found the answer.

2153 posts

Uber Geek


  # 1358255 3-Aug-2015 22:43
Send private message

vroom: I think that's fairly common in my research on my issue - have a look at the AMD forums on their website - that's how I eventually found the answer.


HTML 5 video? did you have that issue too



82 posts

Master Geek


  # 1358260 3-Aug-2015 22:57
Send private message

I didn't get that far, I didn't even try video - but there were quite a few references to video problems. 

 1 | 2
View this topic in a long page with up to 500 replies per page Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Bitcoin.com announces partnership with smartphone manufacturer HTC
Posted 16-Sep-2019 21:30


Finalists Announced for Microsoft NZ Partner Awards
Posted 16-Sep-2019 19:37


OPPO Showcases New CameraX Capabilities at Google Developer Days China 2019
Posted 15-Sep-2019 12:42


New Zealand PC Market returns to growth
Posted 15-Sep-2019 12:24


Home sensor charity director speaks about the preventable death which drives her to push for healthy homes
Posted 11-Sep-2019 08:46


Te ao Maori Minecraft world set to inspire Kiwi students
Posted 11-Sep-2019 08:43


Research reveals The Power of Games in New Zealand
Posted 11-Sep-2019 08:40


Ring Door View Cam now available in New Zealand
Posted 11-Sep-2019 08:38


Vodafone NZ to create X Squad
Posted 10-Sep-2019 10:25


Huawei nova 5T to be available 20th September
Posted 5-Sep-2019 11:55


Kogan.com launches prepay challenger brand Kogan Mobile in New Zealand
Posted 3-Sep-2019 11:42


Pagan Online available now
Posted 27-Aug-2019 20:22


Starship hopes new app will help combat antibiotic resistance challenges
Posted 27-Aug-2019 19:43


Intel expands 10th Gen Intel Core Mobile processor family
Posted 23-Aug-2019 10:22


Digital innovation drives new investment provider
Posted 23-Aug-2019 08:29



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.