Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


View this topic in a long page with up to 500 replies per page Create new topic
1 | 2 | 3


1392 posts

Uber Geek


  # 1361714 9-Aug-2015 20:36
Send private message

gorringS: might be as simple as way you logging ie put network name of nas in front of username like  for example nas1\admin instead of admin on it own as it probably temping to find password from your local pc rather than  nas if don't .
Ive got western digital NAS and is working fine here on windows 10


Just tried that.  Didn't work.

Right then.  I'm going to post a series of screen shots showing what my settings are, starting with the NAS.  I think these should be correct, given how my wife's Win 8.1 PC has no trouble:



Under Network Services, file service is switched on.  Workgroup is WORKGROUP.  Standalone Server is switched on.



Advanced options, just shows WINS server enabled.



My NAS account has full privileges.

Are there any other relevant settings to check for the NAS?



1392 posts

Uber Geek


  # 1361718 9-Aug-2015 20:45
Send private message


My advanced sharing settings.  Looks ok to me.



Clip of the Credentials Manager.  I haven't shown the Generic Credentials listings or "Other Items", but I don't think they're relevant.  When I chose "Remember my credentials" it created an entry, but the NAS didn't recognise my account, so I deleted that credential, hence why nothing is showing here.



Showing that my PC is in the WORKGROUP workgroup.



The pop-up when I try to access a folder on the NAS.



The error message when I try to login.





 
 
 
 


62 posts

Master Geek


  # 1361780 9-Aug-2015 22:21
Send private message

try using the ip address to access it instead as that will validate weither you got internal dns issue. unc \\ipaddress\  instead of using the device name. Alternatively try using in login BASESTAR10\username and see if make any difference. Other thing you can try is flushing your dns by typing ipconfig /flushdns in command prompt

654 posts

Ultimate Geek


  # 1361806 10-Aug-2015 00:22
Send private message

Lizard1977:
My advanced sharing settings.  Looks ok to me.


Showing that my PC is in the WORKGROUP workgroup.



I have a QNap NAS as well, and had a similar network problem after I upgraded from 8.1 to 10 on my computers. (Haven't done a clean install because the computers I've upgraded are running fine, as good as or better than with 8.1)

Not sure if it'll work but try changing Home Group connections to:

Use user accounts and passwords to connect to other computers.

One of my computers could access all other computers and NAS on the network and in the Home Group, but my other two couldn't even join the Home Group or access the NAS, and I kept getting the "enter user ID and password pop up then the credentials error when I tried to access the other computers and NAS with my logon user ID and password.

When I changed to the Use user accounts and passwords option, all computers could access all the others and the NAS, no longer got the User ID/Password prompt either.



1392 posts

Uber Geek


  # 1361812 10-Aug-2015 06:45
Send private message

Thanks for these suggestions, guys:

I tried accessing it via the DNS address and it showed me the folders, same as if I typed in the Network Name, but it still prompts for the login, and still won't accept my username and password.

I tried flushing the DNS - no change.

I tried changing the Homegroup to use user accounts.  Didn't work.  

At this stage, the only other thing I can think of is to restore the NAS to factory settings.  Will that affect any data on the drives?  I'm reluctant to do that because I don't really think it's the NAS that's misconfigured, but I can't see anything else in Windows that could be changed.

dan

1072 posts

Uber Geek

Lifetime subscriber

  # 1361836 10-Aug-2015 08:47
Send private message


you need to add the machine name before the login on windows 10 if your windows 10 machine is using a microsoft cloud account to sign in opposed to a local account

in your private network location settings, choose "use user accounts and passwords to connect to other computers"

then when you connect to the qnap

holly-qnap\admin for username - enter password normally

make sure to tick remember password


also check out this page if you dont get it working:

https://techjourney.net/cannot-connect-to-cifs-smb-samba-network-shares-shared-folders-in-windows-10/

if still stuck PM me can help you via teamviewer.



1392 posts

Uber Geek


  # 1361838 10-Aug-2015 08:52
Send private message

dan:
you need to add the machine name before the login on windows 10 if your windows 10 machine is using a cloud account to sign in opposed to a local account

in your private network location settings, choose "use user accounts and passwords to connect to other computers"

then when you connect to the qnap

holly-qnap\admin for username and password

make sure to tick remember password


I'm pretty sure I've tried all those things already.  Will double-check when I get home tonight though.

If it does fix the problem, though, it baffles me why this has become an issue in Windows 10 when it worked fine previously in Windows 8.1.  I also had the same problems when I signed in to Windows with a new, local account.  

Just to clarify - the NAS is operating as a standalone server, not using AD or LDAP.  I can't work out why my Windows account should have any bearing on how File Explorer accesses the NAS shared folders.

Windows login - Microsoft (Outlook email address) account.
QNAP login - local account.

 
 
 
 


dan

1072 posts

Uber Geek

Lifetime subscriber

  # 1361841 10-Aug-2015 08:59
Send private message

its not just your NAS, same issue if you have a cloud login on windows 10, connecting from windows 10 to machines with windows 8, 7 etc that have open shares that would have worked perfectly fine to connect to without any credentials on Windows 7, 8 etc

the key is the destination machine name at the front of the login and having use user accounts and passwords to connect to other computers enabled

if you switch it from a cloud account to a local account it will just work right away



1392 posts

Uber Geek


  # 1361844 10-Aug-2015 09:02
Send private message

Thanks Dan.  I will try again tonight.

However, someone else already suggested signing in to Windows with local Windows account, but it didn't make any difference.  The same problem persisted.

dan

1072 posts

Uber Geek

Lifetime subscriber

  # 1361853 10-Aug-2015 09:14
Send private message

to be fair i havent tried switching from a cloud to a local, only machines that were clean installed as either cloud or local from the start, there may be a difference or you may have not add your sharing settings right when you switched

the screenshots you posted are exactly the messages you get when having this annoyance tho so it does seem like you have that exact issue

anyway send me a PM if you cant sort it can help you via teamviewer.



2023 posts

Uber Geek

Subscriber

  # 1362025 10-Aug-2015 12:19
Send private message

Yes, you certainly have to follow dan's advice and prefix the NAS user name with the NAS device name. The big clue is evident in the enter credentials screen. Note it says the Domain is your computer's name NOT the NAS name.

Whether this completely fixes your problem I can't say but it won't work without this  small addition.

I also can relate to the mention of SMB version. My main comp had been updated from Win 7, win 8, win 8.1 then win 10. Out of four win 10 comps here this one was the only one that wouldn't share over the network. I kept getting the 80070035 path not found error. Eventually, I tracked the problem down to a Lanman Server registry entry that specified SMB2 was enabled. No other win 10 comps even had that reg entry so I deleted it and all came right. (Since then I have re-installed win 10 with a fresh install).

I have a WD Mybooklive NAS server and access to it is mostly fine but I have seen this comp occasionally have access denied problems when using the UNC name but OK with IP address. A reboot fixed it last time it occurred but I haven't any idea where to start looking for this one!! The NAS shows up in explorer but its shares can't be accessed. Being erratic makes it difficult as we all know.

Anyway, hope you get your access problem sorted.



1392 posts

Uber Geek


  # 1362089 10-Aug-2015 14:02
Send private message

I went home for lunch and was able to test a few things.

I switched the sharing settings to "Use user accounts and passwords to connect to other computers", and then tried the access the shared folder on the NAS with \\holly-qnap\peter as my login.  It blanked the Domain field in the box, but it still said that the folder was inaccessible.  I then logged in to Windows using a local account, and tried it again, but it made no difference.

So no luck then... :(

2023 posts

Uber Geek

Subscriber

  # 1362110 10-Aug-2015 14:22
Send private message

Damn!!! Back to the drawing board.



1392 posts

Uber Geek


  # 1362116 10-Aug-2015 14:28
Send private message

I had a quick read through of this article that Dan linked to:

https://techjourney.net/cannot-connect-to-cifs-smb-samba-network-shares-shared-folders-in-windows-10/

It has some promising suggestions there about guest access which I will look into tonight.  However, I'm doubtful that's the answer, as I was connecting using the NAS account even under windows 8.1 (not a guest access), but it might be worth a try.  The rest of the stuff about Samba and Domain users is a little over my head, but I will hopefully be able to work it out with my computer in front of me.



1392 posts

Uber Geek


  # 1362610 11-Aug-2015 09:25
Send private message

Made some good progress last night (thanks Dan for your awesome support via Teamviewer), and can finally access the NAS shared folders.  Spent a few minutes this morning picking through the settings to see what was going on.

We turned off Advanced Folder Permissions in the Users setting on the NAS.  I also had enabled Guest Access via a registry edit (per the article that Dan linked to) on my desktop PC (but not my Surface).  We also changed one of the shared folders to full guest access.  After that, all the folders became accessible.  When prompted for the credentials via File Explorer, we used BASESTAR10/peter as the username, rather than the name of the NAS, and this seemed to work.  However, what is weird is that it also worked on the Surface, where we changed no settings (not even adding credentials) or even edited the registry.

This morning, on the NAS, I turned off full guest access for the one shared folder we had turned it on for, and it still let me access it.  I also removed the registry value I added to re-enable guest access, and rebooted, and I was still able to access it.  I then tried removing the Windows credentials that were stored for the shared folders.  It stopped working.  I re-added it, and it worked again.  Aha, we're getting somewhere, I thought.  I removed it again, and it continued to work.  This was confirmed on my surface, where no windows credentials had been stored - I could still access the shared folders.

So on the plus side, it's working.  But on the down side, I don't really know why it's working.  It seems to be counter-intuitive.  It seemed like we just needed to get the Windows Credentials right and turn off Advanced Folder Permissions on the NAS.  But even that is counter-intuitive, when the only credentials that work require the PC name (not the NAS name) to preface the login name.  It also doesn't make sense why it will continue to work when the credentials aren't there (as with the Surface).  It suggests that the PC is operating off guest access, but that shouldn't be allowed according to Microsoft.  When I checked the folder permissions on the NAS, it showed for some (but not all) a new user group called Everyone, which has read only access.  That suggested to me that maybe I was able to access the folder as part of the "Everyone" group, but I still am able to create and delete files on those folders, which is a lot more than just read-only access.

So I'm baffled, but grateful that I can access my shared folders again.  I just hope that it's not a temporary fix and that it falls over in the future...

1 | 2 | 3
View this topic in a long page with up to 500 replies per page Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

New AI legaltech product launched in New Zealand
Posted 21-Aug-2019 17:01


Yubico launches first Lightning-compatible security key, the YubiKey 5Ci
Posted 21-Aug-2019 16:46


Disney+ streaming service confirmed launch in New Zealand
Posted 20-Aug-2019 09:29


Industry plan could create a billion dollar interactive games sector
Posted 19-Aug-2019 20:41


Personal cyber insurance a New Zealand first
Posted 19-Aug-2019 20:26


University of Waikato launches space for esports
Posted 19-Aug-2019 20:20


D-Link ANZ expands mydlink ecosystem with new mydlink Mini Wi-Fi Smart Plug
Posted 19-Aug-2019 20:14


Kiwi workers still falling victim to old cyber tricks
Posted 12-Aug-2019 20:47


Lightning Lab GovTech launches 2019 programme
Posted 12-Aug-2019 20:41


Epson launches portable laser projector
Posted 12-Aug-2019 20:27


Huawei launches new distributed HarmonyOS
Posted 12-Aug-2019 20:20


Lenovo introduces single-socket servers for edge and data-intensive workloads
Posted 9-Aug-2019 21:26


The Document Foundation announces LibreOffice 6.3
Posted 9-Aug-2019 16:57


Symantec sell enterprise security assets for US$ 10.7 billion to Broadcom
Posted 9-Aug-2019 16:43


Artificial tongue can distinguish whisky and identify counterfeits
Posted 8-Aug-2019 20:20



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.