Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




321 posts

Ultimate Geek
+1 received by user: 23


# 208571 17-Feb-2017 12:26
Send private message

Hi,

 

When u punch in long numbers into excel cell, it changes it to zero or a formula thing.

 

For Example:

 

my original number is 881654014321, but excel changes it to either "8.81654E+11" or "881654000000" when i save it.

 

Also when i change back the cell format for "8.81654E+11" to "number", it changes to "881654000000" (which is not even my original number)

 

The problem is , i have to do CVS uploads and they show as error because "part number no found".

 

 

 

Any permanent fix for this ?

 

Thanks in advance..





I Eat Dumbbells for Breakfast


Filter this topic showing only the reply marked as answer View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2
1202 posts

Uber Geek
+1 received by user: 172

Trusted
Subscriber

  # 1721773 17-Feb-2017 12:29
One person supports this post
Send private message

Format cell as text.

 

 


5473 posts

Uber Geek
+1 received by user: 1914


  # 1721774 17-Feb-2017 12:29
2 people support this post
Send private message

Change the format of the cell to "number" with 0 decimal places


 
 
 
 




321 posts

Ultimate Geek
+1 received by user: 23


  # 1721777 17-Feb-2017 12:34
Send private message

dolsen:

 

Format cell as text.

 

 

 

 

 

 

If i change to text, it does the same thing and changes to all zeroes at the end.





I Eat Dumbbells for Breakfast




321 posts

Ultimate Geek
+1 received by user: 23


  # 1721778 17-Feb-2017 12:34
Send private message

RunningMan:

 

Change the format of the cell to "number" with 0 decimal places

 

 

 

 

Already done that.

 

But number appears with all zeroes and not what i really entered.





I Eat Dumbbells for Breakfast


1202 posts

Uber Geek
+1 received by user: 172

Trusted
Subscriber

  # 1721781 17-Feb-2017 12:37
Send private message

Sulco:

 

dolsen:

 

Format cell as text.

 

 

 

 

 

 

If i change to text, it does the same thing and changes to all zeroes at the end.

 

 

Are you sure you have changed it correctly? From excel, "Text format cells are treated as text even when a number is in the cell. The cell is displayed exactly as entered."

 

Putting your number into excel here, the number is exactly as entered.

 

 

 

 




321 posts

Ultimate Geek
+1 received by user: 23


  # 1721789 17-Feb-2017 12:43
Send private message

It does not change for me .!!!!!

 

 

 

what am i doing wrong ??

 





I Eat Dumbbells for Breakfast


1202 posts

Uber Geek
+1 received by user: 172

Trusted
Subscriber

  # 1721803 17-Feb-2017 12:54
Send private message

Sulco:

 

It does not change for me .!!!!!

 

 

 

what am i doing wrong ??

 

 

 

So, right click on the cell(s).

 

Select format cells

 

Select text under the category option on the number tab.

 

 

 

 

 

 

 

Edit - I chose text as they way I think you are using this is basically taking a part number from an external source and using it basically as a string. If you are doing calculations on it, using the number with 0 decimal places would be the better approach. Some people may say it the is better approach regardless - I wouldn't necessarily argue against that.

 

 

 

 


 
 
 
 


1031 posts

Uber Geek
+1 received by user: 457

Trusted
Subscriber

  # 1721804 17-Feb-2017 12:55
Send private message

I just tried formatting the cell as a number with 0 decimal places and it worked perfectly. Using Excel 2016 on a PC through Office 365.






4 posts

Wannabe Geek


  # 1721810 17-Feb-2017 13:02
Send private message

Try a single quote before, i.e.  '881654014321


5473 posts

Uber Geek
+1 received by user: 1914


  # 1721814 17-Feb-2017 13:07
Send private message

Using the number you provided, it is displaying correctly for me when the cell is formatted as number, with 0 decimal places.


2537 posts

Uber Geek
+1 received by user: 944

Subscriber

  # 1721822 17-Feb-2017 13:18
Send private message

Microsoft knowledge base article about Excel truncating number values to 15 significant figures, leading remaining places as 0. From your example, though, it looks like your number is only 12 digits to begin with. What version of Excel are you using? Both the prior suggestions here - Number with 0 decimal places, or Text with a leading ' - display your example value correctly for me in both Excel 2013 and Excel 2016, as does setting it to Custom with a Type of 0.

 

 


1202 posts

Uber Geek
+1 received by user: 172

Trusted
Subscriber

  # 1721824 17-Feb-2017 13:23
Send private message

Inphinity:

 

Both the prior suggestions here - Number with 0 decimal places, or Text with a leading ' - display your example value correctly for me in both Excel 2013 and Excel 2016, as does setting it to Custom with a Type of 0.

 

 

 

 

 

Just to clarify, a text field does not need the leading '. A general field does.

 

Having as text field may help protect the value from being automagically corrected / updated by Excel for an inexperienced user.

 

 

 

 


120 posts

Master Geek
+1 received by user: 24


  # 1721827 17-Feb-2017 13:31
Send private message

When you are trying to import the CSV file how are you doing it?

 

Are you going to Date/From Text in a blank Excel spreadsheet

 

Select what row you want to import from

 

Click "My Data has Headers" if csv has headers

 

Select Next

 

Select whether the CSV file is delimited by Tabs or by comma etc.

 

Select Next

 

Select the column that is showing the value you are having issues with?

 

Change it from General to Text

 

Click Finish




321 posts

Ultimate Geek
+1 received by user: 23


  # 1721837 17-Feb-2017 13:56
Send private message

Inphinity:

 

Microsoft knowledge base article about Excel truncating number values to 15 significant figures, leading remaining places as 0. From your example, though, it looks like your number is only 12 digits to begin with. What version of Excel are you using? Both the prior suggestions here - Number with 0 decimal places, or Text with a leading ' - display your example value correctly for me in both Excel 2013 and Excel 2016, as does setting it to Custom with a Type of 0.

 

 

 

 

 

 

i am using Microsoft excel for MAC 2011 and it says its up to date.

 

 





I Eat Dumbbells for Breakfast




321 posts

Ultimate Geek
+1 received by user: 23


  # 1721839 17-Feb-2017 14:02
Send private message

i did format the cell to number by right clicking and format.

 

Then save the file as .csv

 

When i reopen the file, it has again changed back to 8.81654E.11

 

 





I Eat Dumbbells for Breakfast


 1 | 2
Filter this topic showing only the reply marked as answer View this topic in a long page with up to 500 replies per page Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

New Zealand government unveils new digital service to make business easier
Posted 16-Jul-2019 17:35


Scientists unveil image of quantum entanglement
Posted 13-Jul-2019 06:00


Hackers to be challenged at University of Waikato
Posted 12-Jul-2019 21:34


OPPO Reno Z now available in New Zealand
Posted 12-Jul-2019 21:28


Sony introduces WF-1000XM3 wireless headphones with noise cancellation
Posted 8-Jul-2019 16:56


Xero announces new smarter tools, push into the North American market
Posted 19-Jun-2019 17:20


New report by Unisys shows New Zealanders want action by social platform companies and police to monitor social media sites
Posted 19-Jun-2019 17:09


ASB adds Google Pay option to contactless payments
Posted 19-Jun-2019 17:05


New Zealand PC Market declines on the back of high channel inventory, IDC reports
Posted 18-Jun-2019 17:35


Air New Zealand uses drones to inspect aircraft
Posted 17-Jun-2019 15:39


TCL Electronics launches its first-ever 8K TV
Posted 17-Jun-2019 15:18


E-scooter share scheme launches in Wellington
Posted 17-Jun-2019 12:34


Anyone can broadcast with Kordia Pop Up TV
Posted 13-Jun-2019 10:51


Volvo and Uber present production vehicle ready for self-driving
Posted 13-Jun-2019 10:47


100,000 customers connected to fibre broadband network through Enable
Posted 13-Jun-2019 10:35



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.