Just wondering, is it normal for Internet Explorer to ask you to "setup" Internet Explorer each time a cumulative update is installed on Windows 10 (in my case, version 1511)?

 

If it is, can anyone point me in the correct direction of the correct GPO to update (currently have version 1607 ADMK installed on the domain controller)