Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




Lock him up!
11220 posts

Uber Geek

Lifetime subscriber

# 259889 28-Oct-2019 21:52
Send private message

I am having a really perplexing issue with Chromecast. I do not have a dongle but I do have an Nvidia Shield with built-in  Chromecast. I cast to it from the Chrome browser on either of two laptops, one running Win 7, the other Win 10. I’m not sure of the laptop specs offhand, but both are more than capable of normal streaming. The Shield has a wired connection, the laptops are on a wi-fi link that serves only them. 

 

In addition to the Shield, I also have a MeCool combo device that receives DVB-T and satellite, and also has a Shield clone built in for Internet. This is also on a wired connection. The MeCool is not authorised by Google so does not actually work as a cast destination, but it shows up as a cast device on Chrome. 

 

Until recently, casting from either laptop to the Shield has worked perfectly. One time the Shield stopped being recognised but this was easily fixed by resetting the built-in Chromecast app. Since then it has worked fine until a couple days ago.

 

The other day I started getting random issues that don’t make any sense at all to me. Sometimes the Shield is recognised by one laptop or the other, sometimes only one, sometimes both. The Win 10 laptop seems to have the most trouble. For some reason, it seems to see the Shield more often if I also have the MeCool powered on.

 

When I am able to get either computer to cast, the audio is very choppy. This is a new problem. I haven’t had it before. It seems to be the same on both computers, though maybe worse on the Win 7 laptop. I’m not sure if the video is also affected. I only notice it on the audio. I have tried rebooting and powering down all devices. Also resetting the Shield app. Sometimes this seems to help Chrome find the Shield Chromecast device, but is doesn’t help the choppy audio. 

 

There is no problem with the wi-fi or the source. If I view on either laptop, the stream is smooth and the audio perfect. I only get the problem when casting to the Shield, about two metres away. 

 

I also tried casting the desktop instead of the tab. This also used to work fine. This time the audio quality was poor, as if echoing from the bottom of a barrel, but it wasn’t as choppy. 

 

Everything worked perfectly until it stopped working. I am not aware of anything I have changed. It worked, then it didn’t. The randomness of this is very frustrating. I don’t understand what is happening or why. Any suggestions or ideas would be very welcome. I did look on Google, but the information I could find was not very helpful. One ‘tip’: this just happens sometimes and if you wait long enough it may correct itself. I am hoping for something a little better than that.
 

 

 

 

 





I don't think there is ever a bad time to talk about how absurd war is, how old men make decisions and young people die. - George Clooney
 


Create new topic
BDFL - Memuneh
65382 posts

Uber Geek

Administrator
Trusted
Geekzone
Lifetime subscriber

  # 2344631 28-Oct-2019 23:24
Send private message

Are all these devices connected via ethernet? If WiFi is congested (a new neighbour? a new WiFi device on an existing neighbour?) then it could cause performance problems. Or if WiFi isolation is turned on, then the laptops can't see the Chromecast target. 

 

Do you have a new router or updated an existing router? Have you added anything? Tried using ethernet instead of WiFi?







Lock him up!
11220 posts

Uber Geek

Lifetime subscriber

  # 2344637 29-Oct-2019 02:26
Send private message

That's the frustrating thing. Nothing at all has changed in my set-up. It seems completely random.

 

We live on a farm and the nearest neighbours are nearly a kilometer away through trees. No wi-fi interference of any kind. All devices except the two laptops are on Ethernet. The wi-fi the laptaps use is from a D-link in the same room, fed by ethernet. The range is only a couple of meters. This set-up has worked perfectly until just the other day. Nothing has been changed. Then suddenly both laptops could not detect the Shield. I reset the built-in Chromecast app on the Shield as I had previously done but it didn't make a difference. After rebooting both laptops, the Win 7 one saw the Shield but the Win 10 did not. I don't use the satellite/UHF receiver anymore but I turned it on to test the Chromecast since it normally gets detected. For some reason that caused the Win 10 computer to start detecting the Shield. I could cast, but the audio is choppy. The site I am trying to stream does not support casting so it is going through the computer but I am getting the same thing on both laptops and this has not been a problem before.

 

It just occurred to me that our router has indeed changed, in the sense that we switched from RBI to WISP a few months ago, but I'm fairly sure I have tried casting through the laptops since then and have not encountered this problem. Also the randomness that sometimes the Shield is detected, sometimes not, I don't know what could be causing that.

 

 

 

 

 

 





I don't think there is ever a bad time to talk about how absurd war is, how old men make decisions and young people die. - George Clooney
 


 
 
 
 


7210 posts

Uber Geek

Trusted
Subscriber

  # 2344641 29-Oct-2019 06:32
Send private message

The devices that are wired, are they connected direct to the router, or to a switch which inturn also connects to the router.

 

Cyril


113 posts

Master Geek

Vodafone NZ

  # 2344642 29-Oct-2019 06:41
Send private message

I noticed my Chromecast app updated last week on my Mi Box.

 

I wonder if the software update was the issue for you, especially given you were not experiencing any issues prior to last week?

 

It might explain it - if your apps update automatically?

 

 

 

 

 

 

 

 


743 posts

Ultimate Geek


  # 2344675 29-Oct-2019 08:27
Send private message

Have you fully powered down the Shield  - incl. pulling the power plug - not just turned it "off" with the remote?

 

Possibly a SW update or somethings gone to sh%te - might be worth a go if you haven't already.




Lock him up!
11220 posts

Uber Geek

Lifetime subscriber

  # 2345683 29-Oct-2019 09:29
Send private message

I am also starting to suspect something Google has done because of the way things have changed, but I have updates turned off on the Shield for exactly this kind of reason. I'm not sure about Chrome browser on the laptops.

 

The wired devices do go through a LAN switch that is fed from the router. The switch feeds the MeCool and the Shield, as well as the wi-fi that serves the two laptops. I guess I will have to start going through the daisy chain and see if I can find a difference anywhere. I didn't used to mind doing this kind of thing when I was younger, but I really hate it now. Once something is working, it should just keep working. I haven't got the patience or energy for this crap.

 

I did fully power down the Shield while testing this. We also have all devices on a wall switch that is turned off every night.

 

Normally I now keep the MeCool turned off since we no longer use it, so the Shield and wi-fi are the only devices on that LAN connection. One thing I really don't get is that the MeCool appears to affect the ability of at least one laptop to detect the Chromecast device on the Shield. I have tested this several times and it seems to be more than coincidence, though I can't be 100% certain. I have no idea why this would be so.

 

Thanks all for the responses. I really appreciate it. I will post any updates and suggestions continue to be welcomed. 

 

 

 

 





I don't think there is ever a bad time to talk about how absurd war is, how old men make decisions and young people die. - George Clooney
 


Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Vodafone New Zealand starts two year partnership with LetsPlay.Live
Posted 28-Jan-2020 11:24


Ring launches indoor-only security camera
Posted 23-Jan-2020 17:26


New report findings will help schools implement the digital technologies curriculum content
Posted 23-Jan-2020 17:25


N4L to upgrade & support wireless internet inside schools
Posted 23-Jan-2020 17:22


Netflix releases 21 Studio Ghibli works
Posted 22-Jan-2020 11:42


Vodafone integrates eSIM into device and wearable roadmap
Posted 17-Jan-2020 09:45


Do you need this camera app? Group investigates privacy implications
Posted 16-Jan-2020 03:30


JBL launches headphones range designed for gaming
Posted 13-Jan-2020 09:59


Withings introduces ScanWatch wearable combining ECG and sleep apnea detection
Posted 9-Jan-2020 18:34


NZ Police releases public app
Posted 8-Jan-2020 11:43


Suunto 7 combine sports and smart features on new smartwatch generation
Posted 7-Jan-2020 16:06


Intel brings innovation with technology spanning the cloud, network, edge and PC
Posted 7-Jan-2020 15:54


AMD announces high performance desktop and ultrathin laptop processors
Posted 7-Jan-2020 15:42


AMD unveils four new desktop and mobile GPUs including AMD Radeon RX 5600
Posted 7-Jan-2020 15:32


Consolidation in video streaming market with Spark selling Lightbox to Sky
Posted 19-Dec-2019 09:09



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.