Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


View this topic in a long page with up to 500 replies per page Create new topic
1 | 2 | 3
8035 posts

Uber Geek

Trusted

  #283748 18-Dec-2009 13:29
Send private message

If my web server's lan ip address was 192.168.1.55 and the url I want to use to access it was xyz.mydomain.com you would add a line:

192.168.1.55 xyz.mydomain.com

Note: the # character is used to comment out a line so it's not enabled, so don't put a # in front of this line.

First I would double check if your make/model of router supports local loop back, as this would make host file entries unnecessary.

BDFL - Memuneh
65558 posts

Uber Geek

Administrator
Trusted
Geekzone
Lifetime subscriber

  #283751 18-Dec-2009 13:38
Send private message

imanewbe: what do you mean by domain? Im a bit of a noob sorry. Is it like my computer name.


Whe did you put the files? On the default folder for the webserver, or on IIS have your created a new "site"? If you created a new site you must have entered a name on binding - this is the name you have to enter on your browser and in the hosts files.

Now...

1.You might just put the files in the default site, which means the binding is everything coming in regardless of header will be for that site: browsing by IP address should just work

2.You might have created a new site on IIS, which means the binding is to a specific domain (right-click the site, click Binding and find what you have there). In this case on your hosts file you can enter the PC LAN IP address and the site name as specific in the binding.





 
 
 
 




22 posts

Geek


  #283761 18-Dec-2009 13:51
Send private message

Ragnor: If my web server's lan ip address was 192.168.1.55 and the url I want to use to access it was xyz.mydomain.com you would add a line:

192.168.1.55 xyz.mydomain.com

Note: the # character is used to comment out a line so it's not enabled, so don't put a # in front of this line.

First I would double check if your make/model of router supports local loop back, as this would make host file entries unnecessary.


It does not support local loop back.
I tried putting into the hosts file: 10.1.1.3 http://hadleyfraser.homeip.net/ but it didn't seem to help
is this correct. The ip of my computer is 10.1.1.3 and the url i got from dyndns.com is http://hadleyfraser.homeip.net/




22 posts

Geek


  #283764 18-Dec-2009 13:55
Send private message

freitasm:
imanewbe: what do you mean by domain? Im a bit of a noob sorry. Is it like my computer name.


Whe did you put the files? On the default folder for the webserver, or on IIS have your created a new "site"? If you created a new site you must have entered a name on binding - this is the name you have to enter on your browser and in the hosts files.

Now...

1.You might just put the files in the default site, which means the binding is everything coming in regardless of header will be for that site: browsing by IP address should just work

2.You might have created a new site on IIS, which means the binding is to a specific domain (right-click the site, click Binding and find what you have there). In this case on your hosts file you can enter the PC LAN IP address and the site name as specific in the binding.



I right clicked on the site and went to bindings and i have localhost and 127.0.0.1 and neither have a host name. If i try to add 1 it says it 127.0.0.1:80 is an invalid ip address

BDFL - Memuneh
65558 posts

Uber Geek

Administrator
Trusted
Geekzone
Lifetime subscriber

  #283767 18-Dec-2009 13:59
Send private message

It sounds like you're using the default site - which means browinsg by IPAdress should bring up the site.

Next question: when you try on your local PC you can see the default page?






22 posts

Geek


  #283769 18-Dec-2009 14:01
Send private message

Do you mean if i got to localhost can i see it? Yes.

BDFL - Memuneh
65558 posts

Uber Geek

Administrator
Trusted
Geekzone
Lifetime subscriber

  #283772 18-Dec-2009 14:08
Send private message

In this case, if you enter http://10.1.1.3 on another PC you are not seeing anything? In this case I'd say

a) you do have a software firewall blocking connections
b) you other PC is in another LAN segment (not 10.1.1.x)

When did you turn your firewall off? Have you rebooted your PC since turning your firewall off?

On your other PC try running from a command prompt:

TELNET 10.1.1.3 80 [ENTER]
get [ENTER]

What do you see?




 
 
 
 


8035 posts

Uber Geek

Trusted

  #283773 18-Dec-2009 14:10
Send private message

Assuming on your lan pc's you can get to the site via http://10.1.1.3/ then if you want to get to it by http://hadleyfraser.homeip.net/ ...in the hosts file on the lan pc's you would put.

10.1.1.3 hadleyfraser.homeip.net






22 posts

Geek


  #283775 18-Dec-2009 14:14
Send private message

I get TELNET is not recognised as an internal or external command, operable program or batch file. Do i have to run something so i can telnet?
I have completely turned my windows firewall off and havent restarted my PC in a while.
I am running avg free 8.5 and i dont think it has a firewall of its own.



22 posts

Geek


  #283776 18-Dec-2009 14:16
Send private message

Ragnor: If on one of your lan pc's (not the server) you can get to the site by http://10.1.1.3/ then if you want to get to it by http://hadleyfraser.homeip.net/ in the hosts file on the lan pc's you would put.

10.1.1.3 hadleyfraser.homeip.net





I cant get to http://10.1.1.3/ from anyone other computer

8035 posts

Uber Geek

Trusted

  #283778 18-Dec-2009 14:17
Send private message

Can you ping 10.1.1.3 ?

Windows Key + r to bring up the run dialogue > type: "cmd" (without quotes) then hit enter > then type: "ping 10.1.1.3" and hit enter (without quotes)




22 posts

Geek


  #283781 18-Dec-2009 14:22
Send private message

yes. i can ping it. i can also access the shared files on my computer by typing \\computername

8035 posts

Uber Geek

Trusted

  #283782 18-Dec-2009 14:24
Send private message

In IIS take can you post screenshots of the bindings and basic setup screens for the site?

BDFL - Memuneh
65558 posts

Uber Geek

Administrator
Trusted
Geekzone
Lifetime subscriber

  #283784 18-Dec-2009 14:35
Send private message

imanewbe: I get TELNET is not recognised as an internal or external command, operable program or batch file. Do i have to run something so i can telnet?
I have completely turned my windows firewall off and havent restarted my PC in a while.
I am running avg free 8.5 and i dont think it has a firewall of its own.


TELNET is not installed by default on Windos Vista and Windows 7. Open Control Panel, Programs and Features, Turn Windows Features On or Off and check the box next to Telnet...

AVG8.5 free doesn't have a firewall - have you have disabled the Windows firewall entirely? If so you should reboot your system to complete the change.






22 posts

Geek


  #283787 18-Dec-2009 14:42
Send private message

https://cdn.geekzone.co.nz/imagessubs/blog6b51eb8e27aee87eb45af6c77e5657f3.jpg
https://cdn.geekzone.co.nz/imagessubs/blogcde9af319128629c6483770b55693c56.jpg
here are a couple of pics. Is this what you wanted?

1 | 2 | 3
View this topic in a long page with up to 500 replies per page Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Withings launches three new devices to help monitor heart health from home
Posted 13-Feb-2020 20:05


Auckland start-up Yourcar matches new car buyers with dealerships
Posted 13-Feb-2020 18:05


School gardens go high tech to teach kids the importance of technology
Posted 13-Feb-2020 11:10


Malwarebytes finds Mac threats outpace Windows for the first time
Posted 13-Feb-2020 08:01


Amazon launches Echo Show 8 in Australia and New Zealand
Posted 8-Feb-2020 20:36


Vodafone New Zealand starts two year partnership with LetsPlay.Live
Posted 28-Jan-2020 11:24


Ring launches indoor-only security camera
Posted 23-Jan-2020 17:26


New report findings will help schools implement the digital technologies curriculum content
Posted 23-Jan-2020 17:25


N4L to upgrade & support wireless internet inside schools
Posted 23-Jan-2020 17:22


Netflix releases 21 Studio Ghibli works
Posted 22-Jan-2020 11:42


Vodafone integrates eSIM into device and wearable roadmap
Posted 17-Jan-2020 09:45


Do you need this camera app? Group investigates privacy implications
Posted 16-Jan-2020 03:30


JBL launches headphones range designed for gaming
Posted 13-Jan-2020 09:59


Withings introduces ScanWatch wearable combining ECG and sleep apnea detection
Posted 9-Jan-2020 18:34


NZ Police releases public app
Posted 8-Jan-2020 11:43



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.