Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




29 posts

Geek
+1 received by user: 2


Topic # 55267 27-Dec-2009 20:09
Send private message

I've replaced my winXP pc with a win7 machine. Network printing no longer works. This seems to be a common issue with Win7 having Access Denied errors with network printers, but I can't find a solution that works for my printer. Does anyone have any thoughts?

I don't believe the printer installation is at issue, because it worked previously with the XP m/c.  I've rebooted the server it is attached to, just in case, but to no good effect.  I've since sold the XP, so can't go back to that to help with fault finding.

I've upgraded the printer driver on Win7, and have proven that direct printing from the usb port on PC is fine. The print job appears in the print queue, but after a couple of minutes there is an error message "Error - Printing" Not very helpful.

The new PC has Norton security built in, but I don't believe the firewall is the issue.  I've tried disabling for a period, and setting the server as a 'trusted' site - no effect.  If there is any troubleshooting to prove/disprove this, that might be helpful.

I've heard mention of 'compatability mode' with Win7, is that relevant to a solution here?

There are some similar posts elsewhere, but none seem to quite fit what I'm doing.  e.g.
http://social.technet.microsoft.com/Forums/en-US/itprovistaprinting/thread/8c3c3d97-9d85-4ab0-9fc8-4b7aba202fb2
http://forums.techarena.in/networking-security/1177634.htm
http://www.sevenforums.com/hardware-devices/21951-windows-7-access-shared-printer-xp.html

Anyone with ideas or suggestions?

Create new topic
2947 posts

Uber Geek
+1 received by user: 836

Trusted
Subscriber

  Reply # 285488 27-Dec-2009 20:36
Send private message

If you post a little more detail about your setup, someone may be able to help you a bit faster. Info like what your printer is and how it is connected to the server (ie slave, network cable, wireless etc).

If it's a network printer, what's it's IP address? What's the IP address of your Win7 machine? What brand is the printer? etc...



29 posts

Geek
+1 received by user: 2


  Reply # 285489 27-Dec-2009 20:44
Send private message

PC is wireless connected to a WAG54G router.
server is a Thecus N2100 RAID with USB print server.
Printer is a Canon MP610 and installed as http://IP_ADDR/printer/usb-printer. Connected to the RAID on a USB port.

all the above worked with WinXP, but not on Win7.

I left the RAID details out earlier, because I suspect that these will be red herrings as far as fixing the print problem will be concerned.

I can access the RAID over the network but not the printer. Thus it is not a routing problem, but is surely concerned with the print setup.

 
 
 
 


1775 posts

Uber Geek
+1 received by user: 253

Subscriber

  Reply # 285493 27-Dec-2009 21:19
Send private message

farfields:
Printer is a Canon MP610 and installed as http://IP_ADDR/printer/usb-printer. Connected to the RAID on a USB port.


Above line isn't what the manual says though is it. Manual refers to a specific port. Did you use this port.




Ross

 

Spark FibreMAX using Mikrotik CCR1009-8G-1S-1S+

 


Speed Test


Banana?
4048 posts

Uber Geek
+1 received by user: 858

Subscriber

  Reply # 285718 28-Dec-2009 21:09
Send private message

I've found the best way in Win7 is to install a new local printer on a new port.
So, Go to Devices and Printers folder,
Click Add a Printer
Click Add Local Printer
Click Create New Port
Select Local Port
In Port name, enter the UNC address of your printer - eg \\RAID\Printer_Name
It may then automatically find the drivers, or you may have to point windows at the driver for your printer.
After that, you're good to go. This has worked for me a few times in Win7 when I've had Access Denied messages.



29 posts

Geek
+1 received by user: 2


  Reply # 285912 29-Dec-2009 20:09
Send private message

Hi trig42, thanks for the response. Suggestion didn't take me any further unfortunately. Here's what I did:
Removed previous printer installation. Rebooted computer.
Devices and Printers folder,
Click Add a Printer
Click Add Local Printer
Click Create New Port
Select Local Port
entered addres as \\N2100RAID\printer\usb-printer
Had error message "system cannot find the file specified"
I think that this is because of the way the NAS works. The NAS file system is mounted as \\N2100RAID\ but the printer is not visible directly as a file type device. It is managed via the Linux OS that is being run. I presume this is why print jobs are sent via the TCP port.

So, I tried again with the install using:
Add a Printer
Add Local Printer
Create new Port
Select TCP/IP Port
Host name http://192.168.1.100:631/printers/usb-printer
Enter Port number also as 631

The printer appears in the printer list, but as before print job just sits in the queue and does not appear in the print tray!

Question: What is the meaning of the Port Name as:
http://192.168.1.100:631/printers/usb-printer_1
Is the "_1" significant? i.e. why does this get appended, and why can't it be edited?




29 posts

Geek
+1 received by user: 2


  Reply # 286167 30-Dec-2009 22:00
Send private message

I've found a new tip that might have a bearing....
After deleting previous instances of the printer setup, and rebooting, I followed this instructions:

1) Share Permissions
1. On explorer, go to C:\windows\system32\spool\PRINTERS
2. Right click, Properties
3. Sharing tab
4. Advanced Sharing
5. Check "Share this folder"
6. Permissions
7. Grant everyone Full Control

2) NTFS Permissions
1. On explorer, go to C:\windows\system32\spool\printers
2. Right click, Properties
3. Security tab
4. Edit
5. Add
6. Advanced
7. Find Now
8. Choose "NETWORK"
9. OK
10. Grant NETWORK Full Control

then reinstalled the printer again, as a local port with TCP/IP path

Unfortunately, this hasn't fixed the problem :-(

However, I describe what I did as it may give a clue to a reader here on what the cause of the problem is. I do note that during a print job that the system32 path described does, temporarily, contain the print file. I guess this means the print job gets into the queue, but doesn't get to the printer. sigh.

thanks,
FF


Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

From small to medium and beyond: Navigating the ERP battlefield
Posted 21-Nov-2017 21:12


Business owners: ERP software selection starts (and finishes) with you
Posted 21-Nov-2017 21:11


Why I'm not an early adopter
Posted 21-Nov-2017 10:39


Netatmo launches smart home products in New Zealand
Posted 20-Nov-2017 20:06


Huawei Mate 10: Punchy, long battery life, artificial intelligence
Posted 20-Nov-2017 16:30


Propel launch Disney Star Wars Laser Battle Drones
Posted 19-Nov-2017 21:26


UFB killer app: Speed
Posted 17-Nov-2017 17:01


The case for RSS — MacSparky
Posted 13-Nov-2017 14:35


WordPress and Indieweb: Take control of your online presence — 6:30 GridAKL Nov 30
Posted 11-Nov-2017 13:43


Chorus reveals technology upgrade for schools, students
Posted 10-Nov-2017 10:28


Vodafone says Internet of Things (IoT) crucial for digital transformation
Posted 10-Nov-2017 10:06


Police and Facebook launch AMBER Alerts system in NZ
Posted 9-Nov-2017 10:49


Amazon debuts Fire TV Stick Basic Edition in over 100 new countries
Posted 8-Nov-2017 05:34


Vodafone VoIP transition to start this month
Posted 7-Nov-2017 12:33


Spark enhances IoT network capability
Posted 7-Nov-2017 11:33



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.