Geekzone: technology news, blogs, forums
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.

440 posts

Ultimate Geek
+1 received by user: 104

Topic # 58129 9-Mar-2010 09:21
Send private message

I currently have W7 on a single HDD but would like to move the OS partition to a new raid0 drive.

Is there software that will do this or does the OS need to be reinstalled, loading the Raid drivers during install?

Can the partition be moved and then install the raid drivers afterwards somehow

I have used Acronis Disk Director in the past but never from a single HDD to RAID


Windows 7 Pro 64bit, Asus P6T motherboard, Intel i7 920, 6GB DDR3, ATi 5770 1GB

Create new topic
163 posts

Master Geek
+1 received by user: 5

  Reply # 305635 9-Mar-2010 11:07
Send private message

You really should just reinstall, as trying to get it going otherwise will be a world of hurt.

Most RAID controllers included on motherboards these days are software-based, rather than hardware, so the actual RAID implementation is in the driver. This means that if you create a RAID volume and image your existing boot drive onto it, you're likely to find that Windows will show each individual disk in My Computer, rather than a single RAID volume, because it hasn't loaded the driver.

And if you try to install the RAID driver in your existing copy of Windows before copying the boot drive to a RAID volume, you may well find that Windows will refuse to boot because it can't find the boot partition anymore, as the RAID volume is not in the same logical location as the old boot disk.

187 posts

Master Geek

  Reply # 305637 9-Mar-2010 11:14
Send private message

Win 7 makes this easy... so long as the RAID card is supported by the motherboard.

1. Perform Full windows system image backup on existing system drive to USB HDD
2. Removed system drive and add RAID drives
3. Boot from Win 7 DVD, if it finds your RAID volume then choose Restore system image and point it to USB HDD - otherwise you will need to provide drivers for your RAID adapter
4. In theory all should be back as it was when you ran the backup


440 posts

Ultimate Geek
+1 received by user: 104

  Reply # 305641 9-Mar-2010 11:22
Send private message

I have an image already using Acronis True Image. will this work or does it need to be W7 builtin Backup?

187 posts

Master Geek

  Reply # 305649 9-Mar-2010 11:53
Send private message

I would go with Win 7 built-in backup

440 posts

Ultimate Geek
+1 received by user: 104

  Reply # 305656 9-Mar-2010 12:17
Send private message

BartManGeek: Your plan 'A' Fingers crossed

xcubed: Your plan 'B' The most likely

Thanks for your help guys

8020 posts

Uber Geek
+1 received by user: 386


  Reply # 305684 9-Mar-2010 13:35
Send private message

Let us know how it goes

1874 posts

Uber Geek
+1 received by user: 83


  Reply # 305717 9-Mar-2010 16:49
Send private message

Windows 7 is rather good at this type of thing. Last week i upgraded my work pc. Time was short so i thought i would be brutal on it and see how it went, if it didnt work then i would reinstall everything.
Went from a Amd 939 board + 3500+ processor, to a new AM3 board + phenomx4 955, twice the ram, new graphics card etc. Ripped old parts out, new parts in. fired it up. Windows 7 booted, installed all the drivers (without prompting me once) and i was up and running within 30 minutes of me shutting down my pc to take the bits out.
Was rather impressed to say the least. Although this is not quite the same, i see no problem for windows 7 at all, as long as it sees your raid controller.

440 posts

Ultimate Geek
+1 received by user: 104

  Reply # 306485 12-Mar-2010 09:32
Send private message

Plan A worked... mostly

I recovered my OS to the raid drive (loading the raid drivers) it worked well.

Apart from a problem with the activation. It says it need to be activated again. Internet activation doesn't work and when you click on activate by phone it has an error and will not bring up phone numbers or the 25digit prod code. Bugger!

Looks like i'll have to do a clean install :-|

187 posts

Master Geek

  Reply # 306496 12-Mar-2010 09:47
Send private message

Have you tried to 'change the product key" and then re-activate, I have had this occur on over 50 volume license machines.

440 posts

Ultimate Geek
+1 received by user: 104

  Reply # 306504 12-Mar-2010 09:54
Send private message

Yes, but to the same product key. Has same error. I think it was 0x8000048 it seemed to be unknown

I also tried a resetting the licence file by
Stopping the software protection platform service
renaming tokens.dat
and restarting the service
it recreated the file, but had the same error

I could try a different product code?

Update: All fixed and working... after a few error messages it gave me the install code and it activated via phone. Fingers crossed it stays like that

Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:

Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:

Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:

News »

New Zealand hits peak broadband data
Posted 18-Jan-2018 12:21

Amazon Echo devices coming to New Zealand early February 2018
Posted 18-Jan-2018 10:53

$3.74 million for new electric vehicles in New Zealand
Posted 17-Jan-2018 11:27

Nova 2i: Value, not excitement from Huawei
Posted 17-Jan-2018 09:02

Less news in Facebook News Feed revamp
Posted 15-Jan-2018 13:15

Australian Government contract awarded to Datacom Connect
Posted 11-Jan-2018 08:37

Why New Zealand needs a chief technology officer
Posted 6-Jan-2018 13:59

Amazon release Silk Browser and Firefox for Fire TV
Posted 21-Dec-2017 13:42

New Chief Technology Officer role created
Posted 19-Dec-2017 22:18

All I want for Christmas is a new EV
Posted 19-Dec-2017 19:54

How clever is this: AI will create 2.3 million jobs by 2020
Posted 19-Dec-2017 19:52

NOW to deploy SD-WAN to regional councils
Posted 19-Dec-2017 19:46

Mobile market competition issues ComCom should watch
Posted 18-Dec-2017 10:52

New Zealand government to create digital advisory group
Posted 16-Dec-2017 08:47

Australia datum changes means whole country moving 1.8 metres north-east
Posted 16-Dec-2017 08:39

Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.

Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.