Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


4465 posts

Uber Geek
+1 received by user: 884

Moderator
Trusted
Lifetime subscriber

Topic # 59291 1-Apr-2010 01:18
Send private message

I've had a problem for a while that I've only now had the time to look into.

My WHS has an Athlon X2 64 5000+ CPU.   Quite often one of the cores in the CPU will just start working overtime and max its performance.  The other core stays at normal usage. 

Nothing shows in the processes list that stands out as using any of the CPU, and memory usage is pretty standard too.  When this happens my RDP access to the server slows to a crawl, responsiveness of applications on the server slows (eg browsing windows explorer).  The WHS console is not running when this happens.  

The only computers connected to the WHS are a Mac mini running OSX, also running Plex that accesses some shared video folders on the WHS.  When this happens the access to the folder shares slows and any videos that are playing time out and stop playing.  I then can't start them again until such time as the CPU comes back to normal, usually 5-10 minutes later.

There are no other applications running in the taskbar or the background.  I suspect it has to do with folder duplication, as I can hear some disk access while it's happening. I have about 80GB free of a 4.5TB server storage pool.

I've installed the AMD processor drivers but this made no difference, all Windows updates are applied, and all other drivers are up to date.   

There's no real regularity to the timing of this, just seems to do it whenever it's most inconvenient :)

Anyone out there have any ideas what might be causing this?  Or how I can investigate the processes further - beyond the standard Task Manager list that doesn't seem to be giving any clues away?  

Here's a screenshot:

 

View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2


4465 posts

Uber Geek
+1 received by user: 884

Moderator
Trusted
Lifetime subscriber

  Reply # 313682 1-Apr-2010 01:53
Send private message

CtrlAltElite: Weird, so lets get this straight. The task manager is saying your CPU is on full load


Correction, only one core of the two is on full load, and only now and then.  I doubt it's viral or malware, but I'll check.  I've just found a couple of older services that i no longer use so I've disabled those for now to test this out. 



4465 posts

Uber Geek
+1 received by user: 884

Moderator
Trusted
Lifetime subscriber

  Reply # 313689 1-Apr-2010 02:04
Send private message

Cool thanks for the info, will have a read over breakfast tomorrow :)

283 posts

Ultimate Geek
+1 received by user: 2


  Reply # 313737 1-Apr-2010 09:45
Send private message

Can you post a screenshot of the processes tab when this is happening, remember th click the Show All Processes button.  I have not seen a machine where cpu usage is high, but nothing showing in processes.  Kernel cpu usage?

BDFL - Memuneh
60768 posts

Uber Geek
+1 received by user: 11659

Administrator
Trusted
Geekzone
Lifetime subscriber

  Reply # 313740 1-Apr-2010 09:50
Send private message

This could possibly be disc ativity related. I've noticed that when adding lots of files to the WHS (which I don't anymore since it's all there now) everything would get really slow. I suspect the balance process (the one that copies files across the drives for those duplicated folders) might be chewing some CPU calculating where to put the duplicate files - and where to move existing files to.

Then obviously there's the actual I/O operations and the whole server might get really slow.

As I said this is something that happens when either a) you are adding a lot of new files or b) the storage space is almost full and you add new large files, that require a lot of small files to be moved around.

You should just let it do its thing for a couple of days... Then wait and see. And I am using a P4 on a NVIDIA platform motherboard on my WHS.







4465 posts

Uber Geek
+1 received by user: 884

Moderator
Trusted
Lifetime subscriber

  Reply # 313781 1-Apr-2010 11:12
Send private message

mikerussellnz: Can you post a screenshot of the processes tab when this is happening, remember th click the Show All Processes button.  I have not seen a machine where cpu usage is high, but nothing showing in processes.  Kernel cpu usage?


Will do tonight if/when it happens. 



4465 posts

Uber Geek
+1 received by user: 884

Moderator
Trusted
Lifetime subscriber

  Reply # 313782 1-Apr-2010 11:13
Send private message

freitasm: This could possibly be disc ativity related. I've noticed that when adding lots of files to the WHS (which I don't anymore since it's all there now) everything would get really slow. I suspect the balance process (the one that copies files across the drives for those duplicated folders) might be chewing some CPU calculating where to put the duplicate files - and where to move existing files to.

Then obviously there's the actual I/O operations and the whole server might get really slow.

As I said this is something that happens when either a) you are adding a lot of new files or b) the storage space is almost full and you add new large files, that require a lot of small files to be moved around.

You should just let it do its thing for a couple of days... Then wait and see. And I am using a P4 on a NVIDIA platform motherboard on my WHS.



Definitely not copying or moving files around, this happens when the WHS is largely idle.  I only notice it running files across the network, not actually moving them around or anything.  That's not to say that it isn't disk related, just not related to copying, moving, deleting large files. 

BDFL - Memuneh
60768 posts

Uber Geek
+1 received by user: 11659

Administrator
Trusted
Geekzone
Lifetime subscriber

  Reply # 313784 1-Apr-2010 11:21
Send private message

Just get one of the Sysinternals tools to keep an eye on disk activity and you will find out.




1725 posts

Uber Geek
+1 received by user: 342

Trusted

  Reply # 313795 1-Apr-2010 11:37
Send private message

As it may be disk related, there is a WHS plugin called SMART, or something like that, that monitors your HDD(s) health via the SMART HDD stats. It may show an impending failure.




My thoughts are no longer my own and is probably representative of our media-controlled government




4465 posts

Uber Geek
+1 received by user: 884

Moderator
Trusted
Lifetime subscriber

  Reply # 313796 1-Apr-2010 11:39
Send private message

SepticSceptic: As it may be disk related, there is a WHS plugin called SMART, or something like that, that monitors your HDD(s) health via the SMART HDD stats. It may show an impending failure.


Thanks, I've got that installed already, all drives are very healthy indeed.

1725 posts

Uber Geek
+1 received by user: 342

Trusted

  Reply # 313801 1-Apr-2010 11:52
Send private message

Running Lights Out ? There was a service that needed to be disabled.




My thoughts are no longer my own and is probably representative of our media-controlled government




4465 posts

Uber Geek
+1 received by user: 884

Moderator
Trusted
Lifetime subscriber

  Reply # 313802 1-Apr-2010 11:54
Send private message

SepticSceptic: Running Lights Out ? There was a service that needed to be disabled.


Lights out was installed but not running, I uninstalled it last night when I posted initially.  Also removed disabled Virtual Server services and uninstalled it.  

437 posts

Ultimate Geek
+1 received by user: 7

Trusted

  Reply # 313825 1-Apr-2010 12:31
Send private message

Hmm I read this and thought about my issues I have had with maxed cpu

You said you checked and this is prob not affecting you so just in case here is the details.

see Microsoft connect  and search for

searchindexer.exe and portfwd.exe (says resolved but its not) both have bugs logged for excess cpu





"The only way to learn some- thing is to do it"



4465 posts

Uber Geek
+1 received by user: 884

Moderator
Trusted
Lifetime subscriber

  Reply # 313829 1-Apr-2010 12:35
Send private message

Lipex666: Hmm I read this and thought about my issues I have had with maxed cpu

You said you checked and this is prob not affecting you so just in case here is the details.

see Microsoft connect  and search for

searchindexer.exe and portfwd.exe (says resolved but its not) both have bugs logged for excess cpu



Ahh that reminds me, I also uninstalled Windows Search 4.0 last night.  From memory it still occurred afterward, but I was tired so might need to double check.

2584 posts

Uber Geek
+1 received by user: 5

Mod Emeritus
Trusted
Lifetime subscriber

  Reply # 313830 1-Apr-2010 12:35
Send private message

I would suggest using sysinternals process tool next time it is happening. It will defiantly show you what is using those CPU cycles.

Also you did not confirm that the show all processes check box when it was happening?







Media centre PC - Case Silverstone LC16M with 2 X 80mm AcoustiFan DustPROOF, MOBO Gigabyte MA785GT-UD3H, CPU AMD X2 240 under volted, RAM 4 Gig DDR3 1033, HDD 120Gig System/512Gig data, Tuners 2 X Hauppauge HVR-3000, 1 X HVR-2200, Video Palit GT 220, Sound Realtek 886A HD (onboard), Optical LiteOn DH-401S Blue-ray using TotalMedia Theatre Power Corsair VX Series, 450W ATX PSU OS Windows 7 x64



4465 posts

Uber Geek
+1 received by user: 884

Moderator
Trusted
Lifetime subscriber

  Reply # 313831 1-Apr-2010 12:38
Send private message


Also you did not confirm that the show all processes check box when it was happening?


I did reply stating that I would check this tonight when/if it happens again. 

 1 | 2
View this topic in a long page with up to 500 replies per page Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Microsoft Dynamics 365 Business Central launches
Posted 10-Jul-2018 10:40


Spark completes first milestone in voice platform upgrade
Posted 10-Jul-2018 09:36


Microsoft ices heated developers
Posted 6-Jul-2018 20:16


PB Technologies charged for its extended warranties and warned for bait advertising
Posted 3-Jul-2018 15:45


Almost 20,000 people claim credits from Spark
Posted 29-Jun-2018 10:40


Cove sells NZ's first insurance policy via chatbot
Posted 25-Jun-2018 10:04


N4L helping TAKA Trust bridge the digital divide for Lower Hutt students
Posted 18-Jun-2018 13:08


Winners Announced for 2018 CIO Awards
Posted 18-Jun-2018 13:03


Logitech Rally sets new standard for USB-connected video conference cameras
Posted 18-Jun-2018 09:27


Russell Stanners steps down as Vodafone NZ CEO
Posted 12-Jun-2018 09:13


Intergen recognised as 2018 Microsoft Country Partner of the Year for New Zealand
Posted 12-Jun-2018 08:00


Finalists Announced For Microsoft NZ Partner Awards
Posted 6-Jun-2018 15:12


Vocus Group and Vodafone announce joint venture to accelerate fibre innovation
Posted 5-Jun-2018 10:52


Kogan.com to launch Kogan Mobile in New Zealand
Posted 4-Jun-2018 14:34


Enable doubles fibre broadband speeds for its most popular wholesale service in Christchurch
Posted 2-Jun-2018 20:07



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.