Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




1222 posts

Uber Geek
+1 received by user: 58


Topic # 59406 5-Apr-2010 14:21
Send private message

Under XP, all my games which require the tilde key (~) to be pressed to open the console are fine and the console opens.

The same games under Vista, the ~ button does not open the console.

I have an Acer Aspire 4520 laptop (vista home premium sp2), and have tried plugging in an external keyboard, with no joy.

Whats causing this issue, and how can it be fixed?

I have read a few things on the net I only vaguely understand, about going into regedit and editing something, but the thing they recommend to edit is absent. Its worth mentioning I am currently using an infrared MS keyboard, and my laptop has IR port (again I read something about IR drivers being the cause of the problem, and disabling certain drivers).

Create new topic
3290 posts

Uber Geek
+1 received by user: 209

Trusted

  Reply # 315264 6-Apr-2010 11:21
Send private message

I'm wondering if it's related to international keyboard? When you go to Notepad and type ~ what happens? Anything? What about ~ + n, do you get ñ?



1222 posts

Uber Geek
+1 received by user: 58


  Reply # 315274 6-Apr-2010 11:44
Send private message

thank you for your reply.

If I press the key in notepad by itself I get `

If I press shift and the key I get ~

During games it makes no difference any combination of the key by itself or with shift or capslock.

As for the ~ + n, do you mean pressing both at same time or do I have to do something else to do what your saying? If I just try push them simultaneously I get n` or `n.

 
 
 
 


3290 posts

Uber Geek
+1 received by user: 209

Trusted

  Reply # 315310 6-Apr-2010 13:39
Send private message

I just know that in some setups, you can type the international characters (like ?, ?, etc) by typing a modifier (i.e. ~, ') then the letter. So the modifier doesn't do anything on its own, it needs the second character but seems that's not your problem. Just an idea...

4305 posts

Uber Geek
+1 received by user: 85

Moderator
Trusted
Lifetime subscriber

  Reply # 315326 6-Apr-2010 14:08
Send private message

Have you checked your drivers are up to date, and compatible with vista? Have you tried older drivers,manufacturer and generic drivers also?



1222 posts

Uber Geek
+1 received by user: 58


  Reply # 315329 6-Apr-2010 14:16
Send private message

Drivers are Vista compatable, supplied by Acer when laptop was new.

Have tried removing them and use generic driver, no change.

"Built in keyboard" drivers have been updated and rolled back to older versions, etc and no change. External keyboard has been removed, and drivers removed, reinstalled with latest drivers, no change there.

6349 posts

Uber Geek
+1 received by user: 1106

Trusted
Lifetime subscriber

  Reply # 315353 6-Apr-2010 15:22
Send private message

What language is your keyboard set to? (I don't have a Vista machine here so I can't tell you exactly where to look).

bazzer was getting at using it as a "dead key". For example, with the keyboard set to Maori, typing "`" followed by "a" results in "ā". To get "`", you need to press it twice. If your keyboard is set to US then you shouldn't have this problem though!



1222 posts

Uber Geek
+1 received by user: 58


  Reply # 315361 6-Apr-2010 15:33
Send private message

I don't know where to check either, but via a roundabout way I found it set to EN English (New Zealand).

4305 posts

Uber Geek
+1 received by user: 85

Moderator
Trusted
Lifetime subscriber

  Reply # 315399 6-Apr-2010 17:18
Send private message

In the control panel, under Regional and Language settings, you can set what locality of keyboard you use.
Make sure it is set to, English (New Zealand) with US keyboard.



1222 posts

Uber Geek
+1 received by user: 58


  Reply # 315576 6-Apr-2010 23:24
Send private message

I see it is set to US keyboard, thanks for the directions.

Somebody thought the problem may lie with "text services and input languages" > "advanced key settings" > "change key sequence", but in my case the ` grave accent is not being used by that, so I guess that rules that out too.



1222 posts

Uber Geek
+1 received by user: 58


  Reply # 317354 12-Apr-2010 14:43
Send private message

$20 (via internet banking) to the person who can get it working.

4305 posts

Uber Geek
+1 received by user: 85

Moderator
Trusted
Lifetime subscriber

  Reply # 317374 12-Apr-2010 15:22
Send private message

What drivers does the MS keyboard use?

Have you tried uninstalling ALL infrared drivers, via the control panel, device manager, and then trying your game?
If that works, then try installing your MS infrared keyboard again.


EDIT: Uninstall the MS infrared drivers, and then try your game with a wired keyboard.


Another suggestion is to add " -console" without the quote marks, and with the space to the command line of the shortcuts.



1222 posts

Uber Geek
+1 received by user: 58


  Reply # 317567 12-Apr-2010 23:25
Send private message

Under Device manager keyboards I have:

-Launch manager
-Microsoft eHome MCIR 109 keyboard
-Microsoft eHome MCIR 109 keyboard
-Microsoft eHome MCIR keyboard
-Microsoft eHome MCIR keyboard
-Microsoft eHome MCIR Remote Control keyboard keys
-Microsoft eHome MCIR Remote Control keyboard keys.

Windows\system32\drivers\dkbfltr.sys
Windows\system32\drivers\i8042prt.sys
Windows\system32\drivers\kbdclass.sys
Windows\system32\drivers\kbdhid.sys
Windows\system32\kbd106.dll

The first one has the top 3 drivers, all have the 3rd and 4th, and only the 109 keyboards has the kbd106.dll

If I toast the PC right back to factory restore from 2 1/2 years ago, the tilde key still does not work in consoles with laptop keyboard, or any of 7 different external ones I have tried to plug in, which are corded, bluetooth, wireless, and Infrared.


4305 posts

Uber Geek
+1 received by user: 85

Moderator
Trusted
Lifetime subscriber

  Reply # 317933 13-Apr-2010 17:35
Send private message

And when you restore it back to the dark ages, do you also uninstall ALL of the infrared devices before trying again?

Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Geekzone Live »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.