I've been running 2 pc's with Windows 7 sp1 since 25/2 and hadn't noticed any issues, but I've finally got to the bottom of a problem with itunes/ipod touch 1G syncing music/video content and apps and sp1.

Added a new mp3 file to itunes and sync'ed - everything looked normal (sync messages saying copying file, etc) but now there was "No content" on the ipod touch music or videos. Have had this before and usually just a matter of syncing again, but it didn't work. Tried to update an app, but get a sync error message saying app wasn't signed. Reset ipod and restored - no difference.

Tried uninstalling/reinstalling all itunes related Apple s/w and still no progress. Tried again, with trashing the itunes library and restoring from a DVD backup. Now all the apps get the "wasn't signed" error when syncing. Tried earlier versions of itunes as I had upgraded to 10.2 recently. Bookmarks, photos and contacts were successfully synced.

I noticed that from itunes, I could browse the playlists on the ipod, so the music was actually there, but the ipod for some reason wasn't recognising it or that the sync was complete.

Have just uninstalled Wndows 7 sp1 and low and behold syncing works fine and all my music is back! It's taken a while but finally got there!