Geekzone: technology news, blogs, forums
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.

3 posts

Wannabe Geek

Topic # 9262 3-Sep-2006 07:18
Send private message

Hello - forgive me if I've raised this in the wrong forum.
I've seen a few references to similar problems but none seem to address my exact problem.
I am unable to use any of the suggested solutions.

I have a working disc drive , with a working USB / IDE disc box - I've used the box previously with other drives.
This drive is an old C drive I'm trying to copy the data from.

I have attached previous drives to this computer and USB pen drives no problem.
Though currently my pen drive assigns a drive letter but works intermittently when the disc box is attached!

I'm using XP home.

On attaching the USB box - the box is seen, the drive is seen - but no drive letter is assigned.
In disc manager it recognises the drive correctly - but says the drive is working fine - recognises FAT32 but no drive letter.
Heathy online active FAT32.
Under properties the volume is populated.

Right clicking on the drive to assign a drive letter is greyed out.
Using CMD - using diskpart - I can see the disc - but can not assign a letter or a volume.
It is not under list volume.

The disc box is a from - but I can find no other drivers.
Anyway - its worked in the past on this system with other hard drives.

I also tried attaching the same box to a different XP system - same result.

I'm sure I've had this problem in the past and I need to do something the equivalent of Mount - on a unix system.

Any ideas?

If it comes to the crunch I could just attach it as an extra IDE drive but I wanted the freedom of using the USB box.

Regards Andy

Create new topic
4310 posts

Uber Geek
+1 received by user: 152

Mod Emeritus
Lifetime subscriber

Reply # 45262 3-Sep-2006 12:21
Send private message

If the disk is being seen by the system then you should be able to manually assign a letter to it.

I havent used XP for a long time but im sure its the same as it is in Vista..

Go to Start > All Programs > Accessories > System Tools > Computer Management

Click on disk management and it should bring up a list of disks. Right click on your USB disk and select Change drive letter and paths.

Im sure thats how it works in XP, but if not try searching for the Microsoft Management Console and go from there.

Hope this helps. Someone else may be able to confirm if this is the XP way....

3 posts

Wannabe Geek

  Reply # 45311 4-Sep-2006 00:00
Send private message

Thanks for the reply but sorry - its not as easy as that - as I said in the first post - the majority of the right click menus are grey - grey and can not be used.
Assign a drive letter is not counted as a valid option for some reason.

For further clarity - ignore the bit about the pen drive not working - Its because its in MAC format that it can not be read.
It does have a drive letter.


4310 posts

Uber Geek
+1 received by user: 152

Mod Emeritus
Lifetime subscriber

Reply # 45312 4-Sep-2006 00:04
Send private message

Ah sorry for some reason I missed that bit.... that was a useless reply then.

I'm there will be somebody around here who has got some sort of answer....

3 posts

Wannabe Geek

  Reply # 45424 5-Sep-2006 09:42
Send private message

Guess its a case of Physician heal thy self.
If anyone is interested my problem is because the W98 C disc had Goback installed upon it.
The partition info type is type 44 - basically - it looks like a boot manager - windows does not recognise the type.

So you can either boot up goback and remove the goback programme - restore the partition type

Or you can use Powerquest free utility partedit32 from
Change the GoBack type 44 to Fat32 (type 0B).


1 post

Wannabe Geek

  Reply # 47187 30-Sep-2006 10:08
Send private message

You are a genious. I just got a hard disk enclosure, took a good hard drive out of a bad laptop, and could not figure out why no drive letter was being assigned. googled the problem, came across your post, and Shazam! it worked. When I saw GOBACK i knew that was the problem.

Thanks so much - you are a true GEEK!!!


Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:

Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:

Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:

News »

Targus set sights on enterprise and consumer growth in New Zealand
Posted 13-Aug-2018 13:47

Huawei to distribute nova 3i in New Zealand
Posted 9-Aug-2018 16:23

Home robot Vector to be available in New Zealand stores
Posted 9-Aug-2018 14:47

Panasonic announces new 2018 OLED TV line up
Posted 7-Aug-2018 16:38

Kordia completes first live 4K TV broadcast
Posted 1-Aug-2018 13:00

Schools get safer and smarter internet with Managed Network Upgrade
Posted 30-Jul-2018 20:01

DNC wants a safer .nz in the coming year
Posted 26-Jul-2018 16:08

Auldhouse becomes an AWS Authorised Training Delivery Partner in New Zealand
Posted 26-Jul-2018 15:55

Rakuten Kobo launches Kobo Clara HD entry level reader
Posted 26-Jul-2018 15:44

Kiwi team reaches semi-finals at the Microsoft Imagine Cup
Posted 26-Jul-2018 15:38

KidsCan App to Help Kiwi Children in Need
Posted 26-Jul-2018 15:32

FUJIFILM announces new high-performance lenses
Posted 24-Jul-2018 14:57

New FUJIFILM XF10 introduces square mode for Instagram sharing
Posted 24-Jul-2018 14:44

OPPO brings advanced technology to the smartphone market with new device
Posted 24-Jul-2018 09:20

Hawaiki Transpacific cable ready-for-service
Posted 20-Jul-2018 11:29

Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.

Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.