Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




240 posts

Master Geek


# 95466 5-Jan-2012 10:05
Send private message

OK, so I have a pc with 3 HDD's
I am running only a single OS Windows 7 Ultimate 64bit.

I swapped the 500gb HDD for a 3TB HDD  (I was naughty and did this while Windows was running)
These are NOT the Win7 Operating System Drive.

I have 2x 160GB HDD's
one of these is the Win7 OS HDD, the other is just a storage drive where I keep work.

I have had the built in Win7 Backup manager recording images of the 2 160GB drives onto the 3TB drive.
My last backup was 27/12/2011 (this might have been the day I unplugged the 500gb drive).

--------
Due to earthquakes etc in Chch, we had a power cut yesterday morning, and my UPS is obviously poked.
So my computer restarted, and now windows wont load.

What I have Done
I have done a Chkdisk on the OS drive, and that came back fine.
Also made the OS drive the 'Active' partition using diskpart
then tried rebuilding the MBR using bootrec commands.

No matter what I do, I cannot get the drive to boot.


What I think the problem is
After spending hours last night trying to sort this out.
I am pretty certain the 500GB hdd was where the MBR was located.  It is the only thing I can think is the problem.
I don't want to put the 500GB hdd back into my computer, I want it for external use to transfer files around.

Is there a way I can rebuild the MBR on my hdd, and make windows load from the OS drive?
This is literally driving me nuts... =/


Whats Next
I am about to use GParted, but not 100% certain if its going to work or not.
Has anyone come across this before?  Will it work?




Intel Core 2 Duo E6600, 4x 2GB Adata 1066+ DDR2, Sapphire HD4850 X2 2GB GDDR3 PCI-E Quad DVI, 1000w PSU & over 4TB HDD space, Windows 7 Ultimate 64bit
PS3 Slim


Create new topic
389 posts

Ultimate Geek

Subscriber

  # 564671 5-Jan-2012 10:37
Send private message

You could try booting off the windows CD and choose the repair option.

3469 posts

Uber Geek

Trusted
Lifetime subscriber

  # 564672 5-Jan-2012 10:39
Send private message

Sounds more like you've lost your Boot Configuration Data (BCD). You can rebuild this with a repair disk.

I had a similar sort of problem to this last year. A drive im my laptop failed - a different drive to which the OS was on, but the BCD was on it. I built up a repair disk from another computer in the house and had my laptop up and running again pretty quickly.

This may help: http://support.microsoft.com/kb/927392

 
 
 
 




240 posts

Master Geek


  # 564700 5-Jan-2012 11:11
Send private message

Yea BCD sounds about right.
But for some unknown reason its not letting me rebuild it.
Going to try Method 3 here
http://support.microsoft.com/kb/927391

Also, not quite sure, but if I load DiskPart should the disk/partition I made active previously, show after restarting?
Cos its not at all.  As if no disks are active.

And when I load the win7 boot dvd, no operating systems appear.

Gah, such a mission, and a friend of mine is having a similar problem in OZ.  So once I figure mine out, hopefully I can help them also *sigh*.




Intel Core 2 Duo E6600, 4x 2GB Adata 1066+ DDR2, Sapphire HD4850 X2 2GB GDDR3 PCI-E Quad DVI, 1000w PSU & over 4TB HDD space, Windows 7 Ultimate 64bit
PS3 Slim


3407 posts

Uber Geek


  # 564721 5-Jan-2012 11:53
Send private message

You can have a boot sector on 1 drive, booting from another.. as strange as it sounds (more common with newer BIOS that allow botting from HD* as long has 'hard drive' is selected in boot order) as the bootsec config file simply looks for driveX/PartitionX/ for the windows loader.

Chances are its been removed along with the other drive, and you will need to re-add one to the primary OS drive, and reconfigure the boot menu as stated.

You can do it from a Vista boot CD also, both use BOOTMGR instead of NTLDR.

New versions of Hirens (more legit from v14) have utils to mess with bootsectors and menus within a PE OS.

Alternate if you are brave is to GRUB the main drive, and add the chainloader for bootmgr from there.



240 posts

Master Geek


  # 564806 5-Jan-2012 14:14
Send private message

OK working now.

Did not even get to using other boot loaders or anything.
I did something someone suggested in a forum somewhere.

Start a new Install of Windows onto the same drive.  let it finish the copying files to hdd
Then cancel the install.
Reboot and load DVD Installer again, then reload a previous restore point.
Then I rebooted and loaded the DVD again, using the auto repair startup option

After doing the repair startup twice, everything is working.

Yay!

and holy cow, that was just annoying.




Intel Core 2 Duo E6600, 4x 2GB Adata 1066+ DDR2, Sapphire HD4850 X2 2GB GDDR3 PCI-E Quad DVI, 1000w PSU & over 4TB HDD space, Windows 7 Ultimate 64bit
PS3 Slim


Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Chorus to launch Hyperfibre service
Posted 18-Nov-2019 15:00


Microsoft launches first Experience Center worldwide for Asia Pacific in Singapore
Posted 13-Nov-2019 13:08


Disney+ comes to LG Smart TVs
Posted 13-Nov-2019 12:55


Spark launches new wireless broadband "Unplan Metro"
Posted 11-Nov-2019 08:19


Malwarebytes overhauls flagship product with new UI, faster engine and lighter footprint
Posted 6-Nov-2019 11:48


CarbonClick launches into Digital Marketplaces
Posted 6-Nov-2019 11:42


Kordia offers Microsoft Azure Peering Service
Posted 6-Nov-2019 11:41


Spark 5G live on Auckland Harbour for Emirates Team New Zealand
Posted 4-Nov-2019 17:30


BNZ and Vodafone partner to boost NZ Tech for SME
Posted 31-Oct-2019 17:14


Nokia 7.2 available in New Zealand
Posted 31-Oct-2019 16:24


2talk launches Microsoft Teams Direct Routing product
Posted 29-Oct-2019 10:35


New Breast Cancer Foundation app puts power in Kiwi women's hands
Posted 25-Oct-2019 16:13


OPPO Reno2 Series lands, alongside hybrid noise-cancelling Wireless Headphones
Posted 24-Oct-2019 15:32


Waikato Data Scientists awarded $13 million from the Government
Posted 24-Oct-2019 15:27


D-Link launches Wave 2 Unified Access Points
Posted 24-Oct-2019 15:07



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.