Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




172 posts

Master Geek
+1 received by user: 27


Topic # 220211 31-Jul-2017 17:42
Send private message quote this post

had to reboot one of my servers and notice this in the log

 

 

 

[http2:warn] [pid 2139] AH10034: The mpm module (prefork.c) is not supported by mod_http2. The mpm determines how things are processed in your server. HTTP/2 has more demands in this regard and the currently selected mpm will just not do. This is an advisory warning. Your server will continue to work, but the HTTP/2 protocol will be inactive.

 

couldnt find a lot about it on google but it has some thing to do with mpm_prefork being old and doesnt work with http2

 

 

 

so it there a mpm_prefork alternative i can try ??


Create new topic
12870 posts

Uber Geek
+1 received by user: 2111

Trusted
Subscriber

  Reply # 1834505 31-Jul-2017 19:36
Send private message quote this post

If you don't get an answer here try Server Fault. I use Nginx for HTTP/2 and it works fine. I also use CloudFlare, which does HTTP/2 automagically.





AWS Certified Solution Architect Professional, Sysop Administrator Associate, and Developer Associate
TOGAF certified enterprise architect
Professional photographer




172 posts

Master Geek
+1 received by user: 27


  Reply # 1834621 1-Aug-2017 00:28
Send private message quote this post

found this , after doing this the server is running ok

 

 

 

 

 

Troubleshooting

 

Apache 2.4.27, HTTP/2 not supported in prefork

 

Starting from Apache 2.4.27, the Apache MPM (Multi-Processing Module) prefork no longer supports HTTP/2. This will be indicated in your Apache error log as follows:
AH10034: The mpm module (prefork.c) is not supported by mod_http2. The mpm determines how things are processed in your server. HTTP/2 has more demands in this regard and the currently selected mpm will just not do. This is an advisory warning. Your server will continue to work, but the HTTP/2 protocol will be inactive.

 

To fix this, select a different MPM: event or worker. We highly recommend you to use the event prefork.
If you are using PHP, it is likely that PHP is integrated to Apache via the mod_php module, which requires the prefork MPM. If you switch out from preform MPM, you will need to use PHP as FastCGI. To switch to php-fpm, you can do as folllwing. Please note that this assumes you have PHP installed from ondrej/php repository on Ubuntu. The PHP package names could be different in other repositories. Change package name and apt-get commands to match your PHP vendor and package manager.
apachectl stop
apt-get install php7.1-fpm # Install the php-fpm from your PHP repository. This package name depends on the vendor.
a2enmod proxy_fcgi setenvif
a2enconf php7.1-fpm # Again, this depends on your PHP vendor.
a2dismod php7.1 # This disables mod_php.
a2dismod mpm_prefork # This disables the prefork MPM. Only one MPM can run at a time.
a2enmod mpm_event # Enable event MPM. You could also enable mpm_worker.
apachectl start


 
 
 
 




172 posts

Master Geek
+1 received by user: 27


  Reply # 1835201 1-Aug-2017 19:51
Send private message quote this post

notice that after installing php7.1-fpm id f***ed up my php scripts and wordpress

 

since php needs mpm_prefork just have to roll back to the last backup and

 

just wait for a fix or patch


12870 posts

Uber Geek
+1 received by user: 2111

Trusted
Subscriber

  Reply # 1835219 1-Aug-2017 20:25
Send private message quote this post

I had trouble with PHP 7 as well




AWS Certified Solution Architect Professional, Sysop Administrator Associate, and Developer Associate
TOGAF certified enterprise architect
Professional photographer


6393 posts

Uber Geek
+1 received by user: 2832

Moderator
Trusted
Subscriber

  Reply # 1835232 1-Aug-2017 20:50
Send private message quote this post

You don't need to at all - Wordpress supports PHP7. With PHP7-FPM you should be using the event MPM which is the configuration I've got on my servers:

 

a2dismod php7
a2dismod mpm_prefork
a2enmod mpm_event
a2enconf php7.0-fpm

 

Ensure you have not got mod_php enabled and have enabled the php-fpm configuration in your Apache configuration.

 

Edit: It'll also help if you post what you're running as your operating system.





Michael Murphy | https://murfy.nz
Want to be with an epic ISP? Want $20 to join them too? Well, use this link to sign up to BigPipe!
The Router Guide | Electric KiwiCommunity UniFi Cloud Controller | Ubiquiti Edgerouter Tutorial




172 posts

Master Geek
+1 received by user: 27


  Reply # 1836756 3-Aug-2017 18:03
Send private message quote this post

ubuntu 16.04

 

Apache version 2.4.27 from http://ppa.launchpad.net/ondrej/apache2/ubuntu xenial main

 

php 5.6 from http://ppa.launchpad.net/ondrej/php/ubuntu xenial main

 

 


Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

D-Link NZ launches professional Wireless AC Wave 2 Access Point for businesses
Posted 17-Aug-2017 19:25


Garmin introduces the Rino 700 five-watt two-way handheld radio
Posted 17-Aug-2017 19:04


Garmin announces the Foretrex 601 and Foretrex 701 Ballistic Edition for outdoor and tactical use
Posted 17-Aug-2017 19:02


Brightstar announces new distribution partnership with Samsung Knox platform in Australia
Posted 17-Aug-2017 17:07


Free gig-enabled WiFi network extends across Dunedin
Posted 17-Aug-2017 17:04


Samsung expands with connect Gear S3 Frontier
Posted 17-Aug-2017 15:55


Fact-checking Southern Cross Next cable is fastest to USA
Posted 17-Aug-2017 13:57


Thurrott says Microsoft Surface is dead last for reliability
Posted 16-Aug-2017 15:19


LibreOffice 5.4 works better with Microsoft Office files
Posted 16-Aug-2017 13:32


Certus launches Cognition
Posted 14-Aug-2017 09:31


Spark adds Cambridge, Turangi to 4.5G network
Posted 10-Aug-2017 17:55


REANNZ network to receive ongoing Government funding through to 2024
Posted 10-Aug-2017 16:05


Chorus backhaul starts with 2degrees
Posted 10-Aug-2017 15:49


New Zealanders cool on data analytics catching benefit fraud
Posted 10-Aug-2017 09:56


New Zealanders wary of wearable biometrics: Unisys
Posted 9-Aug-2017 09:39



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.