Geekzone: technology news, blogs, forums
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.

382 posts

Ultimate Geek

# 261821 16-Dec-2019 20:05
Send private message quote this post

 Hi Ive been trying to get my data off one drive and onto another using this command and variants;
 sudo tar -cvpzf alsmain2018.tar.gz --exclude=alsmain2018.tar.gz --exclude-caches --one-file-system /media/alistair/USB450G/backintime/alsmain/ --exclude-from <(find /media/alistair/USB450G/backintime/alsmain/ -size +100M)
 which results in:
 tar: /dev/fd/63: No such file or directory
 tar: Error is not recoverable: exiting now


 Ive tried removing last directory backslash and if I run the command: sudo find /media/alistair/USB450G/backintime/alsmain/ -size +100M
 find works as expected, finding files over 100m.


 If I run command: sudo tar -cvpzf alsmain2018.tar.gz --exclude=alsmain2018.tar.gz --exclude-caches --one-file-system /media/alistair/USB450G/backintime/alsmain/
 backup works no errors.




Can anyone figure why my find is wrong?
 Thanks kindly, Al.

Create new topic
645 posts

Ultimate Geek

  # 2376618 16-Dec-2019 20:44
Send private message quote this post

Most of the examples I’ve seen run find and pipe (or use -exec) the output to the tar command:

#include <standard.disclaimer>

92 posts

Master Geek


  # 2376787 17-Dec-2019 09:47
Send private message quote this post

It's the combination of sudo and the <( ) construct.


$ cat <(echo foo)




$ sudo cat <(echo foo)


cat: /proc/self/fd/11: No such file or directory


You could run the find to a file in /tmp, then use that.


120 posts

Master Geek

  # 2376864 17-Dec-2019 11:32
One person supports this post
Send private message quote this post

In the command you use sudo elevates tar only. You cannot pipe data between processes running under different user IDs. You can try:


sudo sh -c 'sudo tar -cvpzf alsmain2018.tar.gz --exclude=alsmain2018.tar.gz --exclude-caches --one-file-system /media/alistair/USB450G/backintime/alsmain/ --exclude-from <(find /media/alistair/USB450G/backintime/alsmain/ -size +100M)'

382 posts

Ultimate Geek

  # 2377026 17-Dec-2019 13:46
Send private message quote this post

Thanks, that was it, sudo was doing the damage.

Create new topic

Twitter and LinkedIn »

Follow us to receive Twitter updates when new discussions are posted in our forums:

Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:

Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:

News »

Netflix releases 21 Studio Ghibli works
Posted 22-Jan-2020 11:42

Vodafone integrates eSIM into device and wearable roadmap
Posted 17-Jan-2020 09:45

Do you need this camera app? Group investigates privacy implications
Posted 16-Jan-2020 03:30

JBL launches headphones range designed for gaming
Posted 13-Jan-2020 09:59

Withings introduces ScanWatch wearable combining ECG and sleep apnea detection
Posted 9-Jan-2020 18:34

NZ Police releases public app
Posted 8-Jan-2020 11:43

Suunto 7 combine sports and smart features on new smartwatch generation
Posted 7-Jan-2020 16:06

Intel brings innovation with technology spanning the cloud, network, edge and PC
Posted 7-Jan-2020 15:54

AMD announces high performance desktop and ultrathin laptop processors
Posted 7-Jan-2020 15:42

AMD unveils four new desktop and mobile GPUs including AMD Radeon RX 5600
Posted 7-Jan-2020 15:32

Consolidation in video streaming market with Spark selling Lightbox to Sky
Posted 19-Dec-2019 09:09

Intel introduces cryogenic control chip to enable quantum computers
Posted 10-Dec-2019 21:32

Vodafone 5G service live in four cities
Posted 10-Dec-2019 08:30

Samsung Galaxy Fold now available in New Zealand
Posted 6-Dec-2019 00:01

NZ company oDocs awarded US$ 100,000 Dubai World Expo grant
Posted 5-Dec-2019 16:00

Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.

Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron

Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.