Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


gzt

gzt

11670 posts

Uber Geek

Lifetime subscriber

#109179 14-Sep-2012 13:09
Send private message

From time to time my iMac refuses to eject a dvd on request. After some classic mechanical servo confusion noise it will start playing the dvd again instead of ejecting it.

Usually it will give the dvd back to me after a while. This time it may be planning to keep it.

Human intervention is required. I have opened the case before. No problem with that procedure (thanks jofizz!).

From there any tips on manually ejecting the dvd from the drive?

Since I'm going in anyway - any tips on effecting a potential temporary repair to the eject sequence?

Create new topic
gehenna
6634 posts

Uber Geek

Moderator
Trusted
Lifetime subscriber

  #686021 14-Sep-2012 13:51
Send private message

When you boot your Mac from powered off (or reboot for that matter) click and hold the mouse button while it starts (or the trackpad button). This will eventually force eject the optical drive contents.

Following that you can reset the SMC controller to see if it fixes the issue long term.  

josephhinvest
www.hinve.st
1344 posts

Uber Geek

Trusted
Subscriber

  #686023 14-Sep-2012 13:52
Send private message

If you do need to remove the drive, it's not that hard to get a disk or foreign object out.
I would normally just remove the top part of the optical drive, usually four small Philips screws. You may have to remove mounting brackets etc first. Then you can just partially lift off the drive top cover and pop the disk off the spindle.
Take care not to move and gears and mechanisms of course.
Unfortunately I don't really have any suggestions as to how to prevent it happening again.

I guess you've tried the easy stuff... Rebooting holding down the mouse button, checked to see whether disk utility will eject the disk?

Cheers,
Joseph

 
 
 
 


gzt

gzt

11670 posts

Uber Geek

Lifetime subscriber

  #686267 15-Sep-2012 00:10
Send private message

I had tried eject on start but not the mouse method. No difference.

This evening tried start and du > unmount > eject (and SMC) but no difference.

I'll get to removing the disk from the drive manually.

Maybe it is a malformed spindle hole on this particular dvd. More likely a worn drive component and the end of drive life.

It is an older machine (core2 2ghz) so given the silly cost of replacement optical internal I may just go external for a while if it continues to misbehave after extracting this particular disk.

gzt

gzt

11670 posts

Uber Geek

Lifetime subscriber

#686842 16-Sep-2012 21:06
Send private message

I got the dvd out this evening.

I removed the four small screws from the top of the drive cover. I levered the cover upwards slightly around the sides. It became obvious cover removal was restricted in part by (what I think was) a data cable pcb assembly screwed to the body of the drive.

Not a lot of room to work in there and it is packed in tightly. Instead of going further I decided to see if the drive was now happy to let the disc go without further work. Plugged in the machine and pressed the eject and I got the dvd back.

I replaced the screws and retested the insert and eject sequence. Works ok.

Inspecting the dvd there was a few icky bits on it. The asset label around the spindle hole had a few small air bubbles in it and was off centre. This might have been a contributor to a release problem.

I have put the machine back together and eject still working so far.

Thanks for your help!

Create new topic





News »

Nanoleaf enhances lighting line with launch of Triangles and Mini Triangles
Posted 17-Oct-2020 20:18


Synology unveils DS1621+ 
Posted 17-Oct-2020 20:12


Ingram Micro introduces FootfallCam to New Zealand channel
Posted 17-Oct-2020 20:06


Dropbox adopts Virtual First working policy
Posted 17-Oct-2020 19:47


OPPO announces Reno4 Series 5G line-up in NZ
Posted 16-Oct-2020 08:52


Microsoft Highway to a Hundred expands to Asia Pacific
Posted 14-Oct-2020 09:34


Spark turns on 5G in Auckland
Posted 14-Oct-2020 09:29


AMD Launches AMD Ryzen 5000 Series Desktop Processors
Posted 9-Oct-2020 10:13


Teletrac Navman launches integrated multi-camera solution for transport and logistics industry
Posted 8-Oct-2020 10:57


Farmside hits 10,000 RBI customers
Posted 7-Oct-2020 15:32


NordVPN starts deploying colocated servers
Posted 7-Oct-2020 09:00


Google introduces Nest Wifi routers in New Zealand
Posted 7-Oct-2020 05:00


Orcon to bundle Google Nest Wifi router with new accounts
Posted 7-Oct-2020 05:00


Epay and Centrapay partner to create digital gift cards
Posted 2-Oct-2020 17:34


Inseego launches 5G MiFi M2000 mobile hotspot
Posted 2-Oct-2020 14:53









Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.