Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


11465 posts

Uber Geek
+1 received by user: 3679

Trusted
Subscriber

Topic # 151033 11-Aug-2014 17:14
Send private message

I've posted about this before but the issue persists.

Often when opening a new link (say going from the front page to a story page on a news website) Safari just stops with the blue bar half way across. Sometimes if you come back later it has loaded and sometimes not. Ditto, sometimes if you refresh the page it loads second time, sometimes not.

Not all sites do it, and neither is it always the same site (although the NZ Herald site seems very prone).

It makes browsing very frustrating!

I have tried the common things such as restarting the VDSL modem (we are on VF naked), switching off plug-ins in Safari and even running Namebench to see if there were better DNS options.

Does anyone have any other ideas? I tried Chrome and that is sometimes better and sometimes the same, so it may in fact be a non-browser issue.





Create new topic
2467 posts

Uber Geek
+1 received by user: 667


  Reply # 1106621 11-Aug-2014 17:17
Send private message

I've noticed in the last week or so that safari will sometimes open a new tab from the GZ 'live' page and then just hang... though a refresh page ALWAYS resolved the page for me thereafter... (IOS7 - iPhone 4s)

dunno why, I just deal with it when it happens and move on myself...



11465 posts

Uber Geek
+1 received by user: 3679

Trusted
Subscriber

  Reply # 1106623 11-Aug-2014 17:21
Send private message

As an example. I clicked the link in the email that notified me of your reply.

I was able to open GZ in another tab and manually navigate to this page about 1 minute faster than the link opening!

My problem is primarily occurring on my iMac using Mavericks (latest release) - it does not seem to happen on my iPhone as much.





12597 posts

Uber Geek
+1 received by user: 5912

Trusted

  Reply # 1106638 11-Aug-2014 17:42
Send private message

I started having this issue with Safari on my iMac, tried all sorts of things but finally surrendered  I now use Chrome.




Mike
Retired IT Manager. 
The views stated in my posts are my personal views and not that of any other organisation.

 

 It's our only home, lets clean it up then...

 

Take My Advice, Pull Down Your Pants And Slide On The Ice!

 

 


gzt

9928 posts

Uber Geek
+1 received by user: 1493


  Reply # 1106653 11-Aug-2014 18:23
Send private message

Imho Safari = worst performing browser on OSX.

2995 posts

Uber Geek
+1 received by user: 1436


  Reply # 1106676 11-Aug-2014 19:05
Send private message

All my iOS devices seem to have this issue. Related? I thought it was just me but the latest update seems to have mucked up connectivity. Chrome is marginally better.




Always be yourself, unless you can be Batman, then always be the Batman



295 posts

Ultimate Geek
+1 received by user: 20


  Reply # 1106688 11-Aug-2014 19:40
Send private message

I've that issue as well previously on VF cable. try changing your dns (google dns) and that should fix it.
another option is to restart your machine in safe mode (this was a known issue with safari so slow to access sites and for some reason booting on safe mode then reboot resolves the issue.)

2635 posts

Uber Geek
+1 received by user: 688

Subscriber

  Reply # 1106696 11-Aug-2014 19:56
Send private message

FWIW - I have used Dolphin Browser on my iPad (and synced to my HTC One M7) for a couple of years. Works well - no issues - really like it.



11465 posts

Uber Geek
+1 received by user: 3679

Trusted
Subscriber

  Reply # 1106765 11-Aug-2014 22:04
Send private message

Chrizvi: I've that issue as well previously on VF cable. try changing your dns (google dns) and that should fix it.
another option is to restart your machine in safe mode (this was a known issue with safari so slow to access sites and for some reason booting on safe mode then reboot resolves the issue.)


Any DNS suggestions? I am using the two VF ones at the moment.

I'll try the safe mode idea too.







11465 posts

Uber Geek
+1 received by user: 3679

Trusted
Subscriber

  Reply # 1106768 11-Aug-2014 22:06
Send private message

scuwp: All my iOS devices seem to have this issue. Related? I thought it was just me but the latest update seems to have mucked up connectivity. Chrome is marginally better.


Yes it seems to be something that has become obvious in the last 6 months or so. Chrome is perhaps a bit better but not a whole lot. It's very frustrating: my internet connection speed has got much faster but the actual experience has got much slower!

It's similar to 4G on my iPhone: if I turn it on, the touch screen response becomes hopeless. Turn it off and it is straight back to normal!!





gzt

9928 posts

Uber Geek
+1 received by user: 1493


  Reply # 1106771 11-Aug-2014 22:12
Send private message

Geektastic:
Chrizvi: I've that issue as well previously on VF cable. try changing your dns (google dns) and that should fix it.
another option is to restart your machine in safe mode (this was a known issue with safari so slow to access sites and for some reason booting on safe mode then reboot resolves the issue.)


Any DNS suggestions? I am using the two VF ones at the moment.

I'll try the safe mode idea too.

Google Public DNS: 8.8.8.8 & 8.8.4.4.

6215 posts

Uber Geek
+1 received by user: 1027

Trusted
Lifetime subscriber

  Reply # 1106798 11-Aug-2014 22:51
Send private message

I've been using Safari as my primary browser for more than ten years and have not run into this. Are all of you using Vodafone (I'm not)?

533 posts

Ultimate Geek
+1 received by user: 40


  Reply # 1106813 12-Aug-2014 00:20
Send private message

I get fairly regularly on my iPad mini. Often requires a refresh to get things moving along. When I was using chrome i would occasionally have it occur and a refresh fixed it as well.

Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Microsoft Dynamics 365 Business Central launches
Posted 10-Jul-2018 10:40


Spark completes first milestone in voice platform upgrade
Posted 10-Jul-2018 09:36


Microsoft ices heated developers
Posted 6-Jul-2018 20:16


PB Technologies charged for its extended warranties and warned for bait advertising
Posted 3-Jul-2018 15:45


Almost 20,000 people claim credits from Spark
Posted 29-Jun-2018 10:40


Cove sells NZ's first insurance policy via chatbot
Posted 25-Jun-2018 10:04


N4L helping TAKA Trust bridge the digital divide for Lower Hutt students
Posted 18-Jun-2018 13:08


Winners Announced for 2018 CIO Awards
Posted 18-Jun-2018 13:03


Logitech Rally sets new standard for USB-connected video conference cameras
Posted 18-Jun-2018 09:27


Russell Stanners steps down as Vodafone NZ CEO
Posted 12-Jun-2018 09:13


Intergen recognised as 2018 Microsoft Country Partner of the Year for New Zealand
Posted 12-Jun-2018 08:00


Finalists Announced For Microsoft NZ Partner Awards
Posted 6-Jun-2018 15:12


Vocus Group and Vodafone announce joint venture to accelerate fibre innovation
Posted 5-Jun-2018 10:52


Kogan.com to launch Kogan Mobile in New Zealand
Posted 4-Jun-2018 14:34


Enable doubles fibre broadband speeds for its most popular wholesale service in Christchurch
Posted 2-Jun-2018 20:07



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.