When backing up my MBP and an iMac I use an external drive (image repository) but when attempting a back up today I had the following issue:

 

 

 

the drive wouldn't show up in finder, so I used disk utility but this only told me that the disk couldn't be repaired, however it did allow to view in finder.

 

Did a quick web search and found a suggestion to searched in terminal using diskutil info -all...this showed the drive but wasn't mounted as per below:

 

   Device Identifier:        disk2s2

 

   Device Node:              /dev/disk2s2

 

   Whole:                    No

 

   Part of Whole:            disk2

 

   Device / Media Name:      Image Repository

 

 

 

   Volume Name:              Image Repository

 

 

 

   Mounted:                  No

 

 

 

   File System Personality:  HFS+

 

   Type (Bundle):            hfs

 

   Name (User Visible):      Mac OS Extended

 

   Journal:                  Unknown (not mounted)

 

   Owners:                   Disabled

 

 

 

   Partition Type:           Apple_HFS

 

   OS Can Be Installed:      No

 

   Media Type:               Generic

 

   Protocol:                 USB

 

   SMART Status:             Not Supported

 

   Volume UUID:              322AE4BC-3614-3A82-BDF2-0D99FD225588

 

   Disk / Partition UUID:    F82E8B35-89EA-49A6-B21E-853F280283A9

 

 

 

   Total Size:               999.9 GB (999858069504 Bytes) (exactly 1952847792 512-Byte-Units)

 

   Volume Free Space:        0 B (0 Bytes) (exactly 0 512-Byte-Units)

 

   Device Block Size:        512 Bytes

 

 

 

   Read-Only Media:          No

 

   Read-Only Volume:         Not applicable (not mounted)

 

 

 

   Device Location:          External

 

   Removable Media:          No

 

 

 

This is where I need help - any suggestions??!!

 

Thanks

 

Maurice

 

ps. OS is El Capitan for both devices.