Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


688 posts

Ultimate Geek
+1 received by user: 15

Trusted

Topic # 58017 4-Mar-2010 14:52
Send private message

Did a speedtest and, aside from speeds being less than 1/20th what they usually are, noticed ping was 0ms:



Now I know this is not the best measure and is quite possibly higher but:  is 0ms technically possible under ideal conditions, or can it never be 0?  Can it even be 0 if we allow for rounding to the nearest ms?

Create new topic
1249 posts

Uber Geek
+1 received by user: 63


  Reply # 304441 4-Mar-2010 15:45
Send private message

0ms would most likely indicate a latency lower than 1ms that has been rounded down.
That would be possible.

An actual latency of 0ms would indicate something akin to teleportation.





rm *


536 posts

Ultimate Geek


  Reply # 304444 4-Mar-2010 15:47

I doubt it's exactly 0 (null), it may be <=0.49ms though. Uni's tend to have epic internet (and that Speedtest server must be extremely close, if not local).

209 posts

Master Geek
+1 received by user: 13

Trusted

  Reply # 304448 4-Mar-2010 15:56
Send private message

No, it's not strinctly possible, but rounded to the nearest ms it's very possible.


Speed of light 299,792,458 m/s
Speed in copper 75% approx
Speed in copper 224,844,344 m/s
Distance (1-way) 10 km
Distance (1-way) 10,000 m
Travel time 0.00 s
Travel time 0.04 ms

Packet size 64 B
Packet size 512 b
Line rate 10 Mbps
Line rate 10000000 bps
Serialisation delay 0.00 s
Serialisation delay 0.05 ms
1-way 0.10 ms
RTT 0.19 ms

I.e., for up to 10km and on a 10Mbps Ethernet, you'd expect  a minimum of 0.19ms round trip for 64byte packets. Actual latency could be higher, for various reasons, but given that processing speed on modern routers is microseconds per packet, you are not going to get above the .5ms needed to round to 1ms.

Note that ADSL imposes several ms of latency due to forward error correction, and cable somewhat less, so you should never see zero ms on current consumer broadband. You on the other hand appear to be fibre connected.
 

2260 posts

Uber Geek

Trusted

  Reply # 304459 4-Mar-2010 16:13
Send private message

Paulthagerous: Did a speedtest and, aside from speeds being less than 1/20th what they usually are, noticed ping was 0ms:



Now I know this is not the best measure and is quite possibly higher but:  is 0ms technically possible under ideal conditions, or can it never be 0?  Can it even be 0 if we allow for rounding to the nearest ms?


Nah not possible at the Uni here,

while we do have a 1gb link between campuses and to citylink
The new proxy that was implemented is caching it I think, as well as sharing the load, because when students come back, it gets owned!!!, using the mac Manual staff proxy I get(I'm using a PC):







I have moved across the ditch.  Now residing in Melbourne as a VOIP/Video Technical Trainer/Engineer. 



688 posts

Ultimate Geek
+1 received by user: 15

Trusted

  Reply # 304469 4-Mar-2010 16:42
Send private message

michaeln: No, it's not strinctly possible, but rounded to the nearest ms it's very possible.

I.e., for up to 10km and on a 10Mbps Ethernet, you'd expect  a minimum of 0.19ms round trip for 64byte packets. Actual latency could be higher, for various reasons, but given that processing speed on modern routers is microseconds per packet, you are not going to get above the .5ms needed to round to 1ms.

Note that ADSL imposes several ms of latency due to forward error correction, and cable somewhat less, so you should never see zero ms on current consumer broadband. You on the other hand appear to be fibre connected.
 


I assume that of the 1Gb, I have more than enough at any time.  It is my understanding it is connected directly to Citylink with Fibre all the way, and well less than 10km away.  Question now is, in real life with real life interferences etc is it likely to be under the 0.5ms threshold?

vinnieg:
Nah not possible at the Uni here,

while we do have a 1gb link between campuses and to citylink
The new proxy that was implemented is caching it I think, as well as sharing the load, because when students come back, it gets owned!!!, using the mac Manual staff proxy I get(I'm using a PC):





My only query would be this: if the speedtest was cached on a uni server, should my test not have recorded a blazing speed as opposed to the slowest I have ever seen it by at least 10 time? Or am I not getting the point?

1249 posts

Uber Geek
+1 received by user: 63


  Reply # 304472 4-Mar-2010 16:47
Send private message

It's possible that the cache's connection/s to the network is/are being saturated.




rm *




688 posts

Ultimate Geek
+1 received by user: 15

Trusted

  Reply # 304473 4-Mar-2010 16:51
Send private message

Will try tomorrow morning at 8 am while all the other students are still asleep lol. Hopefully can replicate ping with blazing speed

2260 posts

Uber Geek

Trusted

  Reply # 304475 4-Mar-2010 16:57
Send private message

I think it's something to do with speedtest being a really unreliable measure on a proxy server connection. Not exactly sure what the proxy is doing, but some things are going really weird. Think the speedtest pings have been up and down all day. I think a better test to try is probably the Slingshot NZ online speed test.. although i don't think it'll show the ping, since I think it's blocked on the proxy.

I think it still must be the cache causing hte false 0ms ping test...because everytime I turn it to manual it's got a ping of about 6+ or so, 4-10 is about right for the distance we are from Telstra. Not sure why speedtest.net does it, but running a tracert to Telstraclear brings back a ping of about 8ms for the first hop which sounds about right




I have moved across the ditch.  Now residing in Melbourne as a VOIP/Video Technical Trainer/Engineer. 

352 posts

Ultimate Geek


  Reply # 304476 4-Mar-2010 16:59
Send private message

maknz: I doubt it's exactly 0 (null), it may be <=0.49ms though.


a real geek might have said <0.5ms, in case their ping was 0.491ms

671 posts

Ultimate Geek
+1 received by user: 10


  Reply # 304482 4-Mar-2010 17:13
Send private message

is 0ms technically possible under ideal conditions, or can it never be 0?  Can it even be 0 if we allow for rounding to the nearest ms?


Just to spell it out, latency is the time taken for an internet signal to get from one computer to another. This is ALWAYS greater than 0 - after all, no information can move faster than the speed of light. 0ms is either rounding (very nearby server (unlikely) or cache) or a bug.

536 posts

Ultimate Geek


  Reply # 304487 4-Mar-2010 17:21

rvangelder:
maknz: I doubt it's exactly 0 (null), it may be <=0.49ms though.


a real geek might have said <0.5ms, in case their ping was 0.491ms


Could've, should've, would've.



688 posts

Ultimate Geek
+1 received by user: 15

Trusted

  Reply # 304490 4-Mar-2010 17:28
Send private message

Screeb:
is 0ms technically possible under ideal conditions, or can it never be 0?  Can it even be 0 if we allow for rounding to the nearest ms?


Just to spell it out, latency is the time taken for an internet signal to get from one computer to another. This is ALWAYS greater than 0 - after all, no information can move faster than the speed of light. 0ms is either rounding (very nearby server (unlikely) or cache) or a bug.


Figured as much but wanted to check :)

wjw

162 posts

Master Geek
+1 received by user: 3


  Reply # 304799 5-Mar-2010 15:12
Send private message

It's got to be a proxy issue. 

 

From a linux box on the above network I get:


PING alias.snap.net.nz (202.37.101.17) 56(84) bytes of data.
64 bytes from alias.snap.net.nz (202.37.101.17): icmp_seq=1 ttl=62 time=0.405 ms
64 bytes from alias.snap.net.nz (202.37.101.17): icmp_seq=2 ttl=62 time=0.351 ms
64 bytes from alias.snap.net.nz (202.37.101.17): icmp_seq=3 ttl=62 time=0.323 ms
64 bytes from alias.snap.net.nz (202.37.101.17): icmp_seq=4 ttl=62 time=0.360 ms
64 bytes from alias.snap.net.nz (202.37.101.17): icmp_seq=5 ttl=62 time=0.445 ms 

Windows ping just shows <1ms 

2260 posts

Uber Geek

Trusted

  Reply # 304811 5-Mar-2010 15:23
Send private message

Yeah it is, we started implementing Bluecoat early in Jan(Dec for the trials), seems to be working ok...




I have moved across the ditch.  Now residing in Melbourne as a VOIP/Video Technical Trainer/Engineer. 

1249 posts

Uber Geek
+1 received by user: 63


Reply # 304814 5-Mar-2010 15:30
Send private message

vinnieg: Yeah it is, we started implementing Bluecoat early in Jan(Dec for the trials), seems to be working ok...

Just don't let the license expire.




rm *


Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Hawaiki Transpacific cable ready-for-service
Posted 20-Jul-2018 11:29


Microsoft Dynamics 365 Business Central launches
Posted 10-Jul-2018 10:40


Spark completes first milestone in voice platform upgrade
Posted 10-Jul-2018 09:36


Microsoft ices heated developers
Posted 6-Jul-2018 20:16


PB Technologies charged for its extended warranties and warned for bait advertising
Posted 3-Jul-2018 15:45


Almost 20,000 people claim credits from Spark
Posted 29-Jun-2018 10:40


Cove sells NZ's first insurance policy via chatbot
Posted 25-Jun-2018 10:04


N4L helping TAKA Trust bridge the digital divide for Lower Hutt students
Posted 18-Jun-2018 13:08


Winners Announced for 2018 CIO Awards
Posted 18-Jun-2018 13:03


Logitech Rally sets new standard for USB-connected video conference cameras
Posted 18-Jun-2018 09:27


Russell Stanners steps down as Vodafone NZ CEO
Posted 12-Jun-2018 09:13


Intergen recognised as 2018 Microsoft Country Partner of the Year for New Zealand
Posted 12-Jun-2018 08:00


Finalists Announced For Microsoft NZ Partner Awards
Posted 6-Jun-2018 15:12


Vocus Group and Vodafone announce joint venture to accelerate fibre innovation
Posted 5-Jun-2018 10:52


Kogan.com to launch Kogan Mobile in New Zealand
Posted 4-Jun-2018 14:34



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.